You are not logged in.

#1 2020-10-16 16:14:27

daniel_shub
Member
Registered: 2012-06-21
Posts: 52

Screensaver not working with XFCE

I am running the XFCE DE on X11 logged in from lightdm and the standard kernel. The monitor is an LCD panel connected via HDMI to an ATI card and I am running the open source drivers (xf86-video-ati and mesa). Based on my parsing of pacman -Q | perl -ne 'print if /screen/ or /lock/', the only screen saver related packages I have installed appear to be xfce4-screensaver and light-locker. The only "oddity" of the setup is that it is a qemu virtual machine created with kvm/virsh with the ATI card passed through from a host that is also running Arch.

On the XFCE screen saver preferences page the screen saver is enabled and set to active when idle after 1 minute. Inhibiting the screen saver for fullscreen applications is not enabled. On the lock screen menu, the enable lock is enabled as well as lock screen with screensaver after 1 minute. Session status messages and user switching are also enabled. On the XFCE power manager display menu display power management is enabled with blanking after 1 minute, sleep after 2 and off after 3.

There is no DPMS configuration setup in /etc/X11 and xset q says

    Screen Saver:
      prefer blanking:  no    allow exposures:  no
      timeout:  60    cycle:  60

When I am not logged in the screen goes to sleep after a minute, but when I am logged in the screen never blanks, locks or sleeps. I am expecting the screen to blank, sleep and lock after a few minutes when I am logged in and not doing anything.

Where should I look to see what is going wrong?

Offline

Board footer

Powered by FluxBB