You are not logged in.

#1 2020-08-22 15:18:50

malyshkin-vitali
Member
Registered: 2020-08-22
Posts: 1

telegram-desktop sound bug.

Hello! package: telegram-desktop 2.3.0-2

Specs:
MB: Gigabyte GA-970A-UD3
CPU: AMD FX 8320
GPU: AMD RADEON RX 580 OC
RAM: 8GB DDR3
SSD: Crucial MX500 500 GB

System is up-to-date

Bug: with telegram-desktop 2.3.0-2 I receive support video calls and bug with sound unfortunately( When my contact call me and the call starts, sound in my PC starts cracking. The same bug I had with speech-dispatcher in Firefox, I just deleted speech-dispatcher and I haven't got any problem until I updated telegram.

The bug with Firefox:https://bugs.launchpad.net/ubuntu/+source/speech-dispatcher/+bug/1736222



LOGS telegram-desktop in terminal

[user@revenge ~]$ telegram-desktop
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
error: : cannot open
error: : cannot open
error: : cannot open
D/tgvoip: === Updating voip config ===
D/tgvoip: {"enable_vp8_encoder":true,"enable_vp8_decoder":true,"enable_vp9_encoder":true,"enable_vp9_decoder":true,"enable_h265_encoder":true,"enable_h265_decoder":true,"enable_h264_encoder":true,"enable_h264_decoder":true,"audio_frame_size":60,"jitter_min_delay_60":2,"jitter_max_delay_60":10,"jitter_max_slots_60":20,"jitter_losses_to_reset":20,"jitter_resync_threshold":0.5,"audio_congestion_window":1024,"audio_max_bitrate":20000,"audio_max_bitrate_edge":16000,"audio_max_bitrate_gprs":8000,"audio_max_bitrate_saving":8000,"audio_init_bitrate":16000,"audio_init_bitrate_edge":8000,"audio_init_bitrate_gprs":8000,"audio_init_bitrate_saving":8000,"audio_bitrate_step_incr":1000,"audio_bitrate_step_decr":1000,"use_system_ns":true,"use_system_aec":true,"force_tcp":false,"jitter_initial_delay_60":2,"adsp_good_impls":"(Qualcomm Fluence)","bad_call_rating":true,"use_ios_vpio_agc":false,"use_tcp":false,"audio_medium_fec_bitrate":20000,"audio_medium_fec_multiplier":0.1,"audio_strong_fec_bitrate":7000}
Invalid return value 0 for stream protocol
Invalid return value 0 for stream protocol
Invalid return value 0 for stream protocol
Invalid return value 0 for stream protocol
Invalid return value 0 for stream protocol
Invalid return value 0 for stream protocol
Invalid return value 0 for stream protocol
Invalid return value 0 for stream protocol

Please help! I very like telegram-desktop!

Last edited by malyshkin-vitali (2020-08-22 15:20:46)

Offline

#2 2020-10-17 21:55:48

avi9526
Member
Registered: 2015-05-15
Posts: 104

Re: telegram-desktop sound bug.

got same problem, seems it's related to webrtc library and psshhhh-audio

Check
https://wiki.archlinux.org/index.php/Pu … _crackling

/etc/pulse/default.pa

load-module module-udev-detect tsched=0

helped me

Last edited by avi9526 (2020-10-17 21:56:24)

Offline

Board footer

Powered by FluxBB