You are not logged in.

#1 2020-10-17 22:07:19

Tempest002
Member
Registered: 2020-08-26
Posts: 11

Disable Fade Animation from dwm/picom [SOLVED]

I use dwm as my standalone window manager and picom for compositing.
I want to disable the little fade-in and fade-out animation each time I open/close a window.

I think its a feature of picom, but found nothing in the config.

Its probably a really noob question but i found nothing really clear on google.
Anyone got a little hint?

Last edited by Tempest002 (2020-10-17 22:38:04)

Offline

#2 2020-10-17 22:17:51

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,447
Website

Re: Disable Fade Animation from dwm/picom [SOLVED]

picom doesn't fade windows in and out unless you've explicitly enabled it.  Please post your config and your xinitrc (or other file that starts picom).


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2020-10-17 22:21:02

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,399

Re: Disable Fade Animation from dwm/picom [SOLVED]

Did you try setting the "no-fading-openclose" option?

picom man page wrote:

--no-fading-openclose
Do not fade on window open/close.

https://jlk.fjfi.cvut.cz/arch/manpages/man/picom.1
https://wiki.archlinux.org/index.php/Pi … er_suspend

Offline

#4 2020-10-17 22:37:45

Tempest002
Member
Registered: 2020-08-26
Posts: 11

Re: Disable Fade Animation from dwm/picom [SOLVED]

thanks 2ManyDogs, this is exactly what i searched for the whole time. I knew I was constantly overlooking it.

Offline

Board footer

Powered by FluxBB