You are not logged in.

#1 2020-10-17 23:43:15

Registered: 2020-10-17
Posts: 2

Issue with UI of instantiated audio plugin.

My current DAW of choice is Harrison Mixbus v6.x. I have a problem with one of their Linux-built VST plugins called AVA-Vocal Flow. When I first tried to instantiate it, the UI would not render properly. It was simply a floating window with a blank grey background. Through Harrison support and their forums, and the Arch Wiki on Intel Graphics I found out that:

The plugin uses OpenGL.
3rd gen Intel Core i7 CPUs (like my 3770, Ivy Bridge) may have a problem with OpenGL.

The upshot was a suggestion to put an environment variable in /etc/environment to report a different version of OpenGL. To wit: MESA_GL_VERSION_OVERRIDE=4.2

This helped.  When I instantiate the plugin, the UI was now visible. BUT, it renders so large that the bottom 20% or so is off the screen, which makes the plugin functionally useless. The UI has two display sizes, but changing from one to the other has no effect.

Now, in the "Intel Graphics" Arch wiki page, there is a mention that the mesa update to v 17 "may break support for OpenGL 2.1 on third gen Intel GPUs." I didn't know if this was relevant to me, but I tried one of the fixes, putting some code into ~/.drirc, but this did nothing. I was flying blind here because I couldn't find out enough info on DRI to know what I was doing, I've only found some info on Wikipedia, and I had to create the .drirc file, as there wasn't one (nor was there an /etc/drirc file).

At this point, I decided that maybe my hardware was too old, and that maybe I needed to upgrade.

Before considering rebuilding my box, and as a test, I installed Ardour 6 and instantiated the plugin.
It worked just fine. It was properly sized, and I could pick either of the sizing options and it displayed perfectly.

Is there anything else I can try?
Is this an application specific problem in the way that Mixbus is displaying the plugin?


Board footer

Powered by FluxBB