You are not logged in.

#1 2020-10-18 04:05:57

Sffred
Member
Registered: 2020-08-30
Posts: 26

[Solved] VMW won't work on linux 5.9.1- unable to install module

After upgrading to linux 5.9.1, vmware doesn't work any more. I have tried reinstalling vmware-workstation, and get this message:

(3/6) Install DKMS modules
==> dkms install --no-depmod -m vmware-workstation -v 16.0.0_16894299 -k 5.9.1-arch1-1
==> depmod 5.9.1-arch1-1
==> Unable to install module vmware-workstation/16.0.0_16894299 for kernel 5.8.8-arch1-1: Missing kernel headers.

It seems that there's issue relating with the kernel.

Last edited by Sffred (2020-10-25 02:25:17)

Offline

#2 2020-10-18 06:06:53

katoitalia
Member
Registered: 2020-10-18
Posts: 7

Re: [Solved] VMW won't work on linux 5.9.1- unable to install module

are you booting into 5.9.1 ? try

uname -r

and if you are still booting into 5.8.8 change your bootloader accordingly

Last edited by katoitalia (2020-10-18 06:07:58)

Offline

#3 2020-10-21 21:54:03

Lostboy
Member
Registered: 2020-10-21
Posts: 1

Re: [Solved] VMW won't work on linux 5.9.1- unable to install module

I fixed a similar issue by doing the following:
Remove current Vmware Workstation package
Download and install https://www.archlinux.org/packages/core … x-headers/
Reinstall https://aur.archlinux.org/packages/vmware-workstation/
Reboot

Offline

#4 2020-10-22 04:52:15

Sffred
Member
Registered: 2020-08-30
Posts: 26

Re: [Solved] VMW won't work on linux 5.9.1- unable to install module

I got the solution from archlinux-cn telegram group.

Use

$ ls /usr/lib/modules

to see if there are redundant folders, for example, you only installed the 5.9.1 kernel but there's a directory named 5.8.8-arch1-1, simply omit it and reinstall the vmware-workstation package.

Offline

Board footer

Powered by FluxBB