You are not logged in.

#1 2020-10-18 06:53:33

zw963
Member
Registered: 2018-06-18
Posts: 117

Kibana depend on nodejs 10.22.1, but current installed is 14.14.0

Which cause kibana start failed since today (2020-10-18) update.


 ╰─ $ NODE_ENV=production /usr/bin/node --max-old-space-size=512 /usr/share/kibana/src/cli --config=/etc/kibana/kibana.yml
Kibana does not support the current Node.js version v14.14.0. Please use Node.js v10.22.1.

Offline

#2 2020-10-18 09:14:49

robt77
Member
From: Manchester
Registered: 2014-10-26
Posts: 17
Website

Re: Kibana depend on nodejs 10.22.1, but current installed is 14.14.0

This is a known issue - see below bug report

https://bugs.archlinux.org/task/67415?p … ing=kibana

The workaround is  apparently is to install nodejs-lts-erbium

https://stackoverflow.com/questions/627 … art-kibana

Online

#3 2020-10-18 13:00:05

zw963
Member
Registered: 2018-06-18
Posts: 117

Re: Kibana depend on nodejs 10.22.1, but current installed is 14.14.0

robt77 wrote:

This is a known issue - see below bug report

https://bugs.archlinux.org/task/67415?p … ing=kibana

The workaround is  apparently is to install nodejs-lts-erbium

https://stackoverflow.com/questions/627 … art-kibana

Infact, it not work.

NODE_ENV=production /usr/bin/node --max-old-space-size=512 /usr/share/kibana/src/cli --config=/etc/kibana/kibana.yml
Kibana does not support the current Node.js version v12.19.0. Please use Node.js v10.22.1.

thanks.

Offline

Board footer

Powered by FluxBB