You are not logged in.

#1 2020-10-13 15:13:48

Scryptus
Member
Registered: 2020-10-13
Posts: 2

Problem with libinput?

Hello !

My pointer does weird things without any touch on my USB mouse : click, paste a multiple times the last content in my clipboard, disappear under a window. And sometimes I can't use it. Finally the middle button rarely works.

Context

I reinstall Archlinux on my desktop in a new SSD. My previous installation (since 2013!) was became very very slow and bloated with a lot of AUR packages. I make the install without problems, I think. But when I start my Gnome Shell session, I have the performance described above.

My investigations
journalctl -e
gnome-shell[882]: libinput error: event5  - COOLER MASTER CM STORM INFERNO GAMING MOUSE: client bug: event processing lagging behind by 59ms, your system is too slow
libinput debug-events
-event1   DEVICE_ADDED     Power Button                      seat0 default group1  cap:k
-event0   DEVICE_ADDED     Power Button                      seat0 default group2  cap:k
-event3   DEVICE_ADDED     Logitech Logitech Illuminated Keyboard seat0 default group3  cap:k
-event4   DEVICE_ADDED     Logitech Logitech Illuminated Keyboard Consumer Control seat0 default group3  cap:kp scroll-nat
-event5   DEVICE_ADDED     COOLER MASTER CM STORM INFERNO GAMING MOUSE seat0 default group4  cap:p left scroll-nat scroll-button
-event6   DEVICE_ADDED     COOLER MASTER CM STORM INFERNO GAMING MOUSE Keyboard seat0 default group4  cap:k
-event7   DEVICE_ADDED     COOLER MASTER CM STORM INFERNO GAMING MOUSE Consumer Control seat0 default group4  cap:kp scroll-nat
-event5   POINTER_AXIS     +0.000s	vert 15.00/1* horiz 0.00/0 (wheel)
 event5   POINTER_AXIS     +2.551s	vert 15.00/1* horiz 0.00/0 (wheel)
 event5   POINTER_AXIS     +2.718s	vert 15.00/1* horiz 0.00/0 (wheel)
 event5   POINTER_AXIS     +2.875s	vert 15.00/1* horiz 0.00/0 (wheel)
 event5   POINTER_BUTTON   +5.449s	BTN_RIGHT (273) pressed, seat count: 1
 event5   POINTER_BUTTON   +5.551s	BTN_RIGHT (273) released, seat count: 0
 event5   POINTER_BUTTON   +6.433s	BTN_LEFT (272) pressed, seat count: 1
 event5   POINTER_BUTTON   +6.582s	BTN_LEFT (272) released, seat count: 0
 event5   POINTER_BUTTON   +9.703s	BTN_MIDDLE (274) pressed, seat count: 1
 event5   POINTER_BUTTON   +11.145s	BTN_SIDE (275) pressed, seat count: 1
event3  - Logitech Logitech Illuminated Keyboard: client bug: event processing lagging behind by 17ms, your system is too slow

Only the middle click (on the wheel) is not detected (the wheel works!).  And we can see the keyboard send an error message without any touch on it!

My hardware

Mouse : COOLER MASTER CM STORM INFERNO
Keyboard : Logitech Illuminated Keyboard
GPU : Radeon HD 7850 with ATI driver

Finally don't know if libinput is the problem or not... Thank you in advance for your help!


PS: I'm not fluent in English. If my message is not clear, tell me what I must explain with other words.

Offline

#2 2020-10-14 21:02:49

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 731

Re: Problem with libinput?

Search for "your system is too slow" on these forums. While I don't have this problem and wouldn't know if there's a solution, I do recall seeing at least a couple of threads last week with that exact same error so those posts would have the solution (if any).

Offline

#3 2020-10-29 09:15:22

Scryptus
Member
Registered: 2020-10-13
Posts: 2

Re: Problem with libinput?

I searched, but no one solves my problem. I found it's probably not libinput, the error is just a very common warning message.

My system is nearly unusable, because it does random copy/paste or click. For example, this message was a torture to write : close tab and lose the post, paste random words of this message in the field, etc.

Have you some suggestions to find a way to solve that ? Please...

Offline

#4 2020-10-29 13:45:03

seth
Member
Registered: 2012-09-03
Posts: 17,333

Re: Problem with libinput?

Do you have an unfancy $5 mouse/keyboard as replacement to test whether the device maybe actually just generates spurious events?
Also, sanity check: do you have a parallel windows installation?

Online

Board footer

Powered by FluxBB