You are not logged in.

#101 2020-08-20 01:07:44

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,544
Website

Re: Reflector reborn

Version 2020.8.19 adds systemd integration with a custom configuration file. See the man page, configuration file (/etc/xdg/reflector/reflector.conf) and wiki for details.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#102 2020-08-26 02:30:58

starquake
Member
Registered: 2013-05-03
Posts: 11

Re: Reflector reborn

Should the folder /etc/xdg/reflector and file /etc/xdg/reflector/reflector.conf already exist? Because on my system they don't. And the wiki make it sound like they are already there.

EDIT: Nevermind, it seems I had a mirror that didn't get updates for quite awhile and I had an old version of reflector.

Last edited by starquake (2020-08-26 02:49:28)

Offline

#103 2020-11-02 18:39:44

berturion
Member
Registered: 2018-06-19
Posts: 12

Re: Reflector reborn

Hello,
I have a problem with reflector.service. As root, when I run "systemctl start reflector.service", the service fails:

# systemctl start reflector.service
Job for reflector.service failed because the control process exited with error code.
See "systemctl status reflector.service" and "journalctl -xe" for details.

Here is the result of "systemctl status reflector.service" right after that:

# systemctl status reflector.service
● reflector.service - Refresh Pacman mirrorlist with Reflector.
     Loaded: loaded (/usr/lib/systemd/system/reflector.service; disabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Mon 2020-11-02 22:28:14 +04; 8min ago
       Docs: https://wiki.archlinux.org/index.php/Reflector
   Main PID: 451347 (code=exited, status=1/FAILURE)

Nov 02 22:28:14 sheldon systemd[1]: Starting Refresh Pacman mirrorlist with Reflector....
Nov 02 22:28:14 sheldon reflector[451375]: error: Permission denied
Nov 02 22:28:14 sheldon systemd[1]: reflector.service: Main process exited, code=exited, status=1/FAILURE
Nov 02 22:28:14 sheldon systemd[1]: reflector.service: Failed with result 'exit-code'.
Nov 02 22:28:14 sheldon systemd[1]: Failed to start Refresh Pacman mirrorlist with Reflector..

But, if I run (as root) :

reflector --verbose --latest 5 --sort rate --save /etc/pacman.d/mirrorlist

then, the mirrorlist file is written correctly.

I have another Arch linux machine and the service is working perfectly. I don't understand.

Can someone help me please (answer below)?

EDIT: I found! I didn't remember I played with the owner and permissions of /etc/pacman.d/mirrorlist. Permissions where set as 755 and the file was owned by my usual user. I changed the owner to root and modified the permissions to 644 on this file and it works now. It is strange though because the service is run by root so it should be able to overwrite the file anyway. Well, that's fine now.

Last edited by berturion (2020-11-02 18:46:48)

Offline

Board footer

Powered by FluxBB