You are not logged in.

#1 2020-11-03 15:15:00

iminotech
Member
Registered: 2020-11-01
Posts: 2

[SOLVED]Correctly partitioned FAT32 partition could not beusedasanESP

Hi all,
I bought Lenovo IdeaPad 5 Slim 14" (14ARE05) whose CPU is AMD Ryzen 7 4700U and tried installing Arch Linux to it, but encountered a problem while installing bootloader.

It seems like I did nothing wrong about partitioning my hard drive from seeing the output of some commands below:

# uname -a
Linux archiso 5.8.12-arch1-1 #1 SMP PREEMPT Sat, 26 Sep 2020 21:42:58 +0000 x86_64 GNU/Linux
# parted /dev/nvme1n1 print
Model: SAMSUNG MZALQ512HALU-000L2 (nvme)
Disk /dev/nvme1n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start    Size   File system  Name                  Flags
 1      1049kB  538MB  537MB  fat32        EFI system partition  boot, esp
 2      538MB   512GB  512GB  ext4          Linux filesystem

But all my attempts to install boot loader were ended in failure.

# mount /dev/nvme1n1p1 /mnt/boot
# mount /dev/nvme1n1p2 /mnt
# arch-chroot /mnt

# grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub
Installing for x86_64-efi platform.
grub-install: error: /boot doesn't look like an EFI partition.
# bootctl --path=/boot install
File system "/boot" is not a FAT EFI System Partition (ESP) file system.

What should I do for making /dev/nvme1n1p1 a valid ESP or is there other thing being wrong state?



Sorry for awkward English and any advice is much appreciated.

Last edited by iminotech (2020-11-03 15:29:30)

Offline

#2 2020-11-03 15:22:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,138

Re: [SOLVED]Correctly partitioned FAT32 partition could not beusedasanESP

Your mount order is wrong. You need to mount your root to /mnt and THEN mount the ESP to /mnt/boot for the setup to be logically properly carried over into the chroot.

Right now you mask whatever you had in /mnt/boot with what's in /mnt and if you recheck with mount from within the chroot you should notice that the ESP is not mounted to /boot

Last edited by V1del (2020-11-03 15:24:12)

Offline

#3 2020-11-03 15:28:11

iminotech
Member
Registered: 2020-11-01
Posts: 2

Re: [SOLVED]Correctly partitioned FAT32 partition could not beusedasanESP

Thank you very much for the advice.
I just have tried unmounting these partitions and re-mounted them in correct order then tried grub-install, ended in success.

Adding [SOLVED] label and thank you again smile

Offline

Board footer

Powered by FluxBB