You are not logged in.

#1 2020-10-30 18:03:10

Registered: 2007-02-05
Posts: 237

Syu broke chromium and accelerated graphics

I turned on my computer today and chromium doesn't load any pages, it doesn't seem to even resolve the address: I type something in the address field and hit enter, the animation on the tab starts spinning, chromium puts 100% load on one core and nothing happens.
Firefox still works fine and I just downloaded opera to test it, opera works as well.

Also when I start xcom2 through steam or WoW through wine the games seem to load, I hear the background music but it only shows a blank/black screen.

Yesterday everything worked flawlessly, today it does not.

Here is the list of packages I upgraded last night before I turned the computer off:

[2020-10-29T22:19:56+0100] [PACMAN] Running 'pacman -Syu'
[2020-10-29T22:19:56+0100] [PACMAN] synchronizing package lists
[2020-10-29T22:19:57+0100] [PACMAN] starting full system upgrade
[2020-10-29T22:20:36+0100] [ALPM] transaction started
[2020-10-29T22:20:36+0100] [ALPM] upgraded tzdata (2020b-2 -> 2020d-1)
[2020-10-29T22:20:36+0100] [ALPM] upgraded libass (0.14.0-2 -> 0.15.0-2)
[2020-10-29T22:20:36+0100] [ALPM] upgraded libva (2.9.0-1 -> 2.9.1-1)
[2020-10-29T22:20:36+0100] [ALPM] upgraded libbluray (1.2.0-3 -> 1.2.1-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded firefox (82.0-1 -> 82.0.2-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded gstreamer (1.18.0-1 -> 1.18.1-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded gst-plugins-base-libs (1.18.0-1 -> 1.18.1-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded gst-libav (1.18.0-1 -> 1.18.1-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded gst-plugins-bad-libs (1.18.0+54+gbd3532008-1 -> 1.18.1-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded libshout (1:2.4.3-3 -> 1:2.4.4-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded gst-plugins-good (1.18.0-1 -> 1.18.1-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded gst-plugins-bad (1.18.0+54+gbd3532008-1 -> 1.18.1-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded gst-plugins-base (1.18.0-1 -> 1.18.1-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded gst-plugins-ugly (1.18.0-1 -> 1.18.1-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded kdecoration (5.20.1-1 -> 5.20.2-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded libksysguard (5.20.1-1 -> 5.20.2-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded ksysguard (5.20.1-1 -> 5.20.2-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded lib32-expat (2.2.9-1 -> 2.2.10-1)
[2020-10-29T22:20:37+0100] [ALPM] upgraded oxygen (5.20.1-1 -> 5.20.2-1)
[2020-10-29T22:20:40+0100] [ALPM] upgraded python-cryptography (3.2-1 -> 3.2.1-1)
[2020-10-29T22:20:40+0100] [ALPM] upgraded python-kiwisolver (1.2.0-1 -> 1.3.0-1)
[2020-10-29T22:20:40+0100] [ALPM] upgraded python-urllib3 (1.25.10-1 -> 1.25.10-2)
[2020-10-29T22:20:40+0100] [ALPM] upgraded python-virtualenv (20.0.32-1 -> 20.0.33-1)
[2020-10-29T22:20:40+0100] [ALPM] upgraded python2-urllib3 (1.25.10-1 -> 1.25.10-2)
[2020-10-29T22:20:40+0100] [ALPM] upgraded qpdf (10.0.1-1 -> 10.0.2-1)

So I pacman -U all these packages back to yesterday's versions, reboot aaaaand the problems persist. chromium is not loading any pages and creates 100%cpu load, games only show a black screen.

Then I remembered the nvidia-455.28 deal with the 5.9 kernel. I mean yesterday 455.28 ran happily with  the 5.9 kernel on my machine (at least in terms of wow) but still, seems like it could be related. So I installed the lts kernel + headers + nvidia-lts, booted the lts kernel aaaaand: same deal! Chromium and WoW/xcom2 not working.

After that I uninstalled the lts and downgraded all nvidia-related packages I could find to 455.23 and downgraded the linux-kernel to 5.8.13

[2020-10-30T18:22:17+0100] [PACMAN] Running 'pacman -U /var/cache/pacman/pkg/linux-5.8.13.arch1-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/linux-headers-5.8.13.arch1-1-x86_64.pkg.tar.zst'
[2020-10-30T18:23:18+0100] [ALPM] transaction started
[2020-10-30T18:23:18+0100] [ALPM] downgraded opencl-nvidia (455.28-1 -> 455.23.04-1)
[2020-10-30T18:23:18+0100] [ALPM] downgraded egl-wayland (1.1.5-1 -> 1.1.4-3)
[2020-10-30T18:23:19+0100] [ALPM] downgraded nvidia-utils (455.28-1 -> 455.23.04-1)
[2020-10-30T18:23:19+0100] [ALPM-SCRIPTLET] If you run into trouble with CUDA not being available, run nvidia-modprobe first.
[2020-10-30T18:23:35+0100] [ALPM] downgraded cuda (11.1.0-2 -> 11.0.3-1)
[2020-10-30T18:23:35+0100] [ALPM] downgraded lib32-nvidia-utils (455.28-1 -> 455.23.04-1)
[2020-10-30T18:23:35+0100] [ALPM] downgraded lib32-opencl-nvidia (455.28-1 -> 455.23.04-1)
[2020-10-30T18:23:35+0100] [ALPM] downgraded libxnvctrl (455.28-1 -> 455.23.04-1)
[2020-10-30T18:23:36+0100] [ALPM] downgraded nvidia (455.28-7 -> 455.23.04-4)
[2020-10-30T18:23:36+0100] [ALPM] downgraded nvidia-settings

Then I booted that and of course, chromium and WoW/xcom2 are not working.

Wtf is going on here?

I was thinking, maybe my graphics card just happened to die betwenn yesterday and today. And while I can't really test that right now I find that somewhat unlikely plus that wouldn't explain what's going on with chromium.

Anyhow, I have no idea what's going on anymore, maybe someone here has an idea.

edit: nvidia-455.38 just hit my mirror, so I ran -Syu again.
Still the same: chromium not doing sh*t and WoW produces a blank screen.

But xcom2, into the breach, into the storm and shadow warrior (2015), all steam, run now. So right now it seems that it's down to that chromium thing and WoW.

Last edited by hybrid (2020-10-30 20:16:28)


#2 2020-11-03 15:31:51

Forum Moderator
Registered: 2012-10-16
Posts: 11,138

Re: Syu broke chromium and accelerated graphics

Can you actively repro this or are you immediately downgrading at the first sight of trouble? There's a potential race condition with loading the graphics server and the graphics driver which can happen with everything on every boot. The issues with 5.9 should be fixed (and were never an issue in a gaming context) with 455.38. Make sure everything is up to date (nvidia-utils, lib32-nvidia-utils and nvidia should all be a variant of 455.38) then post a xorg log and the log from attempting to start chromium/wow as well as

glxinfo -B
sudo journalctl -b


Board footer

Powered by FluxBB