You are not logged in.

#1 2020-11-05 05:43:15

YAOMTC
Member
Registered: 2010-02-23
Posts: 182

USB does not work in Arch ISO [SOLVED]

I am able to start booting from the Arch ISO on a flash drive, but during the boot process, USB fails:

    :: Mounting '/dev/disk/by-label/ARCH_202010' to '/run/archiso/bootmnt'
    Waiting 30 seconds for device /dev/disk/by-label/ARCH_202010 ...
    [...] xhci_hcd 0000.01:00.00: Abort failed to stop command ring: -110
    [...] xhci_hcd 0000.01:00.00: xHCI host controller not responding, assume dead
    [...] xhci_hcd 0000.01:00.00: HC died, cleaning up
    [...] usb 2-7: device not accepting address 2, error -100
    [...] usb usb2-port7: couldn't allocate usb_device
    [...] usb usb1-port2: couldn't allocate usb_device
    ERROR: '/dev/disk/by-label/ARCH_202010' did not show up after 30 seconds...
    Falling back to interactive prompt
    You can try to fix the problem manually, log out when you are finished
    sh: can't access tty; job control turned off

After selecting Arch Linux UEFI in the initial menu, I can't use the keyboard, so there's nothing I can do.

When I try to access my existing Arch install on the SSD, it now just reboots and I don't see anything. It previously did show the boot process but got stuck while trying to start X, at which point I used nomodeset to make it so I could switch TTY and update. The update didn't fix anything. Then I tried updating the BIOS, which then made it so the installed Arch boot process doesn't start at all.

I tried picking up a new motherboard, but the problem persists. Could this be RAM gone bad? A CPU issue?

    CPU: Ryzen 1700X
    GPU: MSI Radeon RX 5700 XT 8 GB
    RAM: 2 x 16 GB
    Mobo 1: X470 Aorus Gaming 5 WiFi
    Mobo 2: ASUS ROG STRIX B450-F

Last edited by YAOMTC (2020-11-05 14:00:43)

Offline

#2 2020-11-05 07:06:59

mpan
Member
Registered: 2012-08-01
Posts: 600
Website

Re: USB does not work in Arch ISO [SOLVED]


Sometimes I seem a bit harsh — don’t get offended too easily! PGP: 7C848198AE93D3BB

Offline

#3 2020-11-05 08:16:35

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,138

Re: USB does not work in Arch ISO [SOLVED]

Try passing usbcore.autosuspend=-1 to the kernel parameters

Offline

#4 2020-11-05 14:00:58

YAOMTC
Member
Registered: 2010-02-23
Posts: 182

Re: USB does not work in Arch ISO [SOLVED]

Just had to use a different flash drive, thank you.

Offline

Board footer

Powered by FluxBB