You are not logged in.

#1 2020-10-15 20:00:26

barii
Member
Registered: 2009-04-09
Posts: 21

Can't set audio device /dev/dsp to s16le output, trying s16le

Hello.

When I run journalctl, I am getting this error message:

Apr 12 21:00:35 barii-archlinux org.gnome.Nautilus[424049]: [AO OSS] Can't set audio device /dev/dsp to s16le output, trying s16le...
Apr 12 21:00:35 barii-archlinux org.gnome.Nautilus[424049]: [AO OSS] Can't set audio device /dev/dsp to s16le output, trying s16le...
Apr 12 21:00:35 barii-archlinux org.gnome.Nautilus[424049]: [AO OSS] Can't set audio device /dev/dsp to s16le output, trying s16le...

This goes on an on in million lines.

Otherwise, if I change the output device in gnome sound settings to HDMI output, which is the correct one, I hear the sound. but I don't know what could I do with this million lines. Google didn't really help sad

Offline

#2 2020-10-15 20:43:22

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,138

Re: Can't set audio device /dev/dsp to s16le output, trying s16le

reads like a misconfiguration of gstreamer that I'm not even sure how you'd actively configure that way. why is it trying to use OSS ? Do you have some weird nautilus plugin? is gst-plugins-good installed? What's the output if you do

gst-play-1.0 $randomaudiofileonyourcomputer$

Offline

#3 2020-11-06 21:48:07

barii
Member
Registered: 2009-04-09
Posts: 21

Re: Can't set audio device /dev/dsp to s16le output, trying s16le

V1del wrote:

reads like a misconfiguration of gstreamer that I'm not even sure how you'd actively configure that way. why is it trying to use OSS ? Do you have some weird nautilus plugin? is gst-plugins-good installed? What's the output if you do

gst-play-1.0 $randomaudiofileonyourcomputer$

I had these:
nautilus-sendto 3.8.6+28+gc87aac4-1
python-nautilus 1.2.3-3

who knows why... I removed them


yes, gst-plugins-good is installed



$ gst-play-1.0 SoundRecord-2019-04-24-16-25-51.wav
Press 'k' to see a list of keyboard shortcuts.
Now playing SoundRecord-2019-04-24-16-25-51.wav
ERROR GStreamer encountered a general stream error. for file:///...../SoundRecord-2019-04-24-16-25-51.wav
ERROR debug information: ../gst-plugins-good/gst/wavparse/gstwavparse.c(1765): gst_wavparse_stream_headers (): /GstPlayBin:playbin/GstURIDecodeBin:uridecodebin0/GstDecodeBin:decodebin0/GstWavParse:wavparse0:
Stream claims blockalign = 4, which is more than 2 - invalid data
Reached end of play list.

Last edited by barii (2020-11-06 21:50:20)

Offline

Board footer

Powered by FluxBB