You are not logged in.

#1 2012-10-25 17:31:20

siriusb
Member
From: Hungary
Registered: 2010-01-01
Posts: 419

[SOLVED] systemd fancontrol fails to start at boot

Hi,

I've just switched to systemd from initscript and I can't resolve an issue: fancontrol fails to run at boot time, but it works properly when manually started.

Logs:

UNIT               LOAD   ACTIVE SUB    JOB DESCRIPTION
colord.service     loaded failed failed     Manage, Install and Generate Color Profiles
fancontrol.service loaded failed failed     Fan control daemon
 #  systemctl status fancontrol
fancontrol.service - Fan control daemon
      Loaded: loaded (/etc/systemd/system/fancontrol.service; enabled)
      Active: failed (Result: exit-code) since Tue, 23 Oct 2012 07:23:42 +0200; 4min 53s ago
     Process: 434 ExecStart=/usr/sbin/fancontrol (code=exited, status=1/FAILURE)
      CGroup: name=systemd:/system/fancontrol.service
Oct 23 07:23:51 arch fancontrol[434]: Controls hwmon1/device/fan2_input
Oct 23 07:23:51 arch fancontrol[434]: MINTEMP=35
Oct 23 07:23:51 arch fancontrol[434]: MAXTEMP=45
Oct 23 07:23:51 arch fancontrol[434]: MINSTART=155
Oct 23 07:23:51 arch fancontrol[434]: MINSTOP=160
Oct 23 07:23:51 arch fancontrol[434]: MINPWM=155
Oct 23 07:23:51 arch fancontrol[434]: MAXPWM=210
Oct 23 07:23:51 arch fancontrol[434]: Device path of hwmon1 has changed
Oct 23 07:23:51 arch fancontrol[434]: Device name of hwmon1 has changed
Oct 23 07:23:51 arch fancontrol[434]: Configuration appears to be outdated, please run pwmconfig again

I thought it is a timing issue, so I tweaked fancontrol.service, but didn't helped:

#  cat /etc/systemd/system/fancontrol.service
.include /usr/lib/systemd/system/fancontrol.service

[Unit]
Requires=sensord.service
After=sensord.service

Any advice?
Thanks.

Last edited by siriusb (2012-10-26 06:33:45)

Offline

#2 2012-10-25 18:49:01

andy_v
Member
From: Estonia
Registered: 2012-04-27
Posts: 31

Re: [SOLVED] systemd fancontrol fails to start at boot

I also ran into this problem a while back and it does seem to be a timing issue. I believe the modules used for hardware monitoring aren't always loaded before fancontrol.service starts (due to systemd's nature of loading everything in parallel). lm_sensors package includes an lm_sensors.service file which loads the modules that were added by sensors-detect to /etc/conf.d/lm_sensors. So in /etc/systemd/system/fancontrol.service try substituting the lines containing sensord.service with lm_sensors.service. At least that seems to have helped me. Good luck!

Offline

#3 2012-10-25 19:15:29

siriusb
Member
From: Hungary
Registered: 2010-01-01
Posts: 419

Re: [SOLVED] systemd fancontrol fails to start at boot

I think you are right. Apparently it seems I mixed up sensord with sensors.  Thanks.

Offline

#4 2020-11-15 15:09:27

Darxus
Member
Registered: 2020-11-15
Posts: 1

Re: [SOLVED] systemd fancontrol fails to start at boot

Since this is one of the first web search hits for the error "Configuration appears to be outdated, please run pwmconfig again", the upstream bug is:  https://github.com/lm-sensors/lm-sensors/issues/227

It contains workarounds.

Last edited by Darxus (2020-11-15 15:10:14)

Offline

#5 2020-11-15 22:03:31

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,589

Re: [SOLVED] systemd fancontrol fails to start at boot

Darxus:  Welcome to the forums.

Using this opportunity to close this old thread.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB