You are not logged in.

#1 2020-11-20 04:54:37

Registered: 2020-11-16
Posts: 6

Apple Magic Mouse 2 Works But No Scrolling

Hey everyone! So I've been reading the Arch Wiki [page]( about Bluetooth mice and my Bluetooth Apple Magic Mouse 2 seems like it should be working perfectly fine. It paired and I can move the cursor and left and right click works fine. The issue is that the multitouch driver doesn't seem to be loading the scrolling settings maybe? I've tried following a few other guides I've found but they all seem to suggest that scrolling should work perfectly fine with no hassle. I'm running the latest LTS Linux kernel and my desktop is KDE Plasma. Below are some solutions I've tried:

Ubuntu Wiki:
Output of

$ lsmod | grep magic


Arch Wiki:
I followed all of the configuration section (except dual-booting setup) but this did not work at all. Nothing changed for me.

Arch Wiki (2):
I read the bluetooth section for the Magic Mouse and made the config file. When I ran

$ echo 55 > /sys/module/hid_magicmouse/parameters/scroll_speed

I got the following error:

bash: /sys/module/hid_magicmouse/parameters/scroll_speed: No such file or directory

I inspected this error a little further and found that the only directory inside `/sys/module` is the following:
Output of:

$ ls /sys/module/ | grep 'hid'

I'm sort of at a loss as all official documentation seems to suggest that the mouse should work fine. All things considered, it _is_ fully usable but I need to pull on scroll bars all the time. I'm thinking I may even need a separate module? Not sure. Help would be appreciated! smile

I should also mention I'd like to get middle mouse click working for my 3D modelling applications. If this is possible it'd be greatly appreciated!

Edit (2):
I found a script here that got it working for me. I had thought that the kernel would have the multitouch drivers but apparently not. I replaced the apt install command with

# pacman -S dkms linux-headers

and I rebooted. I then ran the install script and like *chuckles* magic it worked! I can scroll with one or two fingers but I'll keep tweaking to get it to be two finger scroll so I don't accidentally scroll when I don't want to. I also will tweak it to get a middle mouse button working! For the meantime though, it works really well!

Last edited by triguy (2020-11-21 19:00:14)

"You keep on knockin' but you can't come in!" -Cheech Marin


Board footer

Powered by FluxBB