You are not logged in.

#1 2020-11-20 17:40:46

Stef9998
Member
Registered: 2019-01-13
Posts: 5

package conflicts

Hi you all, I got a package conflict, and I'm not sure how to proceed.
I wanted to do a normal system update and now got the problem. output below

$ sudo pacman -Syu
[...]
looking for conflicting packages...
:: opencascade74 and opencascade are in conflict. Remove opencascade? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: opencascade74 and opencascade are in conflict
$ sudo pacman -Syu
[...]
looking for conflicting packages...
:: opencascade74 and opencascade are in conflict. Remove opencascade? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing opencascade breaks dependency 'opencascade' required by kicad

So 'opencascade' is required by kicad. And 'opencascade74' is required by freecad.
What would be the recommended way to handle this situation?

My guess would be to force remove opencascade and install opencascade74, cause that will be the older version and kicad should be able to use that one I guess. But I would like to hear from someone with more experience what the recommended way would be.
Thanks in advance


Arch Linux, it's not perfect, but it's where I stopped distro-hopping.

Offline

#2 2020-11-20 20:43:00

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,768

Re: package conflicts


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#3 2020-11-20 20:50:51

Stef9998
Member
Registered: 2019-01-13
Posts: 5

Re: package conflicts

Thanks for sharing. My quick google search appearently wasn't good enough^^
I will just --ignore updating freecad then till the problem will be solved.


Arch Linux, it's not perfect, but it's where I stopped distro-hopping.

Offline

Board footer

Powered by FluxBB