You are not logged in.

#1 2020-11-22 11:04:06

riccardocagnasso
Member
Registered: 2012-02-22
Posts: 49

gst-plugins-bad should contain nvcodec

The package gst-plugins-bad doesn't contain nvcodec. Which is a shame because it's the most powerful video decoding engine available.
To get nvcodec compiled you have to have extra/ffnvcodec-headers and cuda installed. You also have to provide cuda's location as a environment variable. I can provide assistance if needed.

Offline

#2 2020-11-22 12:40:26

progandy
Member
Registered: 2012-05-17
Posts: 3,929

Re: gst-plugins-bad should contain nvcodec

libgstnvcodec.so is part of gst-plugins-bad-libs, I do not know if it works. I believe the gstreamer plugin uses g_module_open (a wrapper around dlopen) to load the cuda libraries, so having cuda installed during compilation is not necessary.

Last edited by progandy (2020-11-22 13:28:37)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

Board footer

Powered by FluxBB