You are not logged in.

#1 2020-11-25 20:42:42

danhartman
Member
Registered: 2020-11-25
Posts: 15

XPS 7590 can produce sound on the headphone jack but not the speakers

I'm stumped.
I'm running pulseaudio.  I have installed pavucontrol.  I can see google chrome registering on the meter in the "playback" tab.  But I have only been able to get sound from the headphone jack.

Here are outputs from commands I've seen while searching for solutions.  What else can I try to further learn about this?


$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3266 Analog [ALC3266 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
$ pacmd list-sinks | egrep -i 'index:|name:'
  * index: 0
	name: <alsa_output.hw_0_0>
    index: 1
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
speaker-test -c2

behaves similarly.  I can hear sound if I connect to the headphone jack, but not if I unplug.

Offline

#2 2020-11-26 14:49:04

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

I just noticed that the output of

pacmd list-sinks

lists the availability of index 1: ports.analog-output-speaker as unknown

2 sink(s) available.
  * index: 0
	name: <alsa_output.hw_0_0>
	driver: <module-alsa-sink.c>
	flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9030
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 24.11 ms
	max request: 4 KiB
	max rewind: 4 KiB
	monitor source: 1
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 3
	configured latency: 23.22 ms; range is 0.50 .. 2000.00 ms
	module: 1
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC3266 Analog"
		alsa.id = "ALC3266 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xed518000 irq 180"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a348"
		device.product.name = "Cannon Lake PCH cAVS"
		device.form_factor = "internal"
		device.string = "hw:0,0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.description = "Built-in Audio"
		device.icon_name = "audio-card-pci"
    index: 1
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: (none)
	priority: 9039
	volume: front-left: 78968 / 120% / 4.86 dB,   front-right: 78968 / 120% / 4.86 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max request: 0 KiB
	max rewind: 0 KiB
	monitor source: 2
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 1
	configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 21
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC3266 Analog"
		alsa.id = "ALC3266 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xed518000 irq 180"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a348"
		device.product.name = "Cannon Lake PCH cAVS"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-speaker>

Offline

#3 2020-11-26 15:08:06

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,026

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

That's normal and not an issue, what is a potential issue is that you have a manually defined additional sink, why is that? There also have been a few changes in jack detection, if your system is not up to date, ensure that it is.

Last edited by V1del (2020-11-26 15:09:04)

Online

#4 2020-11-26 15:10:45

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

I was unaware of that.
Ignorance.  I've been flailing on this issue.  I'm fully disoriented as to whether this is a symptom of alsa, pulseaudio, or the combination of the two. 

Which sink has been manually defined?

Offline

#5 2020-11-26 15:11:58

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

thank you for suggesting the update to the system, I just issued

sudo pacman -Syu

Offline

#6 2020-11-26 15:20:07

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,026

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

alsa_output.hw_0_0 is not something that should exist in a default configuration and it's possible that it leads to issues with the proper port changing mechanisms. This will be something you've uncommented in /etc/pulse/default.pa and/or ~/.config/pulse/default.pa

Online

#7 2020-11-26 15:25:48

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

You were correct.
I re-commented the two load-module lines that targeted hw:0,0 and have rebooted.
The output of pacmd list-sinks only shows one sink now.

Current state of audio output remains unchanged.  Where could I look next?

Offline

#8 2020-11-26 15:36:37

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,026

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

Can you post

amixer -c0
dmesg | grep snd

Online

#9 2020-11-26 15:39:23

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

$ amixer -c0
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 127
  Mono: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 0 [0%] [-63.50dB] [off]
  Front Right: Playback 0 [0%] [-63.50dB] [off]
Simple mixer control 'Headphone Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Headphone Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [on]
  Front Right: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Mic Mute-LED Mode',0
  Capabilities: enum
  Items: 'On' 'Off' 'Follow Capture' 'Follow Mute'
  Item0: 'Follow Mute'
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 127
  Front Left: Capture 82 [65%] [7.50dB] [on]
  Front Right: Capture 82 [65%] [7.50dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Headset Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Headset Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Internal Mic',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
$ dmesg | grep snd
[    2.807825] snd_hda_intel: unknown parameter '#vid' ignored
[    2.807827] snd_hda_intel: unknown parameter 'pid' ignored
[    2.808170] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    2.808186] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    4.629461] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.674287] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC3266: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[    4.674289] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.674289] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    4.674290] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    4.674291] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    4.674292] snd_hda_codec_realtek hdaudioC0D0:      Headset Mic=0x18
[    4.674292] snd_hda_codec_realtek hdaudioC0D0:      Headphone Mic=0x1a
[    4.674293] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12

Offline

#10 2020-11-26 15:44:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,026

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

Does just enabling headphone audio despite them being disconnected give you output? E.g.

amixer -c0 'Headphone',0 100%,100%

and then playing something? Also you seem to try to load a custom modprobe definition for snd_hda_intel, what are you trying to do here and can you post that file? In general it would be nice if you could list things you've tried beforehand so we have a general baseline of what to expect.

Online

#11 2020-11-26 15:53:53

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

$ amixer -c0 'Headphone',0 100%,100%
amixer: Unknown command 'Headphone,0'...

I had read at some point about possible failures to detect the headphone jack switch.
I have tried using permutations of the following:

$ cat /etc/modprobe.d/alsa-base.conf
#options snd_hda_intel index=0 model=dell-headset-multi # vid=8086 pid=a348

#options snd_hda_intel index=0 model=auto #vid=8086 pid=a348

Currently they are commented out.
I had tried setting parameters via ~/.asoundrc, upon seeing no change I have deleted that file

Offline

#12 2020-11-26 16:02:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,026

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

Ah whoops that should be

amixer -c0 set 'Headphone',0 100%,100%

of course. Also in general, vid pid have never existed and never done anything on snd_hda_intel, I'm not sure why that myth is so widespread

Online

#13 2020-11-26 16:07:57

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

Thank you for sharing that bit about vid/pid. 

I ran the following.  It did not impact the state of the internal speakers

$ amixer -c0 set 'Headphone',0 100%,100%
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [off]
  Front Right: Playback 127 [100%] [0.00dB] [off]

Offline

#14 2020-11-26 16:18:45

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,026

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

Meh

amixer -c0 set 'Headphone',0 on,on

I do suspect that it's still logically linked to the headphones regardless.

Online

#15 2020-11-26 16:28:40

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

$ amixer -c0 set 'Headphone',0 on,on
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [on]
  Front Right: Playback 127 [100%] [0.00dB] [on]

Still no speaker output.
I share your suspicion.  I watched the "Output Devices" tab of pavucontrol as I plugged and unplugged a cable to the headphone jack. Visually I see that port change correctly.  So at some level, the hardware change is being detected.

Offline

#16 2020-11-26 16:32:31

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,026

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

Bit of a long shot but does it work if you force pulse to try the headphone port regardless

pacmd set-sink-port alsa_output.pci-0000_00_1f.3.analog-stereo analog-output-headphones

if that doesn't work either, you might have to play around with how the jack is assigned using something like hdajackretask (... disable pulse before trying that with

systemctl --user mask pulseaudio{,.socket} --now #unmask to reenable

Online

#17 2020-11-26 16:36:25

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

I love this.  It didn't work, but I love this

pacmd set-sink-port alsa_output.pci-0000_00_1f.3.analog-stereo analog-output-headphones

I will look into the hdajackretask tool.  Thank your for your guidance on how to ensure pulseaudio doesn't interfere with that debugging.

Offline

#18 2020-11-27 17:00:04

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

I find hdajackretask confusing. 
If I run it as my user, it asks for root authentication when I click 'Apply now', and that produces the following error

$ hdajackretask
==== AUTHENTICATING FOR org.freedesktop.policykit.exec ====
Authentication is needed to run `/tmp/hda-jack-retask-QF2AV0/script.sh' as the super user
Authenticating as: root
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ====
Error executing command as another user: Not authorized

This incident has been reported.

If I run it with sudo, when I click 'Apply now' I receive a pop-up window that reads

tee: /sys/class/sound/hwC0D0/reconfig: Device or resource busy

Any thoughts on that error?
I have tried two different kernels, and also booted from an ubuntu live USB.  They have all produced the same symptom.

Offline

#19 2020-11-27 19:01:24

frankieboy
Member
Registered: 2009-04-12
Posts: 64

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

I can't add much to this topic, only that on the same hardware (the oled model) speaker and headset works flawlessly. If you need any help by sending config data (I didn't change anything, default install with Manjaro) let me know.

Offline

#20 2020-11-27 19:05:28

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

Please!  I'll take anything.  I'm about ready to return this machine.

Offline

#21 2020-11-28 03:42:27

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 13,026

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

As mentioned, to prevent the busy line you must ensure pulseaudio is not started (in fact nothing at all,

sudo fuser -v /dev/snd/* 

must come up empty before fumbling with hdajackretask . Also not sure whether that's the case but is there possibly a hardware volume button that doesn't propagate changes to the OS ? Maybe also try updating your BIOS sometimes there's some incorrect layout information in there.

Online

#22 2020-11-28 17:00:54

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

Ok, I see that now. Thank you.  I've re-masked pulseaudio.  fuser returns empty.

After attempting to make modifications from within hdajackretask, I receive errors when I run speaker-test

$ speaker-test -c2

speaker-test 1.2.4

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
ALSA lib confmisc.c:767:(parse_card) cannot find card '0'
ALSA lib conf.c:4745:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4745:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1246:(snd_func_refer) error evaluating name
ALSA lib conf.c:4745:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:5233:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2660:(snd_pcm_open_noupdate) Unknown PCM sysdefault
Playback open error: -2,No such file or directory

Offline

#23 2020-11-29 19:28:53

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

This morning I reinstalled windows 10 that was originally installed when i purchased this machine. After allowing all updates to complete it was also incapable of producing sound via the speakers. I’m going to request a replacement. I’ll update this thread upon verification.

Offline

#24 2020-12-02 17:59:20

danhartman
Member
Registered: 2020-11-25
Posts: 15

Re: XPS 7590 can produce sound on the headphone jack but not the speakers

Update. I received a replacement machine from my vendor. Verified audio worked before installing Arch. Ran my install scripts. Audio works and I didn’t have to do a thing. Thank You

Offline

Board footer

Powered by FluxBB