You are not logged in.

#1 2020-12-04 18:04:36

cathedral_junky
Member
Registered: 2020-12-04
Posts: 13

[SOLVED] Issues booting after installation

Hi apologies for the extreme noobishness, I wanted to install Arch for the first time today alongside an existing debian 10 install on the same ssd. I've been following the arch wiki installation guide but may have misunderstood a step and currently cannot boot into my new arch system. I followed the guide until just about the end of the wiki page before 'Post-installation.' Mounted it before generating fstab. I can still boot fine into Debian with my existing grub menu but it does not detect the Arch install. I can also access the file system fine from Debian.

My SSD essentially looks like this:

/dev/sdb1=ext4 unallocated space ignore this
/dev/sdb2=512M vfat efi partition from debian installer
/dev/sdb3=debian main filesystem
/dev/sdb4=16gb swap partition for debian that I also mounted for arch
/dev/sdb5=arch main filesystem



the fstab I created for Arch: (also tried changing /boot to /boot/efi)

# /dev/sdb2
UUID=23BC-C5AE          /boot        vfat          rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro    0 2

# /dev/sdb5
UUID=56817f7b-659c-4306-943d-61cb1f24364e    /             ext4          rw,relatime    0 1

# /dev/sdb4
UUID=e60c08d9-6e8f-4108-b850-5a087383bb7b    none          swap          defaults      0 0




for comparison, the fstab from my debian system:

# / was on /dev/sdb3 during installation
UUID=05c42a91-4535-4ec1-81af-10a6cd3cdff0 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sdb2 during installation
UUID=23BC-C5AE  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/sdb4 during installation
UUID=e60c08d9-6e8f-4108-b850-5a087383bb7b none            swap    sw              0       0


Does anyone have any insight on what I did wrong here ? Either via the errors in my arch fstab or anything obvious I may have done wrong? Thanks so much for reading.


Edit: ended up adding an entry with grub-customizer in Debian and pointing it to the correct files. All good now.

Last edited by cathedral_junky (2020-12-06 13:16:00)

Offline

#2 2020-12-04 23:21:56

twobooks
Member
Registered: 2020-06-23
Posts: 32

Re: [SOLVED] Issues booting after installation

you can manually add boot entry in your existing grub config file for Arch, at least including following three lines:
        set root='hd1,gpt5'
        linux   /boot/vmlinuz-linux root=UUID=56817f7b-659c-4306-943d-61cb1f24364e rw loglevel=3
        initrd  /boot/initramfs-linux.img

Last edited by twobooks (2020-12-04 23:35:58)

Offline

Board footer

Powered by FluxBB