You are not logged in.

#1 2020-12-09 21:41:51

Registered: 2020-12-09
Posts: 2

[Solved] Cannot boot on NVMe SSD after fresh install

Hello everyone,

I just received my new laptop (Asus UX325EA). As always I want to install ArchLinux on it.

I followed the Installation guide as always. I made a dual boot with Win10 (if it is a problem, I can throw away the win10 installation and make a single boot).

With the ArchLinux ISO there is no issue, I can use my NVMe SSD, create partition, create file system, mount them, etc.
I installed systemd-boot as boot manager, as I use mainly it for some years.

The 2 only things (I guess) I never made is using an NVMe SSD as main drive and using a BTRFS (I want to try out this FS after years of ext4) partition as root partition (I created only a root partition, no dedicated home partition).

When I boot up I get this :

[    0.499894] pci 0000:00:07.0: DPC: RP PIO log size 0 is invalid
[    0.500586] pci 0000:00:07.2: DPC: RP PIO log size 0 is invalid
:: running early hook [udev]
Starting version 247.1-3-arch
:: running hook [udev]
:: Triggering uevents...
:: running hook [btrfs]
Scanning for Btrfs filesystems
Waiting 10 seconds for device /dev/disk/by-partuuid/<the partuuid of my main partition> ...
ERROR: device 'PARTUUID=<the partuuid of my main partition>' not found. Skipping fsck.
:: mounting: /new_root: can't find PARTUUID=<the partuuid of my main partition>.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off
[rootfs ]#

I searched over the forum and wiki, I found out I need to load nvme module (and rerun mkinitcpio). I added nvme module in the MODULES and HOOKS sections of /etc/mkinitcpio.conf (same for btrfs), run mkinitcpio -p linux command.
But it seems to add btrfs module but no indication about nvme. nvme seems to be part of the built-in modules. I double checked partuuid (on the first try I used the partition label). With the emergency shell I tried to find the nvme ssd in /dev/, but I cannot seen it.

As it works perfectly from the installation ISO, I think I only missed up some configuration somewhere, but I didn't found it.
Does anyone can help me please?

Last edited by Kuroidoruido (2020-12-11 10:35:26)


#2 2020-12-11 10:34:36

Registered: 2020-12-09
Posts: 2

Re: [Solved] Cannot boot on NVMe SSD after fresh install

I finally found a solution, thanks to this response : … 1#p1880791

in my systemd-boot loader entry, I added "nvme_load=YES" before the root partition :

/boot/loader/entries/arch.conf :

options      nvme_load=YES root=PARTUUID=<the partuuid of my main partition> rw


Board footer

Powered by FluxBB