You are not logged in.

#1 2020-12-10 03:29:07

andheisus
Member
Registered: 2016-04-16
Posts: 10

[Solved] LightDM Failed to Start After Updates – Blinking Cursor

After updates I did on 02 Dec, I could not reboot to the desktop nor get a graphical login. There is a ‘Failed to start Light Display Manager’ error occasionally showing on boot and then an unresponsive blinking cursor. After I reboot I do not see the ‘Failed’ message again, and I can then at least get to a responsive cursor that allows me to log in to a tty terminal.

I have seen some other similar examples on the forum ( like perhaps https://bbs.archlinux.org/viewtopic.php?id=259802 being the most extensive), both recent and older, but do not yet know how to interpret the logs that other posts have referenced in order to determine what went wrong. I looked at the LightDM wiki page at https://wiki.archlinux.org/index.php/Li … leshooting but am still not sure what may match my issue.

I did a fresh install back in the summer and had no bad issues until this update. Based on what I have seen in the forum, it has led me toward LightDM settings, or maybe a graphics driver problem? I use optimus-manager from the AUR to switch, but normally am in Intel mode only, and it was set to that when all this happened. I see some warnings and errors related to optimus-manager and GPU switching in ‘lightdm –-test-mode –debug’ – how could I check to see if that is part of my problem?

I tried downgrading the vf86-video-intel package to the previous version but it did not help, so I upgraded back.

I am posting some logs and information here to see if anyone can see places I might start to fix this. If this is too much of a scattershot of logs, I apologize, but I really have no idea what to try first and don’t want to make things worse if avoidable...

/var/log/Xorg.0.log – http://ix.io/2GXM

/var/pacman.log (section from 02 Dec upgrades)

	  [2020-12-02T11:03:30-0800] [PACMAN] Running 'pacman -Syyu'
[2020-12-02T11:03:30-0800] [PACMAN] synchronizing package lists
[2020-12-02T11:03:32-0800] [PACMAN] starting full system upgrade
[2020-12-02T11:07:09-0800] [ALPM] running '60-mkinitcpio-remove.hook'...
[2020-12-02T11:07:09-0800] [ALPM] transaction started
[2020-12-02T11:07:09-0800] [ALPM] upgraded libseccomp (2.4.2-1 -> 2.5.1-2)
[2020-12-02T11:07:09-0800] [ALPM] upgraded gcc-libs (10.2.0-3 -> 10.2.0-4)
[2020-12-02T11:07:09-0800] [ALPM] upgraded bash (5.0.018-1 -> 5.0.018-2)
[2020-12-02T11:07:10-0800] [ALPM] upgraded xcb-proto (1.14.1-1 -> 1.14.1-3)
[2020-12-02T11:07:10-0800] [ALPM] upgraded libxml2 (2.9.10-6 -> 2.9.10-7)
[2020-12-02T11:07:10-0800] [ALPM] upgraded util-linux-libs (2.36.1-3 -> 2.36.1-4)
[2020-12-02T11:07:10-0800] [ALPM] upgraded glib2 (2.66.2-1 -> 2.66.3-1)
[2020-12-02T11:07:10-0800] [ALPM] upgraded audit (2.8.5-6 -> 2.8.5-9)
[2020-12-02T11:07:10-0800] [ALPM] upgraded systemd-libs (246.6-1 -> 247.1-1)
[2020-12-02T11:07:10-0800] [ALPM] upgraded avahi (0.8+15+ge8a3dd0-1 -> 0.8+15+ge8a3dd0-3)
[2020-12-02T11:07:10-0800] [ALPM] upgraded libcups (2.3.3+106+ga72b0140e-1 -> 1:2.3.3op1-1)
[2020-12-02T11:07:10-0800] [ALPM] upgraded util-linux (2.36.1-3 -> 2.36.1-4)
[2020-12-02T11:07:10-0800] [ALPM] warning: /etc/systemd/homed.conf installed as /etc/systemd/homed.conf.pacnew
[2020-12-02T11:07:10-0800] [ALPM] upgraded systemd (246.6-1 -> 247.1-1)
[2020-12-02T11:07:10-0800] [ALPM] upgraded libinput (1.16.3-1 -> 1.16.4-1)
[2020-12-02T11:07:10-0800] [ALPM] upgraded libproxy (0.4.15+33+g454a499-2 -> 0.4.15+33+g454a499-4)
[2020-12-02T11:07:10-0800] [ALPM] upgraded xorg-server-common (1.20.9.r21.g5c400cae1-2 -> 1.20.10-1)
[2020-12-02T11:07:10-0800] [ALPM] upgraded xorg-server (1.20.9.r21.g5c400cae1-2 -> 1.20.10-1)
[2020-12-02T11:07:10-0800] [ALPM] upgraded llvm-libs (11.0.0-1 -> 11.0.0-3)
[2020-12-02T11:07:10-0800] [ALPM] upgraded android-file-transfer (3.9-2 -> 4.0-1)
[2020-12-02T11:07:10-0800] [ALPM] upgraded gobject-introspection-runtime (1.66.1-1 -> 1.66.1-3)
[2020-12-02T11:07:10-0800] [ALPM] upgraded python (3.8.6-1 -> 3.9.0-1)
[2020-12-02T11:07:10-0800] [ALPM] upgraded python-gobject (3.38.0-1 -> 3.38.0-3)
[2020-12-02T11:07:10-0800] [ALPM] upgraded cairo (1.17.2+25+gaee96d175-1 -> 1.17.4-1)
[2020-12-02T11:07:10-0800] [ALPM] upgraded js78 (78.5.0-1 -> 78.5.0-2)
[2020-12-02T11:07:10-0800] [ALPM] upgraded tdb (1.4.3-2 -> 1.4.3-4)
[2020-12-02T11:07:10-0800] [ALPM] upgraded brotli (1.0.9-2 -> 1.0.9-4)
[2020-12-02T11:07:10-0800] [ALPM] upgraded bleachbit (4.0.0-3 -> 4.0.0-4)
[2020-12-02T11:07:10-0800] [ALPM] upgraded kcoreaddons (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:10-0800] [ALPM] upgraded kwidgetsaddons (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded kjobwidgets (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded kauth (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded kcodecs (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded kconfig (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded kguiaddons (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded ki18n (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded kconfigwidgets (5.76.0-1 -> 5.76.0-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded kitemviews (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded kdbusaddons (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded kcompletion (5.76.0-1 -> 5.76.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded gnupg (2.2.23-1 -> 2.2.24-1)
[2020-12-02T11:07:11-0800] [ALPM] upgraded gpgme (1.15.0-1 -> 1.15.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded btrfs-progs (5.9-1 -> 5.9-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded libbytesize (2.4-1 -> 2.4-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded volume_key (0.3.12-3 -> 0.3.12-5)
[2020-12-02T11:07:11-0800] [ALPM] upgraded libblockdev (2.24-1 -> 2.24-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded libplist (2.2.0-1 -> 2.2.0-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded libimobiledevice (1.3.0-1 -> 1.3.0-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded bluedevil (1:5.20.3-1 -> 1:5.20.4-1)
[2020-12-02T11:07:11-0800] [ALPM] upgraded enchant (2.2.11-2 -> 2.2.12-1)
[2020-12-02T11:07:11-0800] [ALPM] upgraded bluefish (2.2.12-1 -> 2.2.12-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-cairo (1.20.0-1 -> 1.20.0-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded blueman (2.1.3-1 -> 2.1.3-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded boost-libs (1.72.0-2 -> 1.72.0-4)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-apsw (3.33.0-2 -> 3.33.0-4)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-soupsieve (2.0.1-1 -> 2.0.1-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-beautifulsoup4 (4.9.3-1 -> 4.9.3-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-cssselect (1.1.0-4 -> 1.1.0-6)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-css-parser (1.0.6-1 -> 1.0.6-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-six (1.15.0-1 -> 1.15.0-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-dateutil (2.8.1-3 -> 2.8.1-5)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-dbus-common (1.2.16-1 -> 1.2.16-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-dbus (1.2.16-1 -> 1.2.16-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-dnspython (1:1.16.0-1 -> 1:1.16.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-sgmllib (5.2.1-6 -> 5.2.1-9)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-feedparser (5.2.1-6 -> 5.2.1-9)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-appdirs (1.4.4-1 -> 1.4.4-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-pyparsing (2.4.7-1 -> 2.4.7-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-packaging (20.4-1 -> 20.7-1)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-ordered-set (4.0.2-1 -> 4.0.2-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-setuptools (1:50.3.2-1 -> 1:50.3.2-4)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-html2text (2020.1.16-1 -> 2020.1.16-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-chardet (3.0.4-5 -> 3.0.4-7)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-lxml (4.6.1-1 -> 4.6.2-1)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-html5-parser (0.4.9-3 -> 0.4.9-5)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-markdown (3.3.3-1 -> 3.3.3-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-webencodings (0.5.1-4 -> 0.5.1-6)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-html5lib (1.1-4 -> 1.1-5)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-mechanize (1:0.4.5-2 -> 1:0.4.5-4)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-msgpack (1.0.0-1 -> 1.0.0-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-netifaces (0.10.9-4 -> 0.10.9-6)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-unrardll (0.1.4-3 -> 0.1.4-5)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-pillow (7.2.0-1 -> 8.0.1-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-psutil (5.7.3-1 -> 5.7.3-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-pychm (0.8.6-2 -> 0.8.6-4)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-pygments (2.7.2-1 -> 2.7.2-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-pyqt5-sip (12.8.1-1 -> 12.8.1-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-pyqt5 (5.15.2-1 -> 5.15.2-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded hidapi (0.10.0-2 -> 0.10.1-1)
[2020-12-02T11:07:11-0800] [ALPM] upgraded libibus (1.5.23+1+gdd4cc5b0-1 -> 1.5.23+1+gdd4cc5b0-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-pyqtwebengine (5.15.2-1 -> 5.15.2-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-regex (2020.11.13-1 -> 2020.11.13-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-ifaddr (0.1.7-1 -> 0.1.7-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-zeroconf (0.28.6-1 -> 0.28.6-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded calibre (5.5.0-1 -> 5.6.0-2)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-ptyprocess (0.6.0-4 -> 0.6.0-6)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-pexpect (4.8.0-1 -> 4.8.0-3)
[2020-12-02T11:07:11-0800] [ALPM] upgraded python-pyxdg (0.26-6 -> 0.26-8)
[2020-12-02T11:07:11-0800] [ALPM] upgraded catfish (1.4.13-2 -> 1.4.13-4)
[2020-12-02T11:07:12-0800] [ALPM] upgraded poppler (20.10.0-1 -> 20.12.0-1)
[2020-12-02T11:07:12-0800] [ALPM] upgraded imagemagick (7.0.10.43-1 -> 7.0.10.45-1)
[2020-12-02T11:07:12-0800] [ALPM] upgraded liblouis (3.15.0-1 -> 3.15.0-3)
[2020-12-02T11:07:12-0800] [ALPM] upgraded cups-filters (1.28.5-3 -> 1.28.6-1)
[2020-12-02T11:07:12-0800] [ALPM] upgraded cups (2.3.3+106+ga72b0140e-1 -> 1:2.3.3op1-1)
[2020-12-02T11:07:12-0800] [ALPM] upgraded dialog (1:1.3_20200327-1 -> 1:1.3_20201126-1)
[2020-12-02T11:07:12-0800] [ALPM] upgraded firefox (83.0-1 -> 83.0-2)
[2020-12-02T11:07:12-0800] [ALPM] upgraded libarchive (3.4.3-1 -> 3.5.0-1)
[2020-12-02T11:07:12-0800] [ALPM] upgraded gcc (10.2.0-3 -> 10.2.0-4)
[2020-12-02T11:07:12-0800] [ALPM] upgraded libsigc++ (2.10.4-2 -> 2.10.6-1)
[2020-12-02T11:07:12-0800] [ALPM] upgraded glibmm (2.64.4-1 -> 2.64.5-1)
[2020-12-02T11:07:12-0800] [ALPM] upgraded libmagick6 (6.9.11.41-1 -> 6.9.11.45-1)
[2020-12-02T11:07:12-0800] [ALPM] upgraded poppler-glib (20.10.0-1 -> 20.12.0-1)
[2020-12-02T11:07:13-0800] [ALPM] upgraded inkscape (1.0.1-2 -> 1.0.1-3)
[2020-12-02T11:07:13-0800] [ALPM] upgraded lensfun (0.3.95-2 -> 0.3.95-4)
[2020-12-02T11:07:13-0800] [ALPM] upgraded lib32-gcc-libs (10.2.0-3 -> 10.2.0-4)
[2020-12-02T11:07:13-0800] [ALPM] upgraded libaccounts-glib (1.25-1 -> 1.25-3)
[2020-12-02T11:07:13-0800] [ALPM] upgraded libgexiv2 (0.12.1-1 -> 0.12.1-3)
[2020-12-02T11:07:13-0800] [ALPM] upgraded libieee1284 (0.2.11-9 -> 0.2.11-11)
[2020-12-02T11:07:13-0800] [ALPM] upgraded libixion (0.16.1-1 -> 0.16.1-3)
[2020-12-02T11:07:13-0800] [ALPM] upgraded libnewt (0.52.21-4 -> 0.52.21-5)
[2020-12-02T11:07:13-0800] [ALPM] upgraded liborcus (0.16.1-1 -> 0.16.1-3)
[2020-12-02T11:07:14-0800] [ALPM] upgraded libreoffice-fresh (7.0.3-2 -> 7.0.3-4)
[2020-12-02T11:07:14-0800] [ALPM] upgraded libsynctex (2020.54586-6 -> 2020.54586-7)
[2020-12-02T11:07:14-0800] [ALPM] upgraded libteam (1.31-1 -> 1.31-2)
[2020-12-02T11:07:14-0800] [ALPM] upgraded lightdm-gtk-greeter-settings (1.2.2-4 -> 1.2.2-5)
[2020-12-02T11:07:14-0800] [ALPM] upgraded lilv (0.24.10-1 -> 0.24.10-3)
[2020-12-02T11:07:14-0800] [ALPM] upgraded linux (5.9.10.arch1-1 -> 5.9.11.arch2-1)
[2020-12-02T11:07:15-0800] [ALPM] upgraded linux-firmware (20201113.2ea8667-1 -> 20201120.bc9cd0b-1)
[2020-12-02T11:07:16-0800] [ALPM] upgraded linux-headers (5.9.10.arch1-1 -> 5.9.11.arch2-1)
[2020-12-02T11:07:17-0800] [ALPM] upgraded linux-lts (5.4.79-1 -> 5.4.80-2)
[2020-12-02T11:07:18-0800] [ALPM] upgraded linux-lts-headers (5.4.79-1 -> 5.4.80-2)
[2020-12-02T11:07:18-0800] [ALPM] upgraded mlt (6.22.1-4 -> 6.22.1-6)
[2020-12-02T11:07:18-0800] [ALPM] upgraded mousepad (0.4.2-3 -> 0.5.0-1)
[2020-12-02T11:07:18-0800] [ALPM] upgraded mtools (4.0.25-1 -> 4.0.26-1)
[2020-12-02T11:07:18-0800] [ALPM] upgraded net-snmp (5.9-1 -> 5.9-3)
[2020-12-02T11:07:19-0800] [ALPM] upgraded nvidia (455.45.01-2 -> 455.45.01-4)
[2020-12-02T11:07:19-0800] [ALPM] upgraded nvidia-lts (1:455.45.01-2 -> 1:455.45.01-6)
[2020-12-02T11:07:19-0800] [ALPM] upgraded openexr (2.5.3-1 -> 2.5.3-3)
[2020-12-02T11:07:21-0800] [ALPM] upgraded papirus-icon-theme (20201031-1 -> 20201201-1)
[2020-12-02T11:07:21-0800] [ALPM] upgraded poppler-qt5 (20.10.0-1 -> 20.12.0-1)
[2020-12-02T11:07:21-0800] [ALPM] upgraded protobuf (3.12.4-1 -> 3.12.4-3)
[2020-12-02T11:07:21-0800] [ALPM] upgraded python-pyalsa (1.1.6-5 -> 1.1.6-6)
[2020-12-02T11:07:21-0800] [ALPM] upgraded python-sip (4.19.24-2 -> 4.19.24-4)
[2020-12-02T11:07:21-0800] [ALPM] upgraded python2-appdirs (1.4.4-1 -> 1.4.4-3)
[2020-12-02T11:07:21-0800] [ALPM] upgraded python2-beautifulsoup4 (4.9.3-1 -> 4.9.3-3)
[2020-12-02T11:07:21-0800] [ALPM] upgraded python2-pyparsing (2.4.7-1 -> 2.4.7-3)
[2020-12-02T11:07:21-0800] [ALPM] upgraded python2-six (1.15.0-1 -> 1.15.0-3)
[2020-12-02T11:07:21-0800] [ALPM] upgraded python2-packaging (20.4-1 -> 20.7-1)
[2020-12-02T11:07:21-0800] [ALPM] upgraded python2-chardet (3.0.4-5 -> 3.0.4-7)
[2020-12-02T11:07:21-0800] [ALPM] upgraded python2-cssselect (1.1.0-4 -> 1.1.0-6)
[2020-12-02T11:07:21-0800] [ALPM] upgraded python2-lxml (4.6.1-1 -> 4.6.2-1)
[2020-12-02T11:07:21-0800] [ALPM] upgraded reflector (2020.9-1 -> 2020.9-2)
[2020-12-02T11:07:22-0800] [ALPM] upgraded scribus (1.5.6.1-1 -> 1.5.6.1-3)
[2020-12-02T11:07:22-0800] [ALPM] upgraded sudo (1.9.3.p1-1 -> 1.9.4-1)
[2020-12-02T11:07:22-0800] [ALPM] upgraded systemd-sysvcompat (246.6-1 -> 247.1-1)
[2020-12-02T11:07:22-0800] [ALPM] upgraded vim-runtime (8.2.1989-2 -> 8.2.1989-3)
[2020-12-02T11:07:22-0800] [ALPM] upgraded vim (8.2.1989-2 -> 8.2.1989-3)
[2020-12-02T11:07:22-0800] [ALPM] upgraded xf86-video-intel (1:2.99.917+912+gad5540f6-1 -> 1:2.99.917+913+g9236c582-1)
[2020-12-02T11:07:22-0800] [ALPM] upgraded xorg-server-devel (1.20.9.r21.g5c400cae1-2 -> 1.20.10-1)
[2020-12-02T11:07:22-0800] [ALPM] upgraded xorg-server-xephyr (1.20.9.r21.g5c400cae1-2 -> 1.20.10-1)
[2020-12-02T11:07:22-0800] [ALPM] upgraded xorg-server-xnest (1.20.9.r21.g5c400cae1-2 -> 1.20.10-1)
[2020-12-02T11:07:22-0800] [ALPM] upgraded xorg-server-xvfb (1.20.9.r21.g5c400cae1-2 -> 1.20.10-1)
[2020-12-02T11:07:22-0800] [ALPM] upgraded xorg-server-xwayland (1.20.9.r21.g5c400cae1-2 -> 1.20.10-1)
[2020-12-02T11:07:22-0800] [ALPM] upgraded zbar (0.23.1-3 -> 0.23.1-5)
[2020-12-02T11:07:22-0800] [ALPM] transaction completed
[2020-12-02T11:07:24-0800] [ALPM] running '20-systemd-sysusers.hook'...
[2020-12-02T11:07:24-0800] [ALPM] running '30-systemd-catalog.hook'...
[2020-12-02T11:07:24-0800] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-12-02T11:07:24-0800] [ALPM] running '30-systemd-hwdb.hook'...
[2020-12-02T11:07:24-0800] [ALPM] running '30-systemd-sysctl.hook'...
[2020-12-02T11:07:24-0800] [ALPM-SCRIPTLET] Not setting net/ipv4/conf/all/rp_filter (explicit setting exists).
[2020-12-02T11:07:24-0800] [ALPM-SCRIPTLET] Not setting net/ipv4/conf/default/rp_filter (explicit setting exists).
[2020-12-02T11:07:24-0800] [ALPM-SCRIPTLET] Not setting net/ipv4/conf/all/accept_source_route (explicit setting exists).
[2020-12-02T11:07:24-0800] [ALPM-SCRIPTLET] Not setting net/ipv4/conf/default/accept_source_route (explicit setting exists).
[2020-12-02T11:07:24-0800] [ALPM-SCRIPTLET] Not setting net/ipv4/conf/all/promote_secondaries (explicit setting exists).
[2020-12-02T11:07:24-0800] [ALPM-SCRIPTLET] Not setting net/ipv4/conf/default/promote_secondaries (explicit setting exists).
[2020-12-02T11:07:24-0800] [ALPM] running '30-systemd-tmpfiles.hook'...
[2020-12-02T11:07:24-0800] [ALPM] running '30-systemd-udev-reload.hook'...
[2020-12-02T11:07:24-0800] [ALPM] running '30-systemd-update.hook'...
[2020-12-02T11:07:24-0800] [ALPM] running '60-depmod.hook'...
[2020-12-02T11:07:34-0800] [ALPM] running '90-mkinitcpio-install.hook'...
[2020-12-02T11:07:34-0800] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2020-12-02T11:07:34-0800] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2020-12-02T11:07:34-0800] [ALPM-SCRIPTLET] ==> Starting build: 5.4.80-2-lts
[2020-12-02T11:07:34-0800] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-12-02T11:07:34-0800] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-12-02T11:07:34-0800] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2020-12-02T11:07:34-0800] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-12-02T11:07:34-0800] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-12-02T11:07:35-0800] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-12-02T11:07:35-0800] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-12-02T11:07:35-0800] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-12-02T11:07:35-0800] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-12-02T11:07:35-0800] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts.img
[2020-12-02T11:07:36-0800] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-12-02T11:07:36-0800] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2020-12-02T11:07:36-0800] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2020-12-02T11:07:36-0800] [ALPM-SCRIPTLET] ==> Starting build: 5.4.80-2-lts
[2020-12-02T11:07:36-0800] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-12-02T11:07:36-0800] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-12-02T11:07:36-0800] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-12-02T11:07:36-0800] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-12-02T11:07:37-0800] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2020-12-02T11:07:38-0800] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2020-12-02T11:07:39-0800] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-12-02T11:07:39-0800] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-12-02T11:07:40-0800] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-12-02T11:07:41-0800] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-12-02T11:07:41-0800] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2020-12-02T11:07:45-0800] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-12-02T11:07:45-0800] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2020-12-02T11:07:45-0800] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2020-12-02T11:07:45-0800] [ALPM-SCRIPTLET] ==> Starting build: 5.9.11-arch2-1
[2020-12-02T11:07:45-0800] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-12-02T11:07:45-0800] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-12-02T11:07:45-0800] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2020-12-02T11:07:45-0800] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-12-02T11:07:45-0800] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-12-02T11:07:45-0800] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2020-12-02T11:07:46-0800] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-12-02T11:07:46-0800] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-12-02T11:07:46-0800] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-12-02T11:07:46-0800] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-12-02T11:07:46-0800] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2020-12-02T11:07:47-0800] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-12-02T11:07:47-0800] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2020-12-02T11:07:47-0800] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2020-12-02T11:07:47-0800] [ALPM-SCRIPTLET] ==> Starting build: 5.9.11-arch2-1
[2020-12-02T11:07:47-0800] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-12-02T11:07:47-0800] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-12-02T11:07:47-0800] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-12-02T11:07:47-0800] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-12-02T11:07:48-0800] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2020-12-02T11:07:48-0800] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2020-12-02T11:07:49-0800] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2020-12-02T11:07:49-0800] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-12-02T11:07:50-0800] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-12-02T11:07:51-0800] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-12-02T11:07:52-0800] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-12-02T11:07:52-0800] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2020-12-02T11:07:55-0800] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-12-02T11:07:55-0800] [ALPM] running 'dbus-reload.hook'...
[2020-12-02T11:07:55-0800] [ALPM] running 'detect-old-perl-modules.hook'...
[2020-12-02T11:07:55-0800] [ALPM] running 'glib-compile-schemas.hook'...
[2020-12-02T11:07:55-0800] [ALPM] running 'gtk-update-icon-cache.hook'...
[2020-12-02T11:07:57-0800] [ALPM] running 'texinfo-install.hook'...
[2020-12-02T11:07:58-0800] [ALPM] running 'update-desktop-database.hook'...
[2020-12-02T11:07:58-0800] [ALPM] running 'update-mime-database.hook'...
[2020-12-02T11:08:44-0800] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/spike/.cache/yay/inxi/inxi-3.1.09-1-any.pkg.tar.zst'
[2020-12-02T11:08:44-0800] [ALPM] transaction started
[2020-12-02T11:08:44-0800] [ALPM] upgraded inxi (3.1.06-1 -> 3.1.09-1)
[2020-12-02T11:08:44-0800] [ALPM] transaction completed
[2020-12-02T11:08:44-0800] [ALPM] running '30-systemd-update.hook'...
[2020-12-02T16:13:55-0800] [PACMAN] Running 'pacman -Syu'
[2020-12-02T16:13:55-0800] [PACMAN] synchronizing package lists
[2020-12-02T16:13:56-0800] [PACMAN] starting full system upgrade
[2020-12-02T16:14:01-0800] [ALPM] transaction started
[2020-12-02T16:14:01-0800] [ALPM] upgraded libldap (2.4.54-1 -> 2.4.56-1)
[2020-12-02T16:14:01-0800] [ALPM] upgraded lib32-libldap (2.4.54-1 -> 2.4.56-1)
[2020-12-02T16:14:01-0800] [ALPM] transaction completed
[2020-12-02T16:14:01-0800] [ALPM] running '30-systemd-update.hook'...	


/var/log/lightdm/seat0-greeter.log

   ** Message: 10:21:54.006: Starting lightdm-gtk-greeter 2.0.8 (Jul  4 2020, 16:10:34)
** Message: 10:21:54.008: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf

** (lightdm-gtk-greeter:602): WARNING **: 10:21:54.131: [PIDs] Failed to execute command: /usr/libexec/at-spi-bus-launcher

** (lightdm-gtk-greeter:602): WARNING **: 10:21:54.132: [PIDs] Failed to execute command: systemd

** (lightdm-gtk-greeter:602): WARNING **: 10:21:54.217: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files

(lightdm-gtk-greeter:602): Gtk-WARNING **: 10:21:54.228: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:602): Gtk-WARNING **: 10:22:00.194: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:602): Gtk-WARNING **: 10:22:01.317: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)	

/etc/lightdm/lightdm-gtk-greeter.conf:

[greeter]
theme-name = Adwaita-dark 

/etc/lightdm/lightdm.conf

   #
# General configuration
#
# start-default-seat = True to always start one seat if none are defined in the configuration
# greeter-user = User to run greeter as
# minimum-display-number = Minimum display number to use for X servers
# minimum-vt = First VT to run displays on
# lock-memory = True to prevent memory from being paged to disk
# user-authority-in-system-dir = True if session authority should be in the system location
# guest-account-script = Script to be run to setup guest account
# logind-check-graphical = True to on start seats that are marked as graphical by logind
# log-directory = Directory to log information to
# run-directory = Directory to put running state in
# cache-directory = Directory to cache to
# sessions-directory = Directory to find sessions
# remote-sessions-directory = Directory to find remote sessions
# greeters-directory = Directory to find greeters
# backup-logs = True to move add a .old suffix to old log files when opening new ones
# dbus-service = True if LightDM provides a D-Bus service to control it
#
[LightDM]
#start-default-seat=true
#greeter-user=lightdm
#minimum-display-number=0
#minimum-vt=7 # Setting this to a value < 7 implies security issues, see FS#46799
#lock-memory=true
#user-authority-in-system-dir=false
#guest-account-script=guest-account
#logind-check-graphical=false
#log-directory=/var/log/lightdm
run-directory=/run/lightdm
#cache-directory=/var/cache/lightdm
#sessions-directory=/usr/share/lightdm/sessions:/usr/share/xsessions:/usr/share/wayland-sessions
#remote-sessions-directory=/usr/share/lightdm/remote-sessions
#greeters-directory=$XDG_DATA_DIRS/lightdm/greeters:$XDG_DATA_DIRS/xgreeters
#backup-logs=true
#dbus-service=true

#
# Seat configuration
#
# Seat configuration is matched against the seat name glob in the section, for example:
# [Seat:*] matches all seats and is applied first.
# [Seat:seat0] matches the seat named "seat0".
# [Seat:seat-thin-client*] matches all seats that have names that start with "seat-thin-client".
#
# type = Seat type (local, xremote)
# pam-service = PAM service to use for login
# pam-autologin-service = PAM service to use for autologin
# pam-greeter-service = PAM service to use for greeters
# xserver-command = X server command to run (can also contain arguments e.g. X -special-option)
# xmir-command = Xmir server command to run (can also contain arguments e.g. Xmir -special-option)
# xserver-config = Config file to pass to X server
# xserver-layout = Layout to pass to X server
# xserver-allow-tcp = True if TCP/IP connections are allowed to this X server
# xserver-share = True if the X server is shared for both greeter and session
# xserver-hostname = Hostname of X server (only for type=xremote)
# xserver-display-number = Display number of X server (only for type=xremote)
# xdmcp-manager = XDMCP manager to connect to (implies xserver-allow-tcp=true)
# xdmcp-port = XDMCP UDP/IP port to communicate on
# xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
# greeter-session = Session to load for greeter
# greeter-hide-users = True to hide the user list
# greeter-allow-guest = True if the greeter should show a guest login option
# greeter-show-manual-login = True if the greeter should offer a manual login option
# greeter-show-remote-login = True if the greeter should offer a remote login option
# user-session = Session to load for users
# allow-user-switching = True if allowed to switch users
# allow-guest = True if guest login is allowed
# guest-session = Session to load for guests (overrides user-session)
# session-wrapper = Wrapper script to run session with
# greeter-wrapper = Wrapper script to run greeter with
# guest-wrapper = Wrapper script to run guest sessions with
# display-setup-script = Script to run when starting a greeter session (runs as root)
# display-stopped-script = Script to run after stopping the display server (runs as root)
# greeter-setup-script = Script to run when starting a greeter (runs as root)
# session-setup-script = Script to run when starting a user session (runs as root)
# session-cleanup-script = Script to run when quitting a user session (runs as root)
# autologin-guest = True to log in as guest by default
# autologin-user = User to log in with by default (overrides autologin-guest)
# autologin-user-timeout = Number of seconds to wait before loading default user
# autologin-session = Session to load for automatic login (overrides user-session)
# autologin-in-background = True if autologin session should not be immediately activated
# exit-on-failure = True if the daemon should exit if this seat fails
#
[Seat:*]
#type=local
#pam-service=lightdm
#pam-autologin-service=lightdm-autologin
#pam-greeter-service=lightdm-greeter
#xserver-command=X
#xmir-command=Xmir
#xserver-config=
#xserver-layout=
#xserver-allow-tcp=false
#xserver-share=true
#xserver-hostname=
#xserver-display-number=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
#greeter-session=example-gtk-gnome
#greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true
#user-session=default
#allow-user-switching=true
#allow-guest=true
#guest-session=
session-wrapper=/etc/lightdm/Xsession
#greeter-wrapper=
#guest-wrapper=
#display-setup-script=
#display-stopped-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
#autologin-user=
#autologin-user-timeout=0
#autologin-in-background=false
#autologin-session=
#exit-on-failure=false

#
# XDMCP Server configuration
#
# enabled = True if XDMCP connections should be allowed
# port = UDP/IP port to listen for connections on
# listen-address = Host/address to listen for XDMCP connections (use all addresses if not present)
# key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
# hostname = Hostname to report to XDMCP clients (defaults to system hostname if unset)
#
# The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn.  Alternatively
# it can be a word and the first 7 characters are used as the key.
#
[XDMCPServer]
#enabled=false
#port=177
#listen-address=
#key=
#hostname=

#
# VNC Server configuration
#
# enabled = True if VNC connections should be allowed
# command = Command to run Xvnc server with
# port = TCP/IP port to listen for connections on
# listen-address = Host/address to listen for VNC connections (use all addresses if not present)
# width = Width of display to use
# height = Height of display to use
# depth = Color depth of display to use
#
[VNCServer]
#enabled=false
#command=Xvnc
#port=5900
#listen-address=
#width=1024
#height=768
#depth=8	


dmesg – http://ix.io/2GXT

lightdm –-test-mode –debug

[+0.00s] DEBUG: Logging to /home/spike/.cache/lightdm/log/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=1000 PID=922
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf.d/20-optimus-manager.conf
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Running in user mode
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ?gio-vfs?
[+0.00s] DEBUG: Monitoring logind for seats
[+0.00s] DEBUG: New seat added from logind: seat0
[+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.00s] DEBUG: Seat seat0 has property CanMultiSession=no
[+0.00s] DEBUG: Seat seat0: Starting
[+0.00s] DEBUG: Seat seat0: Creating greeter session
[+0.00s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
[+0.01s] DEBUG: Loading user config from /etc/lightdm/users.conf
[+0.01s] DEBUG: User spike added
[+0.01s] DEBUG: Seat seat0: Creating display server of type x
[+0.01s] DEBUG: Could not run plymouth --ping: Failed to execute child process ?plymouth? (No such file or directory)
[+0.01s] DEBUG: Seat seat0: Starting local X display
[+0.01s] DEBUG: XServer 0: Logging to /home/spike/.cache/lightdm/log/x-0.log
[+0.01s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.01s] WARNING: Error reading existing Xauthority: Failed to open file ?/run/lightdm/root/:0?: Permission denied
[+0.01s] WARNING: XServer 0: Failed to write authority: Failed to open X authority /run/lightdm/root/:0: Permission denied
[+0.01s] DEBUG: XServer 0: Launching X Server
[+0.01s] DEBUG: Launching process 927: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp
[+0.01s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.01s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.01s] WARNING: Could not enumerate user data directory /var/lib/lightdm-data: Error opening directory '/var/lib/lightdm-data': Permission denied
[+0.01s] DEBUG: Process 927 exited with return value 1
[+0.01s] DEBUG: XServer 0: X server stopped
[+0.01s] DEBUG: XServer 0: Removing X server authority /run/lightdm/root/:0
[+0.01s] DEBUG: Seat seat0: Display server stopped
[+0.01s] DEBUG: Launching process 928: /sbin/prime-switch
Traceback (most recent call last):
  File "/sbin/prime-switch", line 33, in <module>
    sys.exit(load_entry_point('optimus-manager==1.3', 'console_scripts', 'prime-switch')())
  File "/sbin/prime-switch", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.9/importlib/metadata.py", line 524, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.9/importlib/metadata.py", line 187, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: optimus-manager
[+0.03s] DEBUG: Process 928 exited with return value 1
[+0.03s] DEBUG: Seat seat0: Exit status of /sbin/prime-switch: 1
[+0.03s] DEBUG: Seat seat0: Stopping session
[+0.03s] DEBUG: Seat seat0: Session stopped
[+0.03s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+0.03s] DEBUG: Seat seat0: Stopping; greeter display server failed to start
[+0.03s] DEBUG: Seat seat0: Stopping
[+0.03s] DEBUG: Seat seat0: Stopped
[+0.03s] DEBUG: Required seat has stopped
[+0.03s] DEBUG: Stopping display manager
[+0.03s] DEBUG: Display manager stopped
[+0.03s] DEBUG: Stopping daemon
[+0.03s] DEBUG: Exiting with return value 1
[spike@zenboy ~]$ exit	

.xsession-errors

	  /usr/bin/iceauth:  creating new authority file /run/user/1000/ICEauthority
gpg-agent[729]: WARNING: "--write-env-file" is an obsolete option - it has no effect
gpg-agent: a gpg-agent is already running - not starting a new one

(xfce4-session:661): xfce4-session-WARNING **: 10:22:01.772: gpg-agent returned no PID in the variables
xfwm4-Message: 10:22:01.897: Prefer XPresent with Mesa Intel(R) UHD Graphics (CML GT2)

** (wrapper-2.0:772): WARNING **: 10:22:02.143: No outputs have backlight property

(wrapper-2.0:773): GLib-GIO-CRITICAL **: 10:22:02.145: g_file_new_for_path: assertion 'path != NULL' failed

(wrapper-2.0:773): GLib-GIO-CRITICAL **: 10:22:02.145: g_file_monitor_file: assertion 'G_IS_FILE (file)' failed

(wrapper-2.0:773): GLib-GObject-WARNING **: 10:22:02.145: invalid (NULL) pointer instance

(wrapper-2.0:773): GLib-GObject-CRITICAL **: 10:22:02.145: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(wrapper-2.0:773): Gtk-WARNING **: 10:22:02.145: Attempting to add a widget with type GtkToggleButton to a container of type XfcePanelPlugin, but the widget is already inside a container of type XfcePanelPlugin, please remove the widget from its existing container first.

(wrapper-2.0:771): libnotify-WARNING **: 10:22:02.162: Failed to connect to proxy

(xfce4-session:661): GLib-WARNING **: 10:22:02.445: GChildWatchSource: Exit status of a child process was requested but ECHILD was received by waitpid(). See the documentation of g_child_watch_source_new() for possible causes.

** (xfce4-screensaver:864): WARNING **: 10:22:02.621: screensaver already running in this session

(wrapper-2.0:772): Gtk-WARNING **: 10:22:02.673: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PowerManagerButton)

(wrapper-2.0:770): Gtk-WARNING **: 10:22:02.674: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)

(wrapper-2.0:771): Gtk-WARNING **: 10:22:02.675: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)

(wrapper-2.0:774): Gtk-WARNING **: 10:22:02.675: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner XfceArrowButton)

(wrapper-2.0:773): Gtk-WARNING **: 10:22:02.676: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)
blueman-applet 10.22.02 WARNING  PluginManager:147 __load_plugin: Not loading PPPSupport because its conflict has higher priority
blueman-applet 10.22.02 WARNING  PluginManager:147 __load_plugin: Not loading DhcpClient because its conflict has higher priority
weather-Message: 10:22:02.787: getting https://api.met.no/weatherapi/sunrise/2.0/?lat=36.178799&lon=-115.171501&date=2020-12-02&offset=-08:00&days=5
weather-Message: 10:22:02.787: getting https://api.met.no/weatherapi/locationforecast/2.0/classic?lat=36.178799&lon=-115.171501&altitude=634

(blueman-tray:936): Gdk-CRITICAL **: 10:22:03.176: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed
[Child 1560, MediaDecoderStateMachine #1] WARNING: Decoder=7f9cad1e0c00 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-83.0/dom/media/MediaDecoderStateMachine.cpp:3471
[Child 1560, MediaDecoderStateMachine #1] WARNING: Decoder=7f9cad1e0c00 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-83.0/dom/media/MediaDecoderStateMachine.cpp:3471
[Child 1560, MediaDecoderStateMachine #2] WARNING: Decoder=7f9c9a5c0c00 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-83.0/dom/media/MediaDecoderStateMachine.cpp:3471
[Child 1560, MediaDecoderStateMachine #2] WARNING: Decoder=7f9c9a5c0c00 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-83.0/dom/media/MediaDecoderStateMachine.cpp:3471
[Child 1560, MediaDecoderStateMachine #2] WARNING: Decoder=7f9c978c1800 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-83.0/dom/media/MediaDecoderStateMachine.cpp:3471
[Child 1560, MediaDecoderStateMachine #2] WARNING: Decoder=7f9c978c1800 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-83.0/dom/media/MediaDecoderStateMachine.cpp:3471
[Child 1560, MediaDecoderStateMachine #2] WARNING: Decoder=7f9c978c1800 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-83.0/dom/media/MediaDecoderStateMachine.cpp:3471
[Child 1560, MediaDecoderStateMachine #2] WARNING: Decoder=7f9c777aec00 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-83.0/dom/media/MediaDecoderStateMachine.cpp:3471
[Child 1560, MediaDecoderStateMachine #2] WARNING: Decoder=7f9c777aec00 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<MediaSourceTrackDemuxer::SamplesPromise> mozilla::MediaSourceTrackDemuxer::DoGetSamples(int32_t): manager is detached.: file /build/firefox/src/firefox-83.0/dom/media/MediaDecoderStateMachine.cpp:3471

(xfce4-terminal:2292): Gtk-WARNING **: 10:52:44.472: TerminalWidget 0x55a67cb81a30 reported min size 22 and natural size 12 in get_preferred_width(); natural size must be >= min size
Gdk-Message: 11:08:55.777: xfdesktop: Fatal IO error 4 (Interrupted system call) on X server :0.

Gdk-Message: 11:08:55.779: xfwm4: Fatal IO error 4 (Interrupted system call) on X server :0.0.
	 

If there is anything else needed I am happy to provide it. I have today done the latest upgrades in order to stay current and also in hopes of getting lucky. I got the 5.9.13 kernel, newer nvidia drivers (455.45.01-1) and systemd, but I’m still having the same issue.

Thanks for any pointers or tips you can give, I’m not sure what to try next.

Last edited by andheisus (2020-12-10 20:29:15)

Offline

#2 2020-12-10 09:03:50

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,237

Re: [Solved] LightDM Failed to Start After Updates – Blinking Cursor

Your optimus-manager is broken due to the python 3.9 bump, rebuild optimus-manager. For in repo packages this is taken care of by the packagers, out of repo you should ensure you rebuild all the python packages you have from the AUR against the new python library.

This is a ~ yearly process, whenever there's a major python version bump.

Last edited by V1del (2020-12-10 09:06:23)

Online

#3 2020-12-10 20:28:32

andheisus
Member
Registered: 2016-04-16
Posts: 10

Re: [Solved] LightDM Failed to Start After Updates – Blinking Cursor

Exactly right, V1del, thanks so much. I was getting so many error messages in the logs it would have taken quite a while to sort that out. The optimus-manager AUR page already had it fully documented, too. Thanks again!

Offline

Board footer

Powered by FluxBB