You are not logged in.

#1 2020-12-16 16:58:09

akjanik
Member
Registered: 2017-11-13
Posts: 18

pulseaudio-modules-bt-git failed to upgrade

After running `yay -Syu`, I am getting following error while updating `pulseaudio-modules-bt-git`

[100%] Built target module-bluez5-device
Install the project...
-- Install configuration: "Release"
-- Installing: /home/adam/.cache/yay/pulseaudio-modules-bt-git/pkg/pulseaudio-modules-bt-git/usr/lib/pulse-14.0/modules/libbluez5-util.so
-- Set runtime path of "/home/adam/.cache/yay/pulseaudio-modules-bt-git/pkg/pulseaudio-modules-bt-git/usr/lib/pulse-14.0/modules/libbluez5-util.so" to "/usr/lib/pulseaudio:/usr/lib/pulse-14.0/modules"
-- Installing: /home/adam/.cache/yay/pulseaudio-modules-bt-git/pkg/pulseaudio-modules-bt-git/usr/lib/pulse-14.0/modules/module-bluez5-discover.so
-- Set runtime path of "/home/adam/.cache/yay/pulseaudio-modules-bt-git/pkg/pulseaudio-modules-bt-git/usr/lib/pulse-14.0/modules/module-bluez5-discover.so" to "/usr/lib/pulseaudio:/usr/lib/pulse-14.0/modules"
-- Installing: /home/adam/.cache/yay/pulseaudio-modules-bt-git/pkg/pulseaudio-modules-bt-git/usr/lib/pulse-14.0/modules/module-bluez5-device.so
-- Set runtime path of "/home/adam/.cache/yay/pulseaudio-modules-bt-git/pkg/pulseaudio-modules-bt-git/usr/lib/pulse-14.0/modules/module-bluez5-device.so" to "/usr/lib/pulseaudio:/usr/lib/pulse-14.0/modules"
-- Installing: /home/adam/.cache/yay/pulseaudio-modules-bt-git/pkg/pulseaudio-modules-bt-git/usr/lib/pulse-14.0/modules/module-bluetooth-discover.so
-- Set runtime path of "/home/adam/.cache/yay/pulseaudio-modules-bt-git/pkg/pulseaudio-modules-bt-git/usr/lib/pulse-14.0/modules/module-bluetooth-discover.so" to "/usr/lib/pulseaudio:/usr/lib/pulse-14.0/modules"
-- Installing: /home/adam/.cache/yay/pulseaudio-modules-bt-git/pkg/pulseaudio-modules-bt-git/usr/lib/pulse-14.0/modules/module-bluetooth-policy.so
-- Set runtime path of "/home/adam/.cache/yay/pulseaudio-modules-bt-git/pkg/pulseaudio-modules-bt-git/usr/lib/pulse-14.0/modules/module-bluetooth-policy.so" to "/usr/lib/pulseaudio:/usr/lib/pulse-14.0/modules"
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "pulseaudio-modules-bt-git"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: pulseaudio-modules-bt-git 1:.r149.dbb5164-1 (Wed 16 Dec 2020 05:47:11 PM CET)
==> Cleaning up...
the PKGDEST for pulseaudio-modules-bt-git is listed by makepkg but does not exist: /home/adam/.cache/yay/pulseaudio-modules-bt-git/pulseaudio-modules-bt-git-1:14.0.r149.dbb5164-2-x86_64.pkg.tar.xz

but when I ls into mentioned directory there is some file, just named slightly differently

[adam@adam ~]$ ls /home/adam/.cache/yay/pulseaudio-modules-bt-git/ -la
total 188
drwxr-xr-x  5 adam adam  4096 Dec 16 17:47 .
drwxr-xr-x 24 adam adam  4096 Dec 15 12:52 ..
drwxr-xr-x  8 adam adam  4096 Dec 16 17:46 .git
-rw-r--r--  1 adam adam  1547 Dec 16 17:47 PKGBUILD
drwxr-xr-x  7 adam adam  4096 Dec 16 17:32 pulseaudio
drwxr-xr-x  7 adam adam  4096 Dec 16 17:32 pulseaudio-modules-bt
-rw-r--r--  1 adam adam 78356 Dec 16 17:47 pulseaudio-modules-bt-git-1:.r149.dbb5164-1-x86_64.pkg.tar.xz
-rw-r--r--  1 adam adam 77992 Oct  6 17:18 pulseaudio-modules-bt-git-r148.75af499-2-x86_64.pkg.tar.xz
-rw-r--r--  1 adam adam   932 Dec 16 17:32 .SRCINFO

I guess there is a problem with filename `pulseaudio-modules-bt-git-1:.r149.dbb5164-1-x86_64.pkg.tar.xz`, it should be named `pulseaudio-modules-bt-git-1:14.0.r149.dbb5164-2-x86_64.pkg.tar.xz` or name validation by installer should be less strict.
Is it a bug? If so, where can I report this?  Can I check if file on the server has correct name?
Can I somehow fix it locally?

Offline

#2 2020-12-16 17:23:44

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,189
Website

Re: pulseaudio-modules-bt-git failed to upgrade

Mod note: Moving to AUR Issues.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2020-12-16 17:34:16

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,315

Re: pulseaudio-modules-bt-git failed to upgrade

You might want to mention in the title that yay is failing. It would probably work fine doing it normally.

Offline

#4 2020-12-16 17:53:11

akjanik
Member
Registered: 2017-11-13
Posts: 18

Re: pulseaudio-modules-bt-git failed to upgrade

It would probably work fine doing it normally.

Can you elaborate? I've been using yay for years to (un)install/update programs and it became a "normal" way for managing system.

Offline

#5 2020-12-16 18:02:53

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,229

Re: pulseaudio-modules-bt-git failed to upgrade

Meaning yay is not the normal way it's your 'normal', but, using makepkg is normal/prefered.
'pulseaudio-modules-bt-git' updates fine.

Offline

Board footer

Powered by FluxBB