You are not logged in.

#1 2020-12-17 09:28:48

JonnyRobbie
Member
Registered: 2015-04-28
Posts: 154

Proper handling versioned `provides` field

I wanted to switch from repo cairo package to aur's cairo-git packages. But when installing I had an error:

error: failed to prepare transaction (could not satisfy dependencies)
:: removing cairo breaks dependency 'cairo>=1.14.0' required by gimp-git

At first glance I thought that maybe cairo-git forgot to put provides field in the PKGBUILD, but looking at it, it is there correctly. So the second idea I had is that the issue is gimp-git's rescriction on pkgver. But at this point, I don't know how to fix that.

Which PKGBUILD would you amend and how?

Offline

#2 2020-12-17 11:18:02

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,968
Website

Re: Proper handling versioned `provides` field

cairo-git needs

provides=('cairo=1.17.2')

Offline

Board footer

Powered by FluxBB