You are not logged in.

#1 2020-12-20 11:25:41

QBrunner
Member
Registered: 2019-11-10
Posts: 8

[SOLVED]SDDM not working. Stuck at boot

I have recently installed Arch again on my desktop. I prefer KDE so I installed it, as well as sddm. I enabled sddm with systemctl enable sddm.service and otherwise followed the arch installation as stated on the wiki. When I boot now it just hangs forever. I can log into any other tty no problem, but on tty1 nothing happens. Gnome for example works so I figured I must have some problem with sddm or maybe even kde. Restarting sddm works, but then I just have a login screen but I can't actually log in, since when I log in sddm just goes away and then appears again.

I have an i7-4790, a gtx1070ti and I am using the proprietary drivers.

Here's the journalctl output
https://pastebin.com/JMA3cEtX

If you need any more information let me know.

Thank you in advance!

Last edited by QBrunner (2020-12-20 13:20:33)

Offline

#2 2020-12-20 12:22:41

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,526

Re: [SOLVED]SDDM not working. Stuck at boot

You have a intel driver trying to identify screens. Easiest way would be to just ensure it doesn't interfere by disabling it in your BIOS/UEFI and make sure your screens are actually connected to the dedicated graphics card rather than the motherboards output.

Maybe also post a xorg log: https://wiki.archlinux.org/index.php/Xorg#General

Last edited by V1del (2020-12-20 12:24:21)

Offline

#3 2020-12-20 12:40:33

QBrunner
Member
Registered: 2019-11-10
Posts: 8

Re: [SOLVED]SDDM not working. Stuck at boot

This is the Xorg Log:https://pastebin.com/fKeKgyND
And the Display is plugged into the gpu via display port.

Offline

#4 2020-12-20 12:44:53

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,526

Re: [SOLVED]SDDM not working. Stuck at boot

That's not a complete log and no mention of any graphics module at all, is nvidia-utils installed? Did you do any xorg configuration?

Last edited by V1del (2020-12-20 12:45:14)

Offline

#5 2020-12-20 12:55:21

QBrunner
Member
Registered: 2019-11-10
Posts: 8

Re: [SOLVED]SDDM not working. Stuck at boot

That's what grep -e Log -e tty Xorg.0.log gave me. Nvidia utils is installed, both the 64 and the 32 bit variants. And besides changing /etc/X11/xorg.conf.d/00-keyboard.conf to
Section "InputClass"
        Identifier "keyboard"
        MatchIsKeyboard "yes"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "nodeadkeys"
EndSection

I didnt change anything about xorg.

Offline

#6 2020-12-20 12:56:29

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,526

Re: [SOLVED]SDDM not working. Stuck at boot

That's for identifying the date of the log, for actually checking what's happening the complete log is more useful.

Offline

#7 2020-12-20 13:01:49

QBrunner
Member
Registered: 2019-11-10
Posts: 8

Re: [SOLVED]SDDM not working. Stuck at boot

https://pastebin.com/pc9JUH2v here is the logfile. Sorry for the wait.

Offline

#8 2020-12-20 13:08:00

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,526

Re: [SOLVED]SDDM not working. Stuck at boot

sudo journalctl -b

after the log in attempt? Have you disabled the intel GPU now? There's nothing wrong logwise, but it seems to detect the nvidia GPU multiple times and then normally shut down xorg after 30 seconds, so I'm wondering what happens after the log in which isn't covered in the outputs so far.

Offline

#9 2020-12-20 13:15:10

QBrunner
Member
Registered: 2019-11-10
Posts: 8

Re: [SOLVED]SDDM not working. Stuck at boot

This is the output of sudo journalctl -b https://pastebin.com/43LGXARu

With disabling the intel gpu I just end up in an infinite login screen. So sddm appears, I log in and sddm appears again.

Offline

#10 2020-12-20 13:20:08

QBrunner
Member
Registered: 2019-11-10
Posts: 8

Re: [SOLVED]SDDM not working. Stuck at boot

It actually works now. I think the issue was that sddm was trying to launch a session that didn't exist. Thank you for the help and especially the tip with the igpu.

Offline

Board footer

Powered by FluxBB