You are not logged in.

#1 2020-12-28 11:39:53

baboulinet
Member
Registered: 2020-12-28
Posts: 2

[SOLVED] No vboxvideo_dri.so driver found

Hi,

I'm trying to run arch in virtualbox with graphical support. I'm using vagrant to manage the virtual machine, and the official archlinux/archlinux box.

The virtualbox-guest-utils-nox package is installed by default in the box. So I replaced it with virtualbox-guest-utils instead, to have X support.

I also installed xorg-server and xorg-xinit.

When I execute the following:

$ startx

I got the following error:

MESA-LOADER: failed to open vboxvideo: /usr/lib/dri/vboxvideo_dri.so: cannot open shared object file: No such file or directory (search paths /usr/lib/dri)

and Xorg log shows:

[   153.366] (II) LoadModule: "glx"
[   153.366] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   153.368] (II) Module glx: vendor="X.Org Foundation"
[   153.368] 	compiled for 1.20.10, module version = 1.0.0
[   153.368] 	ABI class: X.Org Server Extension, version 10.0
[   153.368] (==) Matched vboxvideo as autoconfigured driver 0
[   153.368] (==) Matched modesetting as autoconfigured driver 1
[   153.368] (==) Matched fbdev as autoconfigured driver 2
[   153.368] (==) Matched vesa as autoconfigured driver 3
[   153.368] (==) Assigned the driver to the xf86ConfigLayout
[   153.368] (II) LoadModule: "vboxvideo"
[   153.368] (WW) Warning, couldn't open module vboxvideo
[   153.368] (EE) Failed to load module "vboxvideo" (module does not exist, 0)
[   153.368] (II) LoadModule: "modesetting"
[   153.368] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   153.369] (II) Module modesetting: vendor="X.Org Foundation"
[   153.369] 	compiled for 1.20.10, module version = 1.20.10
[   153.369] 	Module class: X.Org Video Driver
[   153.369] 	ABI class: X.Org Video Driver, version 24.1
[   153.369] (II) LoadModule: "fbdev"
[   153.369] (WW) Warning, couldn't open module fbdev
[   153.369] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   153.369] (II) LoadModule: "vesa"
[   153.369] (WW) Warning, couldn't open module vesa
[   153.369] (EE) Failed to load module "vesa" (module does not exist, 0)

So, do you know how can I get the vboxvideo_dri.so driver ?

Last edited by baboulinet (2020-12-28 14:16:24)

Offline

#2 2020-12-28 14:15:29

baboulinet
Member
Registered: 2020-12-28
Posts: 2

Re: [SOLVED] No vboxvideo_dri.so driver found

Well, I think I have found an answer to my question.

The fact that vboxvideo_dri.so can't be found is not a problem when using Xorg 1.19+, because virtualbox does not use that driver. Instead, it uses the vboxvideo kernel driver and the modsetting X driver.

If anyone encounter the same error, refer to https://bbs.archlinux.org/viewtopic.php?id=243586 for more details.

Offline

Board footer

Powered by FluxBB