You are not logged in.

#1 2020-12-30 16:45:36

momokrono
Member
Registered: 2016-10-27
Posts: 47

[Solved]Latest cuda update breaks linking

After the latest cuda update, ld fails at linking libcudadevrt and libcudart_static

/usr/bin/ld: cannot find -lcudadevrt
/usr/bin/ld: cannot find -lcudart_static

setting linker ldflags to /opt/cuda/targets/x86_64-linux/lib does not solve the problem.
I also tried to create symlinks with no success.

I've noticed also that those libraries appear only as static, while most of the others are shared objects. Is this normal?

Edit: solved after installing cuda-static, and this explains why after the update the package size is basically half of what it was before.

Last edited by momokrono (2020-12-30 16:52:42)

Offline

#2 2020-12-30 19:49:40

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,864

Re: [Solved]Latest cuda update breaks linking

Indeed, see https://bugs.archlinux.org/task/69021 for context.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#3 2020-12-30 20:00:42

momokrono
Member
Registered: 2016-10-27
Posts: 47

Re: [Solved]Latest cuda update breaks linking

Ok, all clear now.
However even if I'm able to compile now, every program compiled with the new libraries fails with a segfault (core dump). Should I report this or open a new thread?

Offline

#4 2020-12-30 20:08:51

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,864

Re: [Solved]Latest cuda update breaks linking

If you have all the packages installed and it's not due to the split, then yes a new bug report seems appropriate.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#5 2020-12-30 20:23:31

momokrono
Member
Registered: 2016-10-27
Posts: 47

Re: [Solved]Latest cuda update breaks linking

Yes I've installed every package and I'm basically where I was before the split, so at this point the segfault must be caused by the new release.

Edit: looking at the bug reports page it's been reported already that every program that relies on cuda is in fault state, downgrading seems to solve the issue and it's because cuda 11.2 requires nvidia 460.xx to work, so for everyone watching I'd suggest to not upgrade until the new nvidia driver comes out if you need cuda acceleration.

Last edited by momokrono (2020-12-30 20:28:28)

Offline

Board footer

Powered by FluxBB