You are not logged in.

#1 2021-01-01 20:03:09

awgolas
Member
Registered: 2021-01-01
Posts: 2

Fiio k3 USB DAC not usable as audio device

Just switched my main machine to arch. I've had a Fiio k3 DAC which worked without issue on Ubuntu 20.04. However, Arch won't register my DAC as an audio device.


This is the output from

dmesg

after plugging in my DAC.

[257599.238257] usb 1-3: new high-speed USB device number 36 using xhci_hcd
[257599.378797] usb 1-3: New USB device found, idVendor=2972, idProduct=0047, bcdDevice= 0.11
[257599.378798] usb 1-3: New USB device strings: Mfr=1, Product=3, SerialNumber=0
[257599.378813] usb 1-3: Product: K3
[257599.378814] usb 1-3: Manufacturer: FiiO 

Inputting the command

lsusb -D 36

returns

Cannot open 36

However, if I run

lsusb -t

it produces

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 10000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/8p, 10000M
    |__ Port 2: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/16p, 480M
    |__ Port 1: Dev 29, If 1, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 1: Dev 29, If 2, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 1: Dev 29, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 3: Dev 36, If 2, Class=Application Specific Interface, Driver=, 480M
    |__ Port 3: Dev 36, If 0, Class=Audio, Driver=, 480M
    |__ Port 3: Dev 36, If 1, Class=Audio, Driver=, 480M
    |__ Port 6: Dev 9, If 0, Class=Mass Storage, Driver=usb-storage, 480M
    |__ Port 8: Dev 3, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 8: Dev 3, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 14: Dev 4, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 14: Dev 4, If 1, Class=Wireless, Driver=btusb, 12M

Showing that it recognizes my DAC as an audio device, but has no driver.
I'm assuming it has something to do with the

    |__ Port 3: Dev 36, If 2, Class=Application Specific Interface, Driver=, 480M
    |__ ...If 0, Class=Audio, Driver=, 480M
    |__ ...If 1, Class=Audio, Driver=, 480M

But I'm not sure how to change the If statements or change the class of the device.
I've tried this with USB-C to USB-3.0, USB-C to USB-2.0, and USB-C to USB-C cables, and it all produces identical output.

pacmd list-sinks

also doesn't show the device.

What could I do to fix this?

Offline

#2 2021-01-01 20:44:56

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,733
Website

Re: Fiio k3 USB DAC not usable as audio device

https://www.reddit.com/r/HeadphoneAdvic … ith_linux/?

If that doesn't work compare the dmesg (or 'udevadm monitor') output from Ubuntu & Arch.

Offline

#3 2021-01-01 21:34:00

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,194
Website

Re: Fiio k3 USB DAC not usable as audio device

Works fine for me. Plug it in and set it up in PA.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#4 2021-01-01 22:13:17

progandy
Member
Registered: 2012-05-17
Posts: 4,140

Re: Fiio k3 USB DAC not usable as audio device

A quick sanity check: you have rebooted after your last kernel update, i.e. the versions reported by uname and pacman are the same?

uname -r
pacman -Q linux # or the kernel package you use

| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#5 2021-01-01 22:23:57

awgolas
Member
Registered: 2021-01-01
Posts: 2

Re: Fiio k3 USB DAC not usable as audio device

progandy wrote:

A quick sanity check: you have rebooted after your last kernel update, i.e. the versions reported by uname and pacman are the same?

uname -r
pacman -Q linux # or the kernel package you use

Nope, uname -r produces

5.9.14-arch1-1

and  pacman -Q linux produces

linux 5.10.4.arch2-1

I'll try a reboot.

That solved it. sometimes it's better that if you see hoof prints, don't go looking for zebras.

Last edited by awgolas (2021-01-02 00:57:05)

Offline

Board footer

Powered by FluxBB