You are not logged in.

#1 2021-01-01 23:56:46

woniududu
Member
Registered: 2021-01-01
Posts: 1

coppeliasim (vrep) crash

$ coppeliasim
[CoppeliaSimClient]    loading the CoppeliaSim library...
[CoppeliaSimClient]    done.
[CoppeliaSimClient:loadinfo]   launching CoppeliaSim...
[CoppeliaSim:loadinfo]   CoppeliaSim V4.1.0., (rev. 1), flavor: 1
[CoppeliaSim:loadinfo]   Legacy machine ID: 5000-9DEB-FFC4-9CEC-F7E3-841D
[CoppeliaSim:loadinfo]   Machine ID: FBE2-736C-70C4-0000-2A91-0101
[CoppeliaSim:loadinfo]   using the default Lua library.
[CoppeliaSim:loadinfo]   loaded the video compression library.
[CoppeliaSim:loadinfo]   if CoppeliaSim crashes now, try to install libgl1-mesa-dev on your system:
        >sudo apt install libgl1-mesa-dev
[CoppeliaSim:loadinfo]   OpenGL NVIDIA Corporation, Renderer: GeForce GTX 1070/PCIe/SSE2, Version: 4.6.0 NVIDIA 455.45.01
[CoppeliaSim:loadinfo]   simulator launched.
[CoppeliaSim:loadinfo]   plugin 'DynamicsBullet-2-78': loading...
[CoppeliaSim:loadinfo]   plugin 'DynamicsBullet-2-78': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'DynamicsBullet-2-83': loading...
[CoppeliaSim:loadinfo]   plugin 'DynamicsBullet-2-83': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'DynamicsNewton': loading...
[CoppeliaSim:loadinfo]   plugin 'DynamicsNewton': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'DynamicsOde': loading...
[CoppeliaSim:loadinfo]   plugin 'DynamicsOde': load succeeded.
[CoppeliaSim:loadinfo]   plugin 'DynamicsVortex': loading...
Sat Jan  2 07:38:44 2021 - ERROR: Compiled with the flag for AVX but not supported by the CPU.


Error: signal 11:

/usr/share/coppeliasim/libcoppeliaSim.so(_Z11_segHandleri+0x30)[0x7ff2d2839ae0]
/usr/lib/libc.so.6(+0x3d6a0)[0x7ff2d57396a0]
/usr/share/coppeliasim/libVxPlatform.so.2020.3(+0x2bdf4)[0x7ff2bc6d9df4]
/usr/share/coppeliasim/libVxPlatform.so.2020.3(_ZN2Vx8LogErrorEPKcz+0x9d)[0x7ff2bc6da20d]
/usr/share/coppeliasim/libVxPlatform.so.2020.3(+0x20e37)[0x7ff2bc6cee37]
/lib64/ld-linux-x86-64.so.2(+0x112de)[0x7ff2d63d72de]
/lib64/ld-linux-x86-64.so.2(+0x113c8)[0x7ff2d63d73c8]
/usr/lib/libc.so.6(_dl_catch_exception+0xe5)[0x7ff2d58370e5]
/lib64/ld-linux-x86-64.so.2(+0x15705)[0x7ff2d63db705]
/usr/lib/libc.so.6(_dl_catch_exception+0x88)[0x7ff2d5837088]

Offline

#2 2021-01-02 15:34:29

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 764

Re: coppeliasim (vrep) crash

This is what the Comments section is for on that AUR package - assuming it is an AUR package, since you added zero context to your post.

Last edited by twelveeighty (2021-01-02 15:34:48)

Offline

#3 2021-01-02 16:12:28

loqs
Member
Registered: 2014-03-06
Posts: 12,556

Re: coppeliasim (vrep) crash

Sat Jan  2 07:38:44 2021 - ERROR: Compiled with the flag for AVX but not supported by the CPU.

Does your system support AVX?

https://aur.archlinux.org/packages/coppeliasim/ is only rebundling an upstream provided bundle.  You could try building https://github.com/CoppeliaRobotics/CoppeliaSimLib although it looks to have lots of sub-projects and it may be the last one mentioned DynamicsVortex https://github.com/CoppeliaRobotics/simExtDynamics required AVX instead of the main binary.
Edit:

$ grep AVX -rl .
./libopencv_imgcodecs.so.4.0.1
./libQt5XcbQpa.so.5.12.5
./libVxCore.so.2020.3.0.68
./programming/b0RemoteApiBindings/cpp/msgpack-c/include/msgpack/predef/hardware/simd/x86/versions.h
./programming/b0RemoteApiBindings/cpp/msgpack-c/include/msgpack/predef/hardware/simd/x86.h
./libopencv_core.so.4.0.1
./libVxPlatform.so.2020.3.0.68
./libopencv_imgproc.so.4.0.1

Why is the AUR package listing the license as LGPL while it is bundling the Edu version which uses a custom license?

libopencv_imgcodecs.so.4.0.1
libopencv_core.so.4.0.1
libopencv_imgproc.so.4.0.1
Looks to be opencv as bundled is built with AVX enabled. See the Arch opencv package which I believe disables use of AVX.

libQt5XcbQpa.so.5.12.5
qt5-base

libVxCore.so.2020.3.0.68
libVxPlatform.so.2020.3.0.68
some part of coppeliasim

Last edited by loqs (2021-01-02 17:49:23)

Offline

Board footer

Powered by FluxBB