You are not logged in.

#1 2021-01-06 09:04:22

ulke
Member
Registered: 2011-04-29
Posts: 50

Gnome overrides locale, ignores language settings

I have set up a system to have one user account overriding the system locale and use German instead of English in Gnome. This used to work in the past, but now it doesn't. Since this account is not used often, I don't know exactly when it stopped working, but it must have been in the past six months or so.

/etc/locale.conf:

LANG=en_US.UTF-8
LC_PAPER=en_DK.UTF-8
LC_TIME=en_DK.UTF-8
LC_MEASUREMENT=en_DK.UTF-8
LC_MONETARY=en_DK.UTF-8
LC_NUMERIC=en_US.UTF-8

The user's ~/.config/locale.conf:

LANG=de_DE.UTF-8

When I log this user in on a virtual console, everything is in German as expected.

However, Gnome now insists on having everything in English. In the settings, under "Region & Language", "Language" is set to "Deutsch" and "Formats" is set to "Deutschland". I've tried setting both to English and back to German (logging out and back in after each change), but that didn't help. When I start a terminal window in Gnome, locale gives this result:

LANG=de_DE.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8

So LANG does get picked up, but then gets overridden by all the other variables for some reason. As mentioned before, this happens only when I use Gnome, not in a virtual console.

Any ideas?

Edit: Forgot version info. Gnome Shell 1:3.38.2+22+g3a343a8aa-1, gnome-settings-daemon 3.38.1-1.  I don't know what else could be relevant.

Last edited by ulke (2021-01-06 09:36:26)

Offline

#2 2021-02-06 14:41:44

ulke
Member
Registered: 2011-04-29
Posts: 50

Re: Gnome overrides locale, ignores language settings

Wrote a bug report.

Offline

#3 2021-02-06 19:06:19

shulamy
Member
From: israel
Registered: 2010-09-11
Posts: 436

Re: Gnome overrides locale, ignores language settings

i think you have to set the locale i gnome settings

because it overrides evrything

ezik

Offline

Board footer

Powered by FluxBB