You are not logged in.

#1 2021-01-06 14:11:22

Filip62
Member
From: Slovakia
Registered: 2020-10-24
Posts: 21

[SOLVED] Eclipse IDE doesn't launch, can't load SWT.

Hi!

I run jdk-openj9-bin from the AUR (version 15.0.1b9_openj9_0.23.0-1 as of now)

I downloaded the official Eclipse installer and installed the IDE, selecting my Java 15 runtime (The installer says Java 11+, so 15 should work.)

Installation went fine, but when I try to open any Eclipse IDE version (for Java or C++ or Rust), all of them refuse to start with the message
"An error has occurred see the log file file ..."

tree ~/.swt
/home/filip/.swt
└── lib
   └── linux
      └── x86_64
         └── libswt-pi3-gtk-4940r23.so

I tried removing the .swt folder and installing libswt from official arch repositories, but that didn't help because it wants "libswt-pi4...", which isn't a part of that package.
Then I tried renaming the "libswt-pi3-gtk-4940r23.so" to "libswt-pi4-gtk-4940r23.so", but that also did not help.

The .swt files get created/downloaded automatically when I launch Eclipse without the official arch libswt package installed.

It works when launching with the jdk11-openj9-bin, and jdk-openjdk(that is Java 14 as of now) packages from the AUR and official arch repositories respectively.

I also created a new topic on the Eclipse forums, but no replies after 24 hours.
I did find very similar issues, but they were old or people were just missing the swt libraries or the Java search path was misconfigured or so, but no relation to Java 15.
There is no mention anywhere, as far as I could tell, that Java 15 isn't supported.

Thank You for help.

Last edited by Filip62 (2021-01-06 16:52:29)

Offline

#2 2021-01-06 14:42:28

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,887

Re: [SOLVED] Eclipse IDE doesn't launch, can't load SWT.

Doesn't look like a java error to me, but eclipse needing a newer swt version then arch provides.

The package has been flagged as out of date since last april and the latest released is 4.18 (or 12 versions later) .
You may want to look into building your own uptodate swt version .

An alternative could be an aur pacakge for eclipse as mentioned on https://wiki.archlinux.org/index.php/Eclipse


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2021-01-06 15:26:09

Filip62
Member
From: Slovakia
Registered: 2020-10-24
Posts: 21

Re: [SOLVED] Eclipse IDE doesn't launch, can't load SWT.

The aur packages are either out of date or packaged insanely bad.

The thing is, it works with other java versions, the swt library in the .swt folder is downloaded by eclipse ide, so I do not need to use the arch libswt package.

Offline

#4 2021-01-06 16:51:48

Filip62
Member
From: Slovakia
Registered: 2020-10-24
Posts: 21

Re: [SOLVED] Eclipse IDE doesn't launch, can't load SWT.

It doesn't work with:
- AdoptOpenJDK 15 OpenJ9

It does work with:
- AdoptOpenJDK 15 Hotspot
- AdoptOpenJDK 14 OpenJ9
- AdoptOpenJDK 11 OpenJ9

Last edited by Filip62 (2021-01-06 18:57:15)

Offline

Board footer

Powered by FluxBB