You are not logged in.

#1 2021-01-05 15:30:40

gsgleason
Member
Registered: 2012-10-08
Posts: 69

[SOLVED] CS:GO mic push-to-talk causes short freeze on kernel 5.10

Ever since kernel 5.10, when I use the mic key in CSGO, there is a brief freeze, about .2 seconds, where audio and video stops.  The video freezes and the audio cuts out, then resumes.

Subsequent mic use works as long as I use it often enough.  After a certain perion (maybe a minute, not sure) of not using the mic, the next use of the mic will trigger the freeze.

Downgrading to kernel 5.9.14 and the associated nvidia driver fixes the issue, as does booting to linux-lts/nvidia-lts.

X570 Aorus Elite WIFI motherboard
AMD Ryzen 9 3950X
Nvidia RTX 2070 Super

Everything is up to date.

I tried reproducing it with arecord from the cli but that doens't have the issue.

I am using pulseaudio and alsa with no custom config. 

I don't even know how to troubleshoot something like this.

Last edited by gsgleason (2021-01-07 17:14:21)

Offline

#2 2021-01-07 14:33:44

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,851

Re: [SOLVED] CS:GO mic push-to-talk causes short freeze on kernel 5.10

Educated guess, the power save on snd_hda_intel and the relevant device wakeup.

Try

options snd_hda_intel power_save=0

in a file in /etc/modprobe.d/snd.conf

Offline

#3 2021-01-07 17:19:14

gsgleason
Member
Registered: 2012-10-08
Posts: 69

Re: [SOLVED] CS:GO mic push-to-talk causes short freeze on kernel 5.10

V1del wrote:

Educated guess, the power save on snd_hda_intel and the relevant device wakeup.

Try

options snd_hda_intel power_save=0

in a file in /etc/modprobe.d/snd.conf

Thank you.  This fixed it.

To test, I ran this:

echo 0 | sudo dd of=/sys/module/snd_hda_intel/parameters/power_save

There was no freeze.

I set it to 1 and restarted csgo and indeed the problem was back.

I've created the permanent config file to keep it persistent.

It seems this was changed with 5.10 to default to 10 seconds.

Thank you again.

[UPDATE]

The problem came back after a few more updates.  This ended up fixing it at that point:

/etc/pulse/default.pa

## comment this out
#load-module module-suspend-on-idle

Last edited by gsgleason (Yesterday 15:23:39)

Offline

Board footer

Powered by FluxBB