You are not logged in.

#1 2021-01-10 18:34:27

Registered: 2012-09-13
Posts: 24

The recent VTE update breaks fonts in terminal

I'm using Tilix on Gnome Wayland. I have been using the Roboto Mono (medium) fonts in the terminal.
The recent update of the vte packages causes only the "regular" font style being used. I tried to change the style to "thin", "light", and "medium" but it always show the same regular font.
Didin't spend much time on this issue so that's all I have right now.


#2 2021-01-11 16:01:53

Registered: 2021-01-11
Posts: 1

Re: The recent VTE update breaks fonts in terminal

I have experienced the same result using guake and Xorg. I have two laptops that I keep relatively in sync - my daily driver which is most up to date with vte*-0.62.2-1 experiences the broken font selection. I can select my preferred font in guake preferences, but this font is not displayed. My other laptop (still on vte*--0.62.1-2) has no problem with guake using my preferred font, which happens to be FreeMono Bold Oblique.
Here is a link to terminal screenshots: … sp=sharing

Reverting to vte*--0.62.1-2 and a reboot on my daily driver allows guake terminal font selection to behave as expected.

Edit: corrected URL for actual discussion/potential solutions
This might be a gnome:vte bug as reported here:

If you revert to vte*--0.62.1-2 as I did, you can add this line to /etc/pacman.conf to temporarily disable vte* updates:
IgnorePkg   = vte3 vte-common

Of course this is not recommended without monitoring the impact, but hopefully 'fixed' vte* packages will be released by gnome devs and brought into Arch. It looks like that is the direction suggested by the gnome bug discussion.

Last edited by utiac (2021-01-14 14:59:37)


Board footer

Powered by FluxBB