You are not logged in.

#1 2021-01-12 05:56:01

sheey
Member
Registered: 2021-01-12
Posts: 2

grub failed to be detected after re-plugged in the usb hard disk

I installed Arch Linux on a usb hard disk, but after I plugged out and re-plugged in the usb cable, BIOS cannot recognize the bootloader and I cannot boot to Arch Linux.
Then I plug in the installation media, go through the grub installation process like following, then it works again, I can see arch_linux in BIOS.

# in arch installation iso
genfstab /mnt >> /mnt/etc/fstab

arch-chroot /mnt

grub-install --target=x86_64-efi --efi-directory=/boot/EFI/ --bootloader-id=arch_linux --recheck
grub-mkconfig -o /boot/grub/grub.cfg

I was keen to found out the source of the problem, so I plugged out and re-plugged in the usb cable. After many tries, I found ONLY reinstall the grub can solve this problem.
But it's not possible for me to reinstall the grub everytime I plug out the usb cable.

thanks a lot.

Last edited by sheey (2021-01-13 01:25:11)

Offline

#2 2021-01-12 06:36:19

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,716
Website

Re: grub failed to be detected after re-plugged in the usb hard disk

Offline

#3 2021-01-13 01:22:31

sheey
Member
Registered: 2021-01-12
Posts: 2

Re: grub failed to be detected after re-plugged in the usb hard disk

thanks, that really solved my problem.

Offline

#4 2021-01-14 17:48:20

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,716
Website

Re: grub failed to be detected after re-plugged in the usb hard disk

Good news, please prepend [SOLVED] to the thread title to help others who encounter this issue.

Offline

Board footer

Powered by FluxBB