You are not logged in.

#1 2021-01-13 02:03:22

crystaldust
Member
Registered: 2016-05-29
Posts: 2

Macbook Pro 2016 won't boot into Arch Linux

Hello Community!

I'm recently trying to install Arch Linux to my old MacBook pro(with big sur updated) while the book won't boot into the EFI USB of the latest iso image, when selecting the 'EFI USB' in the boot selection screen(boot with option key pressed), it turns into black screen and nothing is showing.

I clearly remember that I successfully installed Arch on this book at the end of year 2019, so I tried to switch to 2019.10 iso, I can boot to the live cd but got a keyring issue, then I switched to 2019.12, everything is back! I install Arch on my external harddisk, then reboot, but this time, when I try boot into the newly installed Arch Linux, again, black screen and nothing showing. After checking several times I'm sure there is no problems of the new Arch Linux on my external hard disk. I even plug it into another normal PC, it works well(I can boot into the new system and see the login console).

So that's pretty weird, seems like Macbook has filtered the latest Arch boot file and only some versions can successfully boot. I'm not sure if there are some differences between the different Arch's boot files. Would like to talk about it here and see if we can dig up something.

Btw, some side context:
1. I've turned off the SIP(something like Secure Boot on other UEFI PCs)
2. I also tried some archboot ISOs, the 2020.7 version won't boot, 2016.8 shows the boot menu, but the screen got stuck and lost response after selecting UEFI iso. Considering the fails on latest ISOs boot and the success on 2019.12 ISO, I guess the boot files are different and Macbook's boot system treat them differently.
3. I  installed bootctl in the new Arch Linux system.

Offline

Board footer

Powered by FluxBB