You are not logged in.

#1 2021-01-13 20:40:37

vdegenne
Member
Registered: 2020-06-02
Posts: 4

bluetooth not working anymore (wireless earplugs)

My bluetooth doesn't work anymore, I don't know if I changed sometimes that caused this issue or if upgrading the system is the reason. The problem is I updated the system many times since it is broken, at first I didn't care I just used wired earplugs and hoped time would solve the issue but now that I want to use wireless ones again it still doesn't work, and because this annoyes me I seek the help from the community.
Also bluetooth and wirelss earplugs pairing works on windows dual boot on the same computer so the hardware seems fine and no options in the BIOS is interesting.

Here's some information that could help to track the problem :

➜  ~ uname -r
5.10.6-arch1-1


➜  ~ lspci -nnk | grep -iA2 net
04:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
	Subsystem: AzureWave Device [1a3b:2126]
	Kernel driver in use: ath9k
--
05:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
	Subsystem: ASUSTeK Computer Inc. Device [1043:11cd]
	Kernel driver in use: r8169


➜  ~ sudo dmesg | egrep -i 'blue|firm'
[sudo] password for vdegenne: 
[    0.038463] [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x22 (or later)
[    0.236849] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    1.712097] psmouse serio4: elantech: assuming hardware version 4 (with firmware version 0x361f03)
[    1.925916] usb 3-5: Product: Bluetooth USB Host Controller
[    2.122534] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[    2.574426] [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
[    2.733452] Bluetooth: Core ver 2.22
[    2.733471] Bluetooth: HCI device and connection manager initialized
[    2.733474] Bluetooth: HCI socket layer initialized
[    2.733476] Bluetooth: L2CAP socket layer initialized
[    2.733479] Bluetooth: SCO socket layer initialized
[    2.807092] Bluetooth: hci0: don't support firmware rome 0x1020200
[    2.905041] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    2.905042] Bluetooth: BNEP filters: protocol multicast
[    2.905045] Bluetooth: BNEP socket layer initialized
[    2.905305] random: bluetoothd: uninitialized urandom read (4 bytes read)
[   78.832178] audit: type=1131 audit(1610569279.949:118): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=blueman-mechanism comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

The bluetoothd service is running and enabled on start.
I am using i3 but if I run gnome the dropdown menu says "Bluetooth off" and if I click and develop a menu item says "Turn Off", in other words gnome thinks the bluetooth is on but the UI says otherwise (!)

Another piece of information, if I try to run "bluetoothctl" and "power on" it says "No default controller available".

I really don't know what's going on and can't fix it myself, please help.

Thanks

Offline

#2 2021-01-14 02:47:07

neo64yt
Member
Registered: 2021-01-11
Posts: 1
Website

Re: bluetooth not working anymore (wireless earplugs)

Kernel 5.10 currently has a problem with bluetooth. You should either downgrade to 5.9, using the LTS kernel or patch the kernel yourself. It is recommended to use the LTS version though.

Last edited by neo64yt (2021-01-14 02:51:37)


Le Neo the youtuber

Offline

#3 2021-01-15 12:48:22

vdegenne
Member
Registered: 2020-06-02
Posts: 4

Re: bluetooth not working anymore (wireless earplugs)

neo64yt wrote:

Kernel 5.10 currently has a problem with bluetooth. You should either downgrade to 5.9, using the LTS kernel or patch the kernel yourself. It is recommended to use the LTS version though.

Yes I heard that also somewhere else, I'll give it a try.
Thanks

Offline

#4 2021-01-16 12:53:34

musterzwerg
Member
Registered: 2017-03-31
Posts: 2

Re: bluetooth not working anymore (wireless earplugs)

Hi, I have the same problem, even with the LTS-Kernel.

Offline

#5 2021-01-31 01:58:51

igorog
Member
Registered: 2018-05-15
Posts: 3

Re: bluetooth not working anymore (wireless earplugs)

Is a fix for this bug planned? The problem is already 2 months old.

Offline

#6 2021-01-31 11:40:48

ugjka
Member
From: Latvia
Registered: 2014-04-01
Posts: 1,618
Website

Re: bluetooth not working anymore (wireless earplugs)

https://bugzilla.kernel.org/show_bug.cgi?id=210681

I have downgraded to 5.9.14 and put the kernel on ignore in pacman.conf


Fix yo shit: journalctl -b -p warning
Website (ipv6-only)
"Learning the hard way is the only way for many."
Advaita: Robert Adams, Francis Lucille, Rupert Spira

Offline

#7 2021-02-01 00:19:14

igorog
Member
Registered: 2018-05-15
Posts: 3

Re: bluetooth not working anymore (wireless earplugs)

ugjka wrote:

https://bugzilla.kernel.org/show_bug.cgi?id=210681

I have downgraded to 5.9.14 and put the kernel on ignore in pacman.conf

Why roll back? Is this a good idea? (By the way, I have a lts kernel installed in parallel.)
Isn't it easier to fix this in the newest kernel? Moreover, there is a fix for this bluetooth module and it works great.

Last edited by igorog (2021-02-01 01:29:04)

Offline

Board footer

Powered by FluxBB