You are not logged in.

#1 2021-01-15 14:23:48

manystars
Member
Registered: 2021-01-12
Posts: 7

[SOLVED] systemd-boot Failed to mount /sysroot

Hi everyone,

I'm trying to install Arch on a VM before running on my PC, configuring it to run with LUKS2 and systemd-boot. I get the error after rebooting.

systemd[1]: Failed to mount /sysroot.
[FAILED] Failed to mount /sysroot.
See 'sysctl status sysroot.mount' for details.
[DEPEND] Dependency failed for Initrd Root File System.
[DEPEND] Dependency failed for Reload Configuration from the Real Root.

You are in emergency mode. After logging in,.......
Cannot open access to console, the root account is locked.
See sulogin(8) man page for more details.


These are my settings:

sda                                                                         
├─sda1
│    vfat   FAT32       8FC4-FA7F                                           
└─sda2
     crypto 2           95d50689-d8f1-4de1-8a56-9d15dd6a8f48               
  └─cryptroot
     f2fs   1.14        47b1d1b6-f63d-4f53-a000-f8d91320fdb8 

    Device             Start         End     Sectors     Size Type
>>  /dev/sda1           2048     1050623     1048576     512M EFI System           
    /dev/sda2        1050624    42102110    41051487    19.6G Linux root (x86-64)


/etc/mkinitcpio.conf:

MODULES=(f2fs)
HOOKS=(base systemd autodetect keyboard sd-vconsole modconf block sd-encrypt filesystem fsck)

/boot/loader/loader.conf:

timeout 3
console-mode keep
default Arch

/boot/loader/entries/arch.conf:

title   Arch
initrd  /initramfs-linux.img
linux   /vmlinuz-linux
options rd.luks.name=95d50689-d8f1-4de1-8a56-9d15dd6a8f48=cryptroot root=dev/mapper/cryptroot

#/dev/sda2             95d50689-d8f1-4de1-8a56-9d15dd6a8f48
#/dev/mapper/cryptroot 47b1d1b6-f63d-4f53-a000-f8d91320fdb8


I did not configure /etc/fstab.conf.

Would like to share the details from 'sysctl status sysroot.mount' but I could not access the console. Had already set a password for root after chroot.

Edit: corrected arch.conf

Last edited by manystars (2021-01-15 17:05:02)

Offline

#2 2021-01-15 14:31:10

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,418

Re: [SOLVED] systemd-boot Failed to mount /sysroot

Is that systemd-boot entry cut off, or is that really what you have?

Online

#3 2021-01-15 14:37:22

manystars
Member
Registered: 2021-01-12
Posts: 7

Re: [SOLVED] systemd-boot Failed to mount /sysroot

Yes the entry is cut off. Did not know it was needed.

Last edited by manystars (2021-01-15 14:43:38)

Offline

#4 2021-01-15 14:40:08

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,418

Re: [SOLVED] systemd-boot Failed to mount /sysroot

The entry, as in entries/arch.conf

Online

#5 2021-01-15 14:45:09

manystars
Member
Registered: 2021-01-12
Posts: 7

Re: [SOLVED] systemd-boot Failed to mount /sysroot

I see what you mean now, let me check.

Last edited by manystars (2021-01-15 14:47:16)

Offline

#6 2021-01-15 14:46:13

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,418

Re: [SOLVED] systemd-boot Failed to mount /sysroot

Then the problem should be obvious, that root= entry is not valid.

Online

#7 2021-01-15 14:52:06

manystars
Member
Registered: 2021-01-12
Posts: 7

Re: [SOLVED] systemd-boot Failed to mount /sysroot

Oh sorry yes it has been cut off.

title   Arch
    initrd  /initramfs-linux.img
    linux   /vmlinuz-linux
    options rd.luks.name=95d50689-d8f1-4de1-8a56-9d15dd6a8f48=cryptroot root=dev/mapper/cryptroot

    #/dev/sda2             95d50689-d8f1-4de1-8a56-9d15dd6a8f48
    #/dev/mapper/cryptroot 47b1d1b6-f63d-4f53-a000-f8d91320fdb8

I forgot to check when copy pasting from nano..

Offline

#8 2021-01-15 16:40:57

loqs
Member
Registered: 2014-03-06
Posts: 13,178

Re: [SOLVED] systemd-boot Failed to mount /sysroot

    options rd.luks.name=95d50689-d8f1-4de1-8a56-9d15dd6a8f48=cryptroot root=dev/mapper/cryptroot

Is there still a copy paste issue or is root=dev/mapper/cryptroot really missing the / after = before dev?

Last edited by loqs (2021-01-15 16:41:23)

Offline

#9 2021-01-15 17:01:21

manystars
Member
Registered: 2021-01-12
Posts: 7

Re: [SOLVED] systemd-boot Failed to mount /sysroot

loqs wrote:

Is there still a copy paste issue or is root=dev/mapper/cryptroot really missing the / after = before dev?

Yes it was missing a / before dev. So that was the issue all along! Thank you loqs big_smile

Offline

Board footer

Powered by FluxBB