You are not logged in.

#1 2021-01-13 20:45:21

utack
Member
Registered: 2014-10-20
Posts: 14

[Disappeared] Graphics or complete freezes since switching to Nvidia

Hello,

I have recently been lucky enough to find one of the Nvidia 3070 cards, but ever since I have either the graphics freezes or the complete system freezes.

I have tried a lot of things and this seems to be a problem specifically with Arch Linux right now

Here is the full version:
Freezes of Graphics (dmesg over ssh then shows XID errors 16,19 or 61) or entirely (sysrq keys dead)
Between 10min after boot and 3 days after boot randomly distributed
Linux 5.10.x, both normal and zen kernel
Happens with Nvidia 455, 460 beta and 460
Any desktop environment
Happens with PCIe3 and 4
UEFI reset was done
Memtest is clean
PSU was replaced (yikes) and also not the culprit

Here are the additional uncomfortable bits:
Does happen on an entirely fresh arch install on a USB drive
No problems on Windows over multiple days
Also does not happen on Ubuntu 21.04 prerelease with kernel 5.8.x on a USB drive (8 day streak of zero crashes before aborting the experiment)


Question:
Where do I go from here to narrow this down further
Down grade the kernel, wait for the next kernel release?
Try a different kernel flavour?
Try something different with the Nvidia config that Ubuntu uses by default?

Thank you for your help

Last edited by utack (2021-02-04 20:26:50)

Offline

#2 2021-01-13 21:13:15

seth
Member
Registered: 2012-09-03
Posts: 18,805

Re: [Disappeared] Graphics or complete freezes since switching to Nvidia

https://docs.nvidia.com/deploy/xid-errors/index.html

Did you try the lts kernel? (What version is the used ubuntu at?)

Online

#3 2021-01-13 21:42:13

utack
Member
Registered: 2014-10-20
Posts: 14

Re: [Disappeared] Graphics or complete freezes since switching to Nvidia

Thank you for the idea
Ubuntu was running 5.8.x
I will try the lts kernel and report back when it occurs or if it is crash free for ~5 days

Last edited by utack (2021-01-13 21:42:26)

Offline

#4 2021-01-14 21:47:17

utack
Member
Registered: 2014-10-20
Posts: 14

Re: [Disappeared] Graphics or complete freezes since switching to Nvidia

Update:
One freeze on LTS kernel/Nvidia 460
For now I will got back to Ubuntu to verify it is really stable and was not just a lucky 8 day occurence

Offline

#5 2021-01-14 21:54:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,186

Re: [Disappeared] Graphics or complete freezes since switching to Nvidia

Which driver version does Ubuntu use? There's a known crasher with 455 till 460, see https://forums.developer.nvidia.com/t/b … nce/155506 apparently they might've been able to mitigate it if we can believe the latest green post.

But that one's also quite random and not really guaranteed to be reproducible (I know it's still around, but didn't run into it for a few weeks now). Also maybe post an actually crashing log so we could check whether it's the same issue

Offline

#6 2021-01-15 23:03:34

utack
Member
Registered: 2014-10-20
Posts: 14

Re: [Disappeared] Graphics or complete freezes since switching to Nvidia

Ubuntu was using Nvidia 455

I am aware of this current problem in the Nvidia driver, but the null pointer occured only twice on arch and was visible in dmesg
The absolute majority of times it is spitting out one or two of the three XID codes 16,19 or 61 or I can't find out what happened because it is fully dead including ssh to access dmesg

I will once again verify it is absolutely stable in Ubuntu to fully exlude any chance it was the hardware and report back once again

Offline

#7 2021-01-16 10:02:31

hussam
Member
Registered: 2006-03-26
Posts: 564
Website

Re: [Disappeared] Graphics or complete freezes since switching to Nvidia

Try 450.102.4 driver as it was before the null pointer error started happening according to nvidia forums.
I have some other questions.
1) Is nvidia-drm modesetting enabled or disabled?
2) Are you using uefi or legacy bios?
3) Is nvidia-persistence daemon enabled or disabled?

Offline

#8 2021-01-26 20:36:11

utack
Member
Registered: 2014-10-20
Posts: 14

Re: [Disappeared] Graphics or complete freezes since switching to Nvidia

Sorry for the slow updates, but the testing needs a lot of time to be certain with such a rare bug

1) modesetting makes a huge difference. without it freezes still occur, but much much less frequently
2) uefi
3) it was enabled, disabling it changes nothing

Offline

#9 2021-02-04 20:27:11

utack
Member
Registered: 2014-10-20
Posts: 14

Re: [Disappeared] Graphics or complete freezes since switching to Nvidia

It is gone now 
Maybe a Kernel update, maybe a driver update

Offline

Board footer

Powered by FluxBB