You are not logged in.

#1 2021-01-13 17:27:07

Gogl
Member
Registered: 2021-01-13
Posts: 1

RX 570's memory clock running at maximum frequency all the time

I noticed that my GPU (RX 570) has it's memory running at full clock speed (1750 Mhz) all the time, also while idling. I'm not sure when this started, since I noticed this by mistake.

I have three monitors: 2x 1440p@60Hz and 1440p@144Hz. I'm running linux-zen 5.10.6.zen1-1 kernel. Currently my kernel parameters are "amd_iommu=on iommu=pt amdgpu.dc=1 amdgpu.dcfeaturemask=2"

I have tried to research the issue and found this https://www.phoronix.com/scan.php?page= … vRAM-Clock article, but it didn't solve my issue.

Things I have tried:
-running default arch ja lts kernels
-running 144Hz monitor at 60Hz
-running only 2x 1440p@60Hz monitors
-playing with kernel parameters like: amdgpu.dc and amdgpu.dcfeaturemask
-tried adding amdgpu.ppfeaturemask=0xffffffff kernel parameter to manually change the clock speed with corectrl
-booting live Archbang usb, in case if I have some incompatible custom configurations

Is there something that I'm missing or is there some combination of settings that I haven't tried? I would appreciate your help.

Last edited by Gogl (2021-01-13 17:29:25)

Offline

#2 2021-01-16 13:33:44

Bubla
Member
From: Rosice [CZ]
Registered: 2006-12-24
Posts: 26
Website

Re: RX 570's memory clock running at maximum frequency all the time

I have noticed fans spinning even when idle on my RX 5600 XT, which has not been happening before. radeontop suggests that memory and shader clocks are running (whatever that means) at 100% and 50% respectively, so I guess that it's the same issue that you have come across.
I have never used custom kernel parameters, and I even have only one monitor. So I am pretty sure that it is some kind of a regression.

As you have mentioned the frequency, I have changed my frequency (using Gnome Settings) from 59.95 to 59.96, and to my great surprise, the memory clock went down significantly.

Last edited by Bubla (2021-01-16 13:54:22)

Offline

#3 2021-02-15 21:56:20

candy_pebbles
Member
Registered: 2021-02-15
Posts: 7

Re: RX 570's memory clock running at maximum frequency all the time

Bumping the thread with a very similiar problem.

I have an RX 480 and a fairly new and clean install, but radeontop shows Memory Clock and Shader Clock on 100% most of the time (sometime the Shader Clock is around 50%, but it doesn't go lower than that from what I noticed), I switched to i3wm from xfce, because the whole DE felt really laggy. When I tried to play a game, I noticed some very subtle, but frequent microlags as well as audio delay (but I don't think that has anything to do with this thread). So far I tried: custom kernels (lts and zen) folowing the AMDGPU wiki page, except overclocking and enabling SI and CIK, installing all the necessary drivers, optimizing CPU and RAM in BIOS (I think that the bottleneck is the gpu configuration), various Xorg configurations.

Offline

#4 2021-02-16 11:34:41

Gosi
Member
From: Vienna, Austria
Registered: 2010-02-25
Posts: 85

Re: RX 570's memory clock running at maximum frequency all the time

candy_pebbles wrote:

Bumping the thread with a very similiar problem.

Don't do that if it is not the same problem.

I am pretty sure the original problem was a kernel driver regression and is already fixed. https://gitlab.freedesktop.org/drm/amd/-/issues/1407

Please create your own thread.

Offline

Board footer

Powered by FluxBB