You are not logged in.

#1 2021-01-25 01:57:17

Registered: 2021-01-13
Posts: 1

[SOLVED] Lutris not launching after upgrading to Lutris

Lutris failed to launch after upgrading to Lutris on kernel 5.4.92-1-lts.

Calling Lutris from the terminal returned this error:

$ lutris
Traceback (most recent call last):
  File "/usr/bin/lutris", line 52, in <module>
    from lutris.gui.application import Application  # pylint: disable=no-name-in-module
  File "/usr/lib/python3.9/site-packages/lutris/gui/", line 41, in <module>
    from lutris.gui.installerwindow import InstallerWindow
  File "/usr/lib/python3.9/site-packages/lutris/gui/", line 17, in <module>
    from lutris.installer import interpreter
  File "/usr/lib/python3.9/site-packages/lutris/installer/", line 14, in <module>
    from lutris.installer.installer import LutrisInstaller
  File "/usr/lib/python3.9/site-packages/lutris/installer/", line 16, in <module>
    from import get_services
  File "/usr/lib/python3.9/site-packages/lutris/services/", line 2, in <module>
    from import GOGService
  File "/usr/lib/python3.9/site-packages/lutris/services/", line 9, in <module>
    from lxml import etree
ModuleNotFoundError: No module named 'lxml'

I was able to solve this by simply installing the python-lxml package.

sudo pacman -Syu python-lxml


#2 2021-01-25 17:07:39

From: UK
Registered: 2013-03-23
Posts: 311

Re: [SOLVED] Lutris not launching after upgrading to Lutris

Same for me, thanks for the solution. Hopefully they should make it a dependency in the future big_smile


#3 2021-01-25 21:40:19

Registered: 2021-01-25
Posts: 1

Re: [SOLVED] Lutris not launching after upgrading to Lutris

Thank you. This worked for me as well.


Board footer

Powered by FluxBB