You are not logged in.

#1 2021-01-13 20:51:14

thomas17
Member
Registered: 2017-03-01
Posts: 21

[Solved] Biber Datetime error message

Which package do I have to downgrade, to remove the error?

$ biber
DateTime::TimeZone version 2.44 required--this is only version 2.35 at /usr/lib/perl5/5.32/vendor_perl/DateTime.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.32/vendor_perl/DateTime.pm line 17.
Compilation failed in require at /usr/share/perl5/vendor_perl/Biber/Date/Format.pm line 6.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Biber/Date/Format.pm line 6.
Compilation failed in require at /usr/share/perl5/vendor_perl/Biber/Constants.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Biber/Constants.pm line 10.
Compilation failed in require at /usr/share/perl5/vendor_perl/Biber/Internals.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Biber/Internals.pm line 7.
Compilation failed in require at /usr/share/perl5/core_perl/parent.pm line 16.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Biber.pm line 5.
Compilation failed in require at /usr/bin/vendor_perl/biber line 17.
BEGIN failed--compilation aborted at /usr/bin/vendor_perl/biber line 17.

Last edited by thomas17 (2021-01-13 21:56:39)

Offline

#2 2021-01-13 21:30:02

rullger
Member
From: UK
Registered: 2013-08-17
Posts: 4

Re: [Solved] Biber Datetime error message

perl-datetime 1.52 -> 1.53 caused the breakage

perl-datetime 1.53 requires perl-datetime-timezone 2.44

This has broken perl-finance-quote and prevents quotes being downloaded in gnucash.

Offline

#3 2021-01-13 21:53:45

thomas17
Member
Registered: 2017-03-01
Posts: 21

Re: [Solved] Biber Datetime error message

Thanks can you describe how you found the relevant packages? Just if some other packages break in the future. :-)

Offline

#4 2021-01-14 12:54:58

bjornp_
Member
Registered: 2020-12-31
Posts: 18

Re: [Solved] Biber Datetime error message

I have the same issue. This makes it currently impossible for me to compile LaTeX documents with references. Is there an easy way to fix this currently?


Fun fact: I actually have no clue what I'm doing

Offline

#5 2021-01-14 13:16:16

thomas17
Member
Registered: 2017-03-01
Posts: 21

Re: [Solved] Biber Datetime error message

sudo pacman -U /var/cache/pacman/pkg/perl-datetime-1.52-1-x86_64.pkg.tar.zst

Offline

#6 2021-01-16 18:38:23

carlosal1015
Member
Registered: 2021-01-16
Posts: 2

Re: [Solved] Biber Datetime error message

It works, thanks!

Offline

#7 2021-01-17 01:04:24

bboudreaux28
Member
Registered: 2021-01-17
Posts: 1

Re: [Solved] Biber Datetime error message

I am encountering this same problem. However I'm on a fresh install, and so I don't have perl-date-1.52-1.x86_64.pkg.tar.zst on my computer locally. Do you know another way I could downgrade this package?

Edit: Nevermind, I downgraded perl-datetime to 1.52-1 using the "downgrade" package from the AUR with the command

sudo downgrade 'perl-datetime=1.52-1'

Thanks

Last edited by bboudreaux28 (2021-01-17 01:18:02)

Offline

#8 2021-01-29 01:19:14

carlosal1015
Member
Registered: 2021-01-16
Posts: 2

Re: [Solved] Biber Datetime error message

The issue was solved with 'perl-datetime= 1.53-1'.

Offline

Board footer

Powered by FluxBB