You are not logged in.

#1 2021-02-07 21:50:24

Registered: 2011-04-09
Posts: 197

Recovery boot (from Jan 2021 ISO) hangs at uevents

Short story: My laptop had a hard time, with a shorted battery that cut off power and left the system unable to boot. I'm trying to boot it from a freshly downloaded ISO image on a flash drive to diagnose the problem, but the recovery boot process is stuck at "Triggering uevents".
Suggestions on how to get it to boot again welcome.

The details:

1. The laptop is an old Lenovo Thinkpad W520 that was working fine with an up to date Archlinux system until a few weeks ago. Then it went totally dead and I thought it could be the power supply, so I took the whole system to a repair shop to get a new one.   The laptop remained dead with a new power supply as well, and the repairmen suggested to remove the battery before trying again. That worked, and the system booted up. At that point, I shut it down from the terminal  with the standard shutdown command and went home.

2. Unfortunately, I must have been too fast to leave the shop or something, because once home the laptop did not boot up any longer, getting stuck on "loading initial ramdisk".

3. At this point, I thought I would need to boot from an emergency disk to carry out a proper diagnosis. So I prepared a flash drive from the latest ISO and tried booting from it.

4. No luck. The boot process hangs at "Triggering uevents"

Help greatly appreciated


Board footer

Powered by FluxBB