You are not logged in.

#1 2021-02-09 18:05:57

Archiamigo
Member
Registered: 2021-02-09
Posts: 4

[Solucionado] Problemas pulseaudio

Buenas, hasta hace unos días iba todo bien, ahora tengo estos fallos en el escritorio enlighenment.

En Emixer no muestra nada cuando se abre, todo vacío, no controles de volumen, no nada.

El terminal me devuelve estos fallos:

$ start-pulseaudio-x11
Error en la conexión: Conexión negada
pa_context_connect() falló: Conexión negada
$ systemctl --user status pulseaudio.service
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
     Active: failed (Result: core-dump) since Tue 2021-02-09 18:19:05 CET; 32min ago
TriggeredBy: ● pulseaudio.socket
    Process: 710 ExecStart=/usr/bin/pulseaudio --daemonize=no --log-target=journal (code=dumped, signal=ABRT)
   Main PID: 710 (code=dumped, signal=ABRT)

feb 09 18:19:05 Laptop systemd[567]: pulseaudio.service: Main process exited, code=dumped, status=6/ABRT
feb 09 18:19:05 Laptop systemd[567]: pulseaudio.service: Failed with result 'core-dump'.
feb 09 18:19:05 Laptop systemd[567]: Failed to start Sound Service.
feb 09 18:19:05 Laptop systemd[567]: pulseaudio.service: Scheduled restart job, restart counter is at 5.
feb 09 18:19:05 Laptop systemd[567]: Stopped Sound Service.
feb 09 18:19:05 Laptop systemd[567]: pulseaudio.service: Start request repeated too quickly.
feb 09 18:19:05 Laptop systemd[567]: pulseaudio.service: Failed with result 'core-dump'.
feb 09 18:19:05 Laptop systemd[567]: Failed to start Sound Service.

Si además me podéis recomendar un foro de arch solo en español, molaría.

Last edited by Archiamigo (2021-02-10 01:52:59)

Offline

#2 2021-02-09 18:14:50

Archiamigo
Member
Registered: 2021-02-09
Posts: 4

Re: [Solucionado] Problemas pulseaudio

He intentado reinstalar pulseaudio y me lanza varios errores.


$ sudo pacman -S pulseaudio
advertencia: pulseaudio-14.2-2 está actualizado -- reinstalándolo
resolviendo dependencias...
buscando conflictos entre paquetes...

Paquetes (1) pulseaudio-14.2-2

Tamaño total de la instalación:  6,21 MiB
Tamaño neto tras actualizar:    0,00 MiB

:: ¿Continuar con la instalación? [S/n]
(1/1) comprobando las claves del depósito                                                              [############################################################] 100%
(1/1) verificando la integridad de los paquetes                                                        [############################################################] 100%
(1/1) cargando los archivos de los paquetes                                                            [############################################################] 100%
(1/1) comprobando conflictos entre archivos                                                            [############################################################] 100%
(1/1) comprobando el espacio disponible en el disco                                                    [############################################################] 100%
advertencia: no se pudo obtener información del archivo usr/share/bash-completion/completions/parec
:: Procesando los cambios de los paquetes...
(1/1) reinstalando pulseaudio                                                                          [############################################################] 100%
advertencia: se han advertido errores mientras se extraía /usr/share/bash-completion/completions/parec (Could not stat /usr/share/bash-completion/completions/parec)
:: Ejecutando los «hooks» de posinstalación...
(1/3) Reloading device manager configuration...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Compiling GSettings XML schema files...
/usr/share/glib-2.0/schemas/org.gnome.dfeet.gschema.xml:1:1  Error en la línea 1, carácter 1: El documento estaba vacío o sólo contenía espacios en blanco.  Se ha ignorado este archivo completamente.

Todos los paquetes que tengo instalados son de repos oficiales, no tengo habilitado ningún otro repositorio, ni AUR ni nada.

el sistema está actualizado.

Offline

#3 2021-02-09 18:47:43

Archiamigo
Member
Registered: 2021-02-09
Posts: 4

Re: [Solucionado] Problemas pulseaudio

pongo los errores que me devuelve el terminal por si a alguien se le ocurre algo.

$ journalctl --boot --catalog --priority=err
Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal', 'wheel' can see all messages.
      Pass -q to turn off this notice.
-- Journal begins at Mon 2021-01-25 02:01:51 CET, ends at Tue 2021-02-09 19:29:14 CET. --
feb 09 18:19:01 Laptop pulseaudio[625]: Assertion 'pa_database_unset(u->database, &key) >= 0' failed at ../pulseaudio/src/modules/module-stream-restore.c:2236, function >
feb 09 18:19:02 Laptop systemd-coredump[640]: Process 625 (pulseaudio) of user 1000 dumped core.

                                              Stack trace of thread 625:
                                              #0  0x00007fb892ca7ef5 raise (libc.so.6 + 0x3cef5)
                                              #1  0x00007fb892c91862 abort (libc.so.6 + 0x26862)
                                              #2  0x00007fb88ddfe047 module_stream_restore_LTX_pa__init (module-stream-restore.so + 0xc047)
                                              #3  0x00007fb89307f416 pa_module_load (libpulsecore-14.2.so + 0x2d416)
                                              #4  0x00007fb89306eaef n/a (libpulsecore-14.2.so + 0x1caef)
                                              #5  0x00007fb8930752de pa_cli_command_execute_line_stateful (libpulsecore-14.2.so + 0x232de)
                                              #6  0x00007fb893075a74 pa_cli_command_execute_file_stream (libpulsecore-14.2.so + 0x23a74)
                                              #7  0x000055e7413296c4 main (pulseaudio + 0x86c4)
                                              #8  0x00007fb892c92b25 __libc_start_main (libc.so.6 + 0x27b25)
                                              #9  0x000055e74132a8de n/a (pulseaudio + 0x98de)
░░ Subject: Process 625 (pulseaudio) dumped core
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ Documentation: man:core(5)
░░
░░ Process 625 (pulseaudio) crashed and dumped core.
░░
░░ This usually indicates a programming error in the crashing program and
░░ should be reported to its vendor as a bug.
feb 09 18:19:02 Laptop systemd[567]: Failed to start Sound Service.
░░ Subject: A start job for unit UNIT has failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ A start job for unit UNIT has finished with a failure.
░░
░░ The job identifier is 38 and the job result is failed.
feb 09 18:19:02 Laptop pulseaudio[660]: Assertion 'pa_database_unset(u->database, &key) >= 0' failed at ../pulseaudio/src/modules/module-stream-restore.c:2236, function >
feb 09 18:19:03 Laptop systemd-coredump[669]: Process 660 (pulseaudio) of user 1000 dumped core.

                                              Stack trace of thread 660:
                                              #0  0x00007f6fac50bef5 raise (libc.so.6 + 0x3cef5)
                                              #1  0x00007f6fac4f5862 abort (libc.so.6 + 0x26862)
                                              #2  0x00007f6fa7662047 module_stream_restore_LTX_pa__init (module-stream-restore.so + 0xc047)
                                              #3  0x00007f6fac8e3416 pa_module_load (libpulsecore-14.2.so + 0x2d416)
                                              #4  0x00007f6fac8d2aef n/a (libpulsecore-14.2.so + 0x1caef)
                                              #5  0x00007f6fac8d92de pa_cli_command_execute_line_stateful (libpulsecore-14.2.so + 0x232de)
                                              #6  0x00007f6fac8d9a74 pa_cli_command_execute_file_stream (libpulsecore-14.2.so + 0x23a74)
                                              #7  0x000055fb676f56c4 main (pulseaudio + 0x86c4)
                                              #8  0x00007f6fac4f6b25 __libc_start_main (libc.so.6 + 0x27b25)

Offline

#4 2021-02-10 01:51:55

Archiamigo
Member
Registered: 2021-02-09
Posts: 4

Re: [Solucionado] Problemas pulseaudio

Solucionado, era por un dongle bluetooth que estaba intentando configurar. Encontré la solución en otro foro XD.

Por si a alguien le pasa otra vez y que no tenga que buscar mil horas como yo, la solución es borrar todo el contenido de ~/.config/pulse menos la cookie, al reiniciar vuelve a generar
todos los archivos de configuración y listo, a funcionar.

Ahora el tema es ver como pongo a funcionar el doongle bluetoot sin que me pete pulseaudio, pero eso ya es otro tema y abriré otro hilo.

Gracias anticipadas por ayudarme en el próximo hilo sobre lo del bluetooth XD.

Offline

Board footer

Powered by FluxBB