You are not logged in.

#1 2020-10-29 16:38:55

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

[SOLVED] tribler fails to start

==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading Tribler-v7.4.4.tar.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   643  100   643    0     0   1224      0 --:--:-- --:--:-- --:--:--  1222
100 3106k  100 3106k    0     0  1125k      0  0:00:02  0:00:02 --:--:-- 2483k
==> Validating source files with sha512sums...
    Tribler-v7.4.4.tar.xz ... Passed
==> Extracting sources...
  -> Extracting Tribler-v7.4.4.tar.xz with bsdtar
==> Starting prepare()...
sed: can't read src/tribler/tribler-core/tribler_core/version.py: No such file or directory
==> ERROR: A failure occurred in prepare().
    Aborting...
[admin@workstation tribler]$ makepkg -sri
==> Making package: tribler 7.4.4-4 (Thu Oct 29 18:33:10 2020)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found Tribler-v7.4.4.tar.xz
==> Validating source files with sha512sums...
    Tribler-v7.4.4.tar.xz ... Passed
==> Extracting sources...
  -> Extracting Tribler-v7.4.4.tar.xz with bsdtar
==> Starting prepare()...
sed: can't read src/tribler/tribler-core/tribler_core/version.py: No such file or directory
==> ERROR: A failure occurred in prepare().
    Aborting...

Last edited by RedArcher (2021-02-10 11:21:17)

Offline

#2 2020-10-29 17:32:20

metak
Member
Registered: 2009-09-27
Posts: 194

Re: [SOLVED] tribler fails to start

Change this in PKGBUILD

src/tribler/tribler-core/tribler_core/version.py

to

Tribler/Core/version.py

Offline

#3 2020-10-29 18:02:57

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

Re: [SOLVED] tribler fails to start

Thanks Bro!

Offline

#4 2020-12-07 19:00:19

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

Re: [SOLVED] tribler fails to start

Tribler does not work. I guess, it is due to recent extensive Python updates of ArchLinux. Can anyone relate?

Offline

#5 2020-12-07 19:08:45

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,173

Re: [SOLVED] tribler fails to start

Did you rebuild and reinstall tribler after the Python update?


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#6 2020-12-07 20:08:07

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

Re: [SOLVED] tribler fails to start

Yes (assuming I did it correctly)

Offline

#7 2020-12-07 22:42:25

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,936

Re: [SOLVED] tribler fails to start

RedArcher wrote:

Tribler does not work. I guess, it is due to recent extensive Python updates of ArchLinux. Can anyone relate?

In between your first sentence and your second sentence is blank whitespace. You were *supposed* to actually describe your problem there.

Currently, there's nothing to relate to. Please try again with more details.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#8 2021-01-02 19:16:03

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

Re: [SOLVED] tribler fails to start

The following error appears on Arch Linux, and, I guess, on Manjaro Linux, too.

Traceback (most recent call last):
  File "/opt/Tribler/tribler-gui/tribler_gui/tribler_request_manager.py", line 120, in <lambda>
    request.reply.finished.connect(lambda: request.on_finished(request))
  File "/opt/Tribler/tribler-gui/tribler_gui/tribler_request_manager.py", line 198, in on_finished
    json_result = json.loads(bytes(data), encoding='latin_1')
  File "/opt/Tribler/tribler-core/tribler_core/utilities/json_util.py", line 112, in loads
    return json.loads(s, *args, **kwargs)
  File "/usr/lib/python3.9/json/__init__.py", line 359, in loads
    return cls(**kw).decode(s)
TypeError: __init__() got an unexpected keyword argument 'encoding'

Edit: Please ignore this post, for the time being, as I didn't update my current installation (version 7.4.4) to 7.6.1 yet.

I've made the update.
It appears that it's a problem on the software side. Here's the error:

Traceback (most recent call last):
  File "/opt/Tribler/tribler-gui/tribler_gui/event_request_manager.py", line 130, in <lambda>
    self.reply.error.connect(lambda error: self.on_error(error, reschedule_on_err=reschedule_on_err))
  File "/opt/Tribler/tribler-gui/tribler_gui/event_request_manager.py", line 70, in on_error
    raise CoreConnectTimeoutError("Could not connect with the Tribler Core within 60 seconds")
tribler_gui.event_request_manager.CoreConnectTimeoutError: Could not connect with the Tribler Core within 60 seconds
[PID:23400] 2021-01-02 22:09:54,859 - ERROR <session:249> Session.unhandled_error_observer(): Unhandled exception occurred! schema2parameters() missing 1 required keyword-only argument: 'location'
--LONG TEXT--
Traceback (most recent call last):
  File "/opt/Tribler/run_tribler.py", line 84, in start_tribler
    await session.start()
  File "/opt/Tribler/tribler-core/tribler_core/session.py", line 289, in start
    await self.api_manager.start()
  File "/opt/Tribler/tribler-core/tribler_core/restapi/rest_manager.py", line 102, in start
    await self.runner.setup()
  File "/usr/lib/python3.9/site-packages/aiohttp/web_runner.py", line 275, in setup
    self._server = await self._make_server()
  File "/usr/lib/python3.9/site-packages/aiohttp/web_runner.py", line 375, in _make_server
    await self._app.startup()
  File "/usr/lib/python3.9/site-packages/aiohttp/web_app.py", line 416, in startup
    await self.on_startup.send(self)
  File "/usr/lib/python3.9/site-packages/aiohttp/signals.py", line 34, in send
    await receiver(*args, **kwargs)  # type: ignore
  File "/usr/lib/python3.9/site-packages/aiohttp_apispec/aiohttp_apispec.py", line 77, in doc_routes
    self._register(app_)
  File "/usr/lib/python3.9/site-packages/aiohttp_apispec/aiohttp_apispec.py", line 117, in _register
    self._register_route(route, method, view)
  File "/usr/lib/python3.9/site-packages/aiohttp_apispec/aiohttp_apispec.py", line 131, in _register_route
    self._update_paths(view.__apispec__, method, self.prefix + url_path)
  File "/usr/lib/python3.9/site-packages/aiohttp_apispec/aiohttp_apispec.py", line 153, in _update_paths
    raw_parameters = self.plugin.converter.schema2parameters(
TypeError: schema2parameters() missing 1 required keyword-only argument: 'location'

--CONTEXT--
{'message': 'Task exception was never retrieved', 'exception': TypeError("schema2parameters() missing 1 required keyword-only argument: 'location'"), 'future': <Task finished name='Task-1' coro=<start_tribler_core.<locals>.start_tribler() done, defined at /opt/Tribler/run_tribler.py:53> exception=TypeError("schema2parameters() missing 1 required keyword-only argument: 'location'")>}

Last edited by RedArcher (2021-01-02 20:21:31)

Offline

#9 2021-01-05 14:45:28

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

Re: [SOLVED] tribler fails to start

FS#69090 - [pysolfc] ModuleNotFoundError: No module named 'validate'
https://bugs.archlinux.org/task/69090#comment195253

polyzen wrote:

Comment by Daniel M. Capella (polyzen) - Friday, 25 December 2020, 11:53 GMT
A large number of packages were unusable due to this change, I went ahead and included the shim thanks to loqs' suggestion.

blacktav, this will be fixed once you've updated your packages.

Offline

#10 2021-01-05 15:01:39

loqs
Member
Registered: 2014-03-06
Posts: 13,005

Re: [SOLVED] tribler fails to start

What is the output of

pacman -Qi python-configobj

python-configobj 5.0.6.r110.g3e2f4cc-1 supplies the shim validate

Offline

#11 2021-01-06 07:18:13

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

Re: [SOLVED] tribler fails to start

$ pacman -Qi python-configobj
Name            : python-configobj
Version         : 5.0.6.r110.g3e2f4cc-1
Description     : Simple config file reader and writer
Architecture    : any
URL             : https://github.com/DiffSK/configobj
Licenses        : BSD
Groups          : None
Provides        : None
Depends On      : python-six
Optional Deps   : None
Required By     : tribler
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 339.94 KiB
Packager        : Daniel M. Capella <polyzen@archlinux.org>
Build Date      : Thu Dec 24 23:22:37 2020
Install Date    : Sat Dec 26 18:36:49 2020
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

Offline

#12 2021-01-06 20:04:52

loqs
Member
Registered: 2014-03-06
Posts: 13,005

Re: [SOLVED] tribler fails to start

Is this issue resolved?  What is the relevance of post #9?

Offline

#13 2021-01-07 05:22:37

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

Re: [SOLVED] tribler fails to start

loqs wrote:

Is this issue resolved?  What is the relevance of post #9?

Yes, it is still relevant.  The second part of post #9 is relevant.

Offline

#14 2021-01-07 09:12:50

loqs
Member
Registered: 2014-03-06
Posts: 13,005

Re: [SOLVED] tribler fails to start

RedArcher wrote:
loqs wrote:

Is this issue resolved?  What is the relevance of post #9?

Yes, it is still relevant.  The second part of post #9 is relevant.

Post #9

RedArcher wrote:

FS#69090 - [pysolfc] ModuleNotFoundError: No module named 'validate'
https://bugs.archlinux.org/task/69090#comment195253

polyzen wrote:

Comment by Daniel M. Capella (polyzen) - Friday, 25 December 2020, 11:53 GMT
A large number of packages were unusable due to this change, I went ahead and included the shim thanks to loqs' suggestion.

blacktav, this will be fixed once you've updated your packages.

Post #10

loqs wrote:

What is the output of

pacman -Qi python-configobj

python-configobj 5.0.6.r110.g3e2f4cc-1 supplies the shim validate

You posted in #11 python-configobj 5.0.6.r110.g3e2f4cc-1 the version supplying the shim is installed.
You have not posted any output showing a failure to find the validate module.
So I still do not understand how post #9 is relevant or if you have any remaining issue with tribler.

Offline

#15 2021-01-07 21:13:29

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

Re: [SOLVED] tribler fails to start

True, there's no mention of the 'validate' module.
I just believe (yes, just a belief) that it has to do with a recent python update of Arch.

What do you think I should do?

Offline

#16 2021-01-07 21:26:19

loqs
Member
Registered: 2014-03-06
Posts: 13,005

Re: [SOLVED] tribler fails to start

The traceback is still the same as the second of the two in post #8?
If so https://github.com/Tribler/tribler/issues/5814 / https://bugs.archlinux.org/task/68874

Last edited by loqs (2021-01-07 21:28:47)

Offline

#17 2021-01-08 07:14:14

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

Re: [SOLVED] tribler fails to start

Yes, it seems so.

Traceback (most recent call last):
  File "/opt/Tribler/tribler-gui/tribler_gui/event_request_manager.py", line 130, in <lambda>
    self.reply.error.connect(lambda error: self.on_error(error, reschedule_on_err=reschedule_on_err))
  File "/opt/Tribler/tribler-gui/tribler_gui/event_request_manager.py", line 70, in on_error
    raise CoreConnectTimeoutError("Could not connect with the Tribler Core within 60 seconds")
tribler_gui.event_request_manager.CoreConnectTimeoutError: Could not connect with the Tribler Core within 60 seconds
[PID:104993] 2021-01-08 09:12:34,178 - ERROR <session:249> Session.unhandled_error_observer(): Unhandled exception occurred! schema2parameters() missing 1 required keyword-only argument: 'location'
--LONG TEXT--
Traceback (most recent call last):
  File "/opt/Tribler/run_tribler.py", line 84, in start_tribler
    await session.start()
  File "/opt/Tribler/tribler-core/tribler_core/session.py", line 289, in start
    await self.api_manager.start()
  File "/opt/Tribler/tribler-core/tribler_core/restapi/rest_manager.py", line 102, in start
    await self.runner.setup()
  File "/usr/lib/python3.9/site-packages/aiohttp/web_runner.py", line 275, in setup
    self._server = await self._make_server()
  File "/usr/lib/python3.9/site-packages/aiohttp/web_runner.py", line 375, in _make_server
    await self._app.startup()
  File "/usr/lib/python3.9/site-packages/aiohttp/web_app.py", line 416, in startup
    await self.on_startup.send(self)
  File "/usr/lib/python3.9/site-packages/aiohttp/signals.py", line 34, in send
    await receiver(*args, **kwargs)  # type: ignore
  File "/usr/lib/python3.9/site-packages/aiohttp_apispec/aiohttp_apispec.py", line 77, in doc_routes
    self._register(app_)
  File "/usr/lib/python3.9/site-packages/aiohttp_apispec/aiohttp_apispec.py", line 117, in _register
    self._register_route(route, method, view)
  File "/usr/lib/python3.9/site-packages/aiohttp_apispec/aiohttp_apispec.py", line 131, in _register_route
    self._update_paths(view.__apispec__, method, self.prefix + url_path)
  File "/usr/lib/python3.9/site-packages/aiohttp_apispec/aiohttp_apispec.py", line 153, in _update_paths
    raw_parameters = self.plugin.converter.schema2parameters(
TypeError: schema2parameters() missing 1 required keyword-only argument: 'location'

--CONTEXT--
{'message': 'Task exception was never retrieved', 'exception': TypeError("schema2parameters() missing 1 required keyword-only argument: 'location'"), 'future': <Task finished name='Task-1' coro=<start_tribler_core.<locals>.start_tribler() done, defined at /opt/Tribler/run_tribler.py:53> exception=TypeError("schema2parameters() missing 1 required keyword-only argument: 'location'")>}

Offline

#18 2021-01-08 12:48:55

loqs
Member
Registered: 2014-03-06
Posts: 13,005

Re: [SOLVED] tribler fails to start

If you build python-apispec 3.3.2-1 for python 3.9 does that work?

$ git clone git://git.archlinux.org/svntogit/community.git --single-branch --branch "packages/python-apispec"
$ cd community/trunk/
$ git checkout e8552ed8128b8da52c8b7a6e02297164efbe978 # 3.3.2-1
$ makepkg -rsi

Offline

#19 2021-02-10 11:22:12

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 76

Re: [SOLVED] tribler fails to start

Yes

$ makepkg -rsi
==> Making package: python-apispec 3.3.2-1 (Wed Feb 10 13:21:10 2021)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...

Packages (16) python-apipkg-1.5-5  python-flex-6.14.1-5
              python-iniconfig-1.1.1-1  python-jsonpointer-2.0-7
              python-pbr-5.5.1-3  python-py-1.10.0-1  python-pytest-6.2.1-1
              python-rfc3987-1.3.8-6  python-semver-2.13.0-3
              python-strict-rfc3339-0.7-7  python-validate-email-1.3-7
              python-bottle-0.12.19-2  python-mock-3.0.5-5
              python-openapi-spec-validator-0.2.9-3  python-prance-0.20.0-1
              python-pytest-runner-5.2-3

Total Installed Size:  6.44 MiB

:: Proceed with installation? [Y/n] 
(16/16) checking keys in keyring                   [######################] 100%
(16/16) checking package integrity                 [######################] 100%
(16/16) loading package files                      [######################] 100%
(16/16) checking for file conflicts                [######################] 100%
(16/16) checking available disk space              [######################] 100%
:: Processing package changes...
( 1/16) installing python-iniconfig                [######################] 100%
( 2/16) installing python-apipkg                   [######################] 100%
( 3/16) installing python-py                       [######################] 100%
( 4/16) installing python-pytest                   [######################] 100%
( 5/16) installing python-pytest-runner            [######################] 100%
( 6/16) installing python-bottle                   [######################] 100%
( 7/16) installing python-validate-email           [######################] 100%
( 8/16) installing python-rfc3987                  [######################] 100%
( 9/16) installing python-strict-rfc3339           [######################] 100%
(10/16) installing python-jsonpointer              [######################] 100%
(11/16) installing python-flex                     [######################] 100%
(12/16) installing python-semver                   [######################] 100%
(13/16) installing python-prance                   [######################] 100%
(14/16) installing python-pbr                      [######################] 100%
(15/16) installing python-mock                     [######################] 100%
(16/16) installing python-openapi-spec-validator   [######################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Retrieving sources...
  -> Downloading python-apispec-3.3.2.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   131  100   131    0     0    464      0 --:--:-- --:--:-- --:--:--   464
100 62209    0 62209    0     0  10841      0 --:--:--  0:00:05 --:--:-- 12549
==> Validating source files with sha512sums...
    python-apispec-3.3.2.tar.gz ... Passed
==> Extracting sources...
  -> Extracting python-apispec-3.3.2.tar.gz with bsdtar
==> Starting build()...
running build
running build_py
creating build
creating build/lib
creating build/lib/apispec
copying src/apispec/plugin.py -> build/lib/apispec
copying src/apispec/__init__.py -> build/lib/apispec
copying src/apispec/utils.py -> build/lib/apispec
copying src/apispec/yaml_utils.py -> build/lib/apispec
copying src/apispec/exceptions.py -> build/lib/apispec
copying src/apispec/core.py -> build/lib/apispec
creating build/lib/apispec/ext
copying src/apispec/ext/__init__.py -> build/lib/apispec/ext
creating build/lib/apispec/ext/marshmallow
copying src/apispec/ext/marshmallow/field_converter.py -> build/lib/apispec/ext/marshmallow
copying src/apispec/ext/marshmallow/schema_resolver.py -> build/lib/apispec/ext/marshmallow
copying src/apispec/ext/marshmallow/openapi.py -> build/lib/apispec/ext/marshmallow
copying src/apispec/ext/marshmallow/__init__.py -> build/lib/apispec/ext/marshmallow
copying src/apispec/ext/marshmallow/common.py -> build/lib/apispec/ext/marshmallow
running egg_info
creating src/apispec.egg-info
writing src/apispec.egg-info/PKG-INFO
writing dependency_links to src/apispec.egg-info/dependency_links.txt
writing requirements to src/apispec.egg-info/requires.txt
writing top-level names to src/apispec.egg-info/top_level.txt
writing manifest file 'src/apispec.egg-info/SOURCES.txt'
reading manifest file 'src/apispec.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no previously-included files matching '*.pyc' found under directory 'docs'
warning: no previously-included files matching '*.pyo' found under directory 'docs'
warning: no previously-included files matching '*.pyc' found under directory 'tests'
warning: no previously-included files matching '*.pyo' found under directory 'tests'
no previously-included directories found matching 'docs/_build'
writing manifest file 'src/apispec.egg-info/SOURCES.txt'
==> Starting check()...
running pytest
running egg_info
writing src/apispec.egg-info/PKG-INFO
writing dependency_links to src/apispec.egg-info/dependency_links.txt
writing requirements to src/apispec.egg-info/requires.txt
writing top-level names to src/apispec.egg-info/top_level.txt
reading manifest file 'src/apispec.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no previously-included files matching '*.pyc' found under directory 'docs'
warning: no previously-included files matching '*.pyo' found under directory 'docs'
warning: no previously-included files matching '*.pyc' found under directory 'tests'
warning: no previously-included files matching '*.pyo' found under directory 'tests'
no previously-included directories found matching 'docs/_build'
writing manifest file 'src/apispec.egg-info/SOURCES.txt'
running build_ext
============================= test session starts ==============================
platform linux -- Python 3.9.1, pytest-6.2.1, py-1.10.0, pluggy-0.13.1
rootdir: /home/admin/PKGBUILD/community/trunk/src/apispec-3.3.2
plugins: Faker-5.6.2
collected 415 items                                                            

tests/test_core.py ..................................................... [ 12%]
.................................................                        [ 24%]
tests/test_ext_marshmallow.py .......................................... [ 34%]
...................................................                      [ 46%]
tests/test_ext_marshmallow_common.py ............                        [ 49%]
tests/test_ext_marshmallow_field.py .................................... [ 58%]
....................................................................     [ 74%]
tests/test_ext_marshmallow_openapi.py ..................ss.............. [ 83%]
.........................................................                [ 96%]
tests/test_utils.py ......                                               [ 98%]
tests/test_yaml_utils.py .......                                         [100%]

=============================== warnings summary ===============================
../../../../../../../usr/lib/python3.9/site-packages/marshmallow/fields.py:195: 7 warnings
tests/test_ext_marshmallow_field.py: 14 warnings
tests/test_ext_marshmallow_openapi.py: 19 warnings
  /usr/lib/python3.9/site-packages/marshmallow/fields.py:195: RemovedInMarshmallow4Warning: Passing field metadata as a keyword arg is deprecated. Use the explicit `metadata=...` argument instead.
    warnings.warn(

-- Docs: https://docs.pytest.org/en/stable/warnings.html
================= 413 passed, 2 skipped, 40 warnings in 1.22s ==================
==> Entering fakeroot environment...
==> Starting package()...
running install
running build
running build_py
running egg_info
writing src/apispec.egg-info/PKG-INFO
writing dependency_links to src/apispec.egg-info/dependency_links.txt
writing requirements to src/apispec.egg-info/requires.txt
writing top-level names to src/apispec.egg-info/top_level.txt
reading manifest file 'src/apispec.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no previously-included files matching '*.pyc' found under directory 'docs'
warning: no previously-included files matching '*.pyo' found under directory 'docs'
warning: no previously-included files matching '*.pyo' found under directory 'tests'
no previously-included directories found matching 'docs/_build'
writing manifest file 'src/apispec.egg-info/SOURCES.txt'
running install_lib
creating /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr
creating /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib
creating /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9
creating /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages
creating /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec
creating /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext
copying build/lib/apispec/ext/__init__.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext
creating /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow
copying build/lib/apispec/ext/marshmallow/field_converter.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow
copying build/lib/apispec/ext/marshmallow/schema_resolver.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow
copying build/lib/apispec/ext/marshmallow/openapi.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow
copying build/lib/apispec/ext/marshmallow/__init__.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow
copying build/lib/apispec/ext/marshmallow/common.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow
copying build/lib/apispec/plugin.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec
copying build/lib/apispec/__init__.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec
copying build/lib/apispec/utils.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec
copying build/lib/apispec/yaml_utils.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec
copying build/lib/apispec/exceptions.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec
copying build/lib/apispec/core.py -> /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/__init__.py to __init__.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow/field_converter.py to field_converter.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow/schema_resolver.py to schema_resolver.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow/openapi.py to openapi.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow/__init__.py to __init__.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/ext/marshmallow/common.py to common.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/plugin.py to plugin.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/__init__.py to __init__.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/utils.py to utils.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/yaml_utils.py to yaml_utils.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/exceptions.py to exceptions.cpython-39.pyc
byte-compiling /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec/core.py to core.cpython-39.pyc
writing byte-compilation script '/tmp/tmpfqjsj9ee.py'
/usr/bin/python /tmp/tmpfqjsj9ee.py
removing /tmp/tmpfqjsj9ee.py
running install_egg_info
Copying src/apispec.egg-info to /home/admin/PKGBUILD/community/trunk/pkg/python-apispec/usr/lib/python3.9/site-packages/apispec-3.3.2-py3.9.egg-info
running install_scripts
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "python-apispec"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: python-apispec 3.3.2-1 (Wed Feb 10 13:21:21 2021)
==> Removing installed dependencies...
checking dependencies...
:: python-apispec optionally requires python-prance: for validation
:: python-apispec optionally requires python-openapi-spec-validator: for validation
:: python-sentry_sdk optionally requires python-bottle: adds support for the Bottle Web Framework

Packages (16) python-apipkg-1.5-5  python-bottle-0.12.19-2
              python-flex-6.14.1-5  python-iniconfig-1.1.1-1
              python-jsonpointer-2.0-7  python-mock-3.0.5-5
              python-openapi-spec-validator-0.2.9-3  python-pbr-5.5.1-3
              python-prance-0.20.0-1  python-py-1.10.0-1  python-pytest-6.2.1-1
              python-pytest-runner-5.2-3  python-rfc3987-1.3.8-6
              python-semver-2.13.0-3  python-strict-rfc3339-0.7-7
              python-validate-email-1.3-7

Total Removed Size:  6.44 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
( 1/16) removing python-pytest-runner              [######################] 100%
( 2/16) removing python-pytest                     [######################] 100%
( 3/16) removing python-py                         [######################] 100%
( 4/16) removing python-prance                     [######################] 100%
( 5/16) removing python-semver                     [######################] 100%
( 6/16) removing python-openapi-spec-validator     [######################] 100%
( 7/16) removing python-mock                       [######################] 100%
( 8/16) removing python-pbr                        [######################] 100%
( 9/16) removing python-iniconfig                  [######################] 100%
(10/16) removing python-flex                       [######################] 100%
(11/16) removing python-validate-email             [######################] 100%
(12/16) removing python-strict-rfc3339             [######################] 100%
(13/16) removing python-rfc3987                    [######################] 100%
(14/16) removing python-jsonpointer                [######################] 100%
(15/16) removing python-bottle                     [######################] 100%
(16/16) removing python-apipkg                     [######################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Installing package python-apispec with pacman -U...
loading packages...
warning: downgrading package python-apispec (4.0.0-3 => 3.3.2-1)
resolving dependencies...
looking for conflicting packages...

Packages (1) python-apispec-3.3.2-1

Total Installed Size:  0.22 MiB
Net Upgrade Size:      0.01 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
:: Processing package changes...
(1/1) downgrading python-apispec                   [######################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...

Offline

Board footer

Powered by FluxBB