You are not logged in.

#1 2021-01-23 19:16:31

kumala
Member
Registered: 2016-03-11
Posts: 16

[solved] Lenovo X1 Carbon randomly boots to a black screen

I have suffered this issue since mid 2020 more or less. I had discussed it on the Arch IRC but no one seemed to know what could be wrong. Since it appeared after a system upgrade I thought I would wait for some new kernel upgrades and it would probably work again. But it's been months now and the problem is still the same.

Before I dive into the technical details, I would like to know if someone has had the same issue or if it could be something common that I have missed when searching the forum.

So the problem is that when I power on my Lenovo X1 Carbon (from 2016 if I recall correctly) with Arch installed on it since day one, the BIOS menu appears correctly, the boot loader asks what to boot, I chose Arch, and then the screen goes black and supposedly it should ask for the LUKS password, but nothing happens instead, just a black screen.

I did not change anything in the firmware settings, it happened after a system upgrade. I thought I would not be able to boot my system any more, but after shutting down by pressing the power button for a long time and then booting up again a few times, it randomly works as expected. I would say I need about 10 tries before it works.
It's really weird, I don't know what could be the root of this issue. I have tried to type my password blindly and see if something boots but nothing seems to be happening.

Any idea is welcome, thanks.

Last edited by kumala (2021-02-12 12:19:51)

Offline

#2 2021-02-12 12:19:03

kumala
Member
Registered: 2016-03-11
Posts: 16

Re: [solved] Lenovo X1 Carbon randomly boots to a black screen

I have solved this issue by updating the firmware of the laptop.

Offline

Board footer

Powered by FluxBB