You are not logged in.

#1 2021-02-18 13:27:14

dimischiavone
Member
From: Turin
Registered: 2019-09-13
Posts: 16

t495s amdgpu low performance

Hi, i've been using arch since 1 year on the thinkpad t495s with ryzen 7 3700u pro and the integrated amd apu (amd radeon vega 10) without any problems. Since the 5.10.x kernel series i've seen a decrease in performance of the graphics card. I play a few games (mainly League of legends and Wow Classic) with some occasional native steam game and i have always got consistently 60 or more fps on all the games with medium/low settings; whereas now i struggle to get more than 20 fps. I have noticed that the laptop can become sluggish at times so i guess that even the normal gui rendering has suffered some performance hit too. I found out that radeontop reports the "Memory Clock" always stuck at 100%, when this happens i discovered that watching a video on youtube lets the clock adjust dynamically again. For example: when i start the x session the memory clock is at 100% and if i run a game i get 20 fps. When i play a few seconds of a youtube video and then run the same game i can go up to 90-100 fps again instead. I can't seem to find the culprit of this issue...i tried downgrading mesa and the kernel but i get the same results. Just to let you know, the other last important thing that happened is a bios update from lenovo in december. I have also run the integrated Lenovo uefi hardware diagnostics tools to see if maybe there was any hardware fault, but it reported all tests as successfull.
I'm running the latest 5.10.16-arch1-1 kernel with kde plasma 5.21 and xorg 1.20.10-3.

Edit:
I have found that this issue is already being tracked here and i'm trying to downgrade linux-firmware to check if that solves the issue.
Edit 2:
Reverting linux-firmware to any build preceding december fixed the issue for me.

Last edited by dimischiavone (2021-02-18 16:20:35)

Offline

Board footer

Powered by FluxBB