You are not logged in.

#1 2021-02-21 05:42:20

omonk
Member
Registered: 2021-02-13
Posts: 5

KDE desktop environment cannot adjust the animation speed

As the title says. My KDE version is 5.21. I just adjusted a few desktop effects, but after I saved them, it seems that the animation speed became unadjustable, it is always at a faster speed. When I try to adjust the animation speed in "System Settings->Workspace->Workspace Behavior->General Behavior->Animation Speed", this setting is not valid. I only remember that I installed a desktop effect called "Rubberband Maximize Animation", and after I enabled it, the animation speed didn't work, but I don't know if this is the reason.

Here are my "qdbus org.kde.KWin /KWin supportInformation".

Version
=======
KWin version: 5.21.0
Qt Version: 5.15.2
Qt compile version: 5.15.2
XCB compile version: 1.14

Operation Mode: X11 only

Build Options
=============
KWIN_BUILD_DECORATIONS: yes
KWIN_BUILD_TABBOX: yes
KWIN_BUILD_ACTIVITIES: yes
HAVE_DRM: yes
HAVE_GBM: yes
HAVE_EGL_STREAMS: yes
HAVE_X11_XCB: yes
HAVE_EPOXY_GLX: yes
HAVE_WAYLAND_EGL: yes

X11
===
Vendor: The X.Org Foundation
Vendor Release: 12010000
Protocol Version/Revision: 11/0
SHAPE: yes; Version: 0x11
RANDR: yes; Version: 0x14
DAMAGE: yes; Version: 0x11
Composite: yes; Version: 0x4
RENDER: yes; Version: 0xb
XFIXES: yes; Version: 0x50
SYNC: yes; Version: 0x31
GLX: yes; Version: 0x0

Decoration
==========
Plugin: org.kde.breeze
Theme: 
Plugin recommends border size: None
Blur: 0
onAllDesktopsAvailable: false
alphaChannelSupported: true
closeOnDoubleClickOnMenu: false
decorationButtonsLeft: 
decorationButtonsRight: 3, 4, 5
borderSize: 0
gridUnit: 22
font: Noto Sans CJK SC,11,-1,5,57,0,0,0,0,0
smallSpacing: 5
largeSpacing: 22

Platform
==========
Name: KWin::X11StandalonePlatform

Cursor
======
themeName: breeze_cursors
themeSize: 48

Options
=======
focusPolicy: 0
xwaylandCrashPolicy: 
xwaylandMaxCrashCount: 3
nextFocusPrefersMouse: false
clickRaise: true
autoRaise: false
autoRaiseInterval: 0
delayFocusInterval: 0
shadeHover: false
shadeHoverInterval: 250
separateScreenFocus: false
placement: 4
focusPolicyIsReasonable: true
borderSnapZone: 10
windowSnapZone: 10
centerSnapZone: 0
snapOnlyWhenOverlapping: false
rollOverDesktops: true
focusStealingPreventionLevel: 1
operationTitlebarDblClick: 5000
operationMaxButtonLeftClick: 5000
operationMaxButtonMiddleClick: 5015
operationMaxButtonRightClick: 5014
commandActiveTitlebar1: 0
commandActiveTitlebar2: 28
commandActiveTitlebar3: 2
commandInactiveTitlebar1: 4
commandInactiveTitlebar2: 28
commandInactiveTitlebar3: 2
commandWindow1: 7
commandWindow2: 8
commandWindow3: 8
commandWindowWheel: 28
commandAll1: 10
commandAll2: 3
commandAll3: 14
keyCmdAllModKey: 16777250
showGeometryTip: false
condensedTitle: false
electricBorderMaximize: true
electricBorderTiling: true
electricBorderCornerRatio: 0.25
borderlessMaximizedWindows: false
killPingTimeout: 5000
hideUtilityWindowsForInactive: true
compositingMode: 1
useCompositing: true
hiddenPreviews: 1
glSmoothScale: 1
xrenderSmoothScale: false
glStrictBinding: true
glStrictBindingFollowsDriver: true
glCoreProfile: true
glPreferBufferSwap: 101
glPlatformInterface: 1
windowsBlockCompositing: true
latencyPolicy: 
renderTimeEstimator: 

Screen Edges
============
desktopSwitching: false
desktopSwitchingMovingClients: true
cursorPushBackDistance: 1x1
timeThreshold: 50
reActivateThreshold: 350
actionTopLeft: 0
actionTop: 0
actionTopRight: 0
actionRight: 0
actionBottomRight: 0
actionBottom: 0
actionBottomLeft: 0
actionLeft: 0

Screens
=======
Multi-Head: no
Active screen follows mouse:  yes
Number of Screens: 1

Screen 0:
---------
Name: eDP
Geometry: 0,0,2560x1600
Scale: 1
Refresh Rate: 60.001


Compositing
===========
Compositing is active
Compositing Type: OpenGL
OpenGL vendor string: AMD
OpenGL renderer string: AMD Radeon(TM) Vega 8 Graphics (RAVEN, DRM 3.40.0, 5.10.17-1-lts, LLVM 11.1.0)
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.3.4
OpenGL platform interface: GLX
OpenGL shading language version string: 4.60
Driver: RadeonSI
GPU class: Vega
OpenGL version: 4.6
GLSL version: 4.60
Mesa version: 20.3.4
X server version: 1.20.10
Linux kernel version: 5.10.17
Direct rendering: Requires strict binding: yes
GLSL shaders:  yes
Texture NPOT support:  yes
Virtual Machine:  no
OpenGL 2 Shaders are used

Loaded Effects:
---------------
kwin4_effect_translucency
kwin4_effect_frozenapp
kwin4_effect_sessionquit
kwin4_effect_dialogparent
kwin4_effect_login
kwin4_effect_windowaperture
kwin4_effect_fullscreen
kwin4_effect_logout
kwin4_effect_dimscreen
kwin4_effect_fadingpopups
kwin4_effect_maximize
kwin4_effect_morphingpopups
slidingpopups
kwin4_effect_yetanothermagiclamp
screenshot
glide
desktopgrid
colorpicker
resize
presentwindows
highlightwindow
contrast
startupfeedback
screenedge
kscreen

Currently Active Effects:
-------------------------
contrast

Effect Settings:
----------------
kwin4_effect_translucency:
pluginId: kwin4_effect_translucency
isActiveFullScreenEffect: false

kwin4_effect_frozenapp:
pluginId: kwin4_effect_frozenapp
isActiveFullScreenEffect: false

kwin4_effect_sessionquit:
pluginId: kwin4_effect_sessionquit
isActiveFullScreenEffect: false

kwin4_effect_dialogparent:
pluginId: kwin4_effect_dialogparent
isActiveFullScreenEffect: false

kwin4_effect_login:
pluginId: kwin4_effect_login
isActiveFullScreenEffect: false

kwin4_effect_windowaperture:
pluginId: kwin4_effect_windowaperture
isActiveFullScreenEffect: false

kwin4_effect_fullscreen:
pluginId: kwin4_effect_fullscreen
isActiveFullScreenEffect: false

kwin4_effect_logout:
pluginId: kwin4_effect_logout
isActiveFullScreenEffect: false

kwin4_effect_dimscreen:
pluginId: kwin4_effect_dimscreen
isActiveFullScreenEffect: false

kwin4_effect_fadingpopups:
pluginId: kwin4_effect_fadingpopups
isActiveFullScreenEffect: false

kwin4_effect_maximize:
pluginId: kwin4_effect_maximize
isActiveFullScreenEffect: false

kwin4_effect_morphingpopups:
pluginId: kwin4_effect_morphingpopups
isActiveFullScreenEffect: false

slidingpopups:
slideInDuration: 75
slideOutDuration: 125

kwin4_effect_yetanothermagiclamp:

screenshot:

glide:
duration: 80
inRotationEdge: 0
inRotationAngle: 3
inDistance: 30
inOpacity: 0.4
outRotationEdge: 2
outRotationAngle: 3
outDistance: 30
outOpacity: 0

desktopgrid:
zoomDuration: 150
border: 10
desktopNameAlignment: 0
layoutMode: 0
customLayoutRows: 2
usePresentWindows: true

colorpicker:

resize:
textureScale: false
outline: true

presentwindows:
layoutMode: 0
showCaptions: true
showIcons: true
doNotCloseWindows: false
ignoreMinimized: false
accuracy: 20
fillGaps: true
fadeDuration: 75
showPanel: false
leftButtonWindow: 1
rightButtonWindow: 2
middleButtonWindow: 0
leftButtonDesktop: 2
middleButtonDesktop: 0
rightButtonDesktop: 0

highlightwindow:

contrast:

startupfeedback:
type: 1

screenedge:

kscreen:


Loaded Plugins:
---------------
kwin5_plugin_krunner
kwin5_plugin_nightcolor

Available Plugins:
------------------
kwin5_plugin_colord
kwin5_plugin_krunner
kwin5_plugin_nightcolor 

Offline

#2 2021-02-25 14:59:22

omonk
Member
Registered: 2021-02-13
Posts: 5

Re: KDE desktop environment cannot adjust the animation speed

Solution: Go to  ~/.config/kwinrc   Delete the line about animationDurationFactor  Then the slider will work again.

Last edited by omonk (2021-02-25 14:59:47)

Offline

Board footer

Powered by FluxBB