You are not logged in.

#1 2021-02-23 20:14:53

Registered: 2021-02-23
Posts: 2

[SOLVED] System update stopped in post-transaction hooks.

Ran pacman -Syu and at 6/15 in the post-transaction hooks it hung.  Systemd was not working--"Transport endpoint is not connected--and being unable to restart it, I rebooted the machine.  I saw in other posts that rerunning "pacman -Syu" should continue but the message said there was nothing to do.  I assume those post-transaction hooks are important and should be run. 

How can I discover what they are and run them?  If this is answered somewhere else I apologize, I couldn't find it; just point me in the right direction please.

Here is the abbreviated screen output.  See … 0c18593b3c for the full output.

[root@dev log]# pacman -Syu
:: Synchronizing package databases...

  See for the rest

:: Running post-transaction hooks...
( 1/15) Creating system user accounts...
( 2/15) Updating journal message catalog...
( 3/15) Reloading system manager configuration...
Failed to reload daemon: Transport endpoint is not connected
error: command failed to execute correctly
( 4/15) Updating udev hardware database...
( 5/15) Applying kernel sysctl settings...
Not setting net/ipv4/conf/all/rp_filter (explicit setting exists).
Not setting net/ipv4/conf/default/rp_filter (explicit setting exists).
Not setting net/ipv4/conf/all/accept_source_route (explicit setting exists).
Not setting net/ipv4/conf/default/accept_source_route (explicit setting exists).
Not setting net/ipv4/conf/all/promote_secondaries (explicit setting exists).
Not setting net/ipv4/conf/default/promote_secondaries (explicit setting exists).
( 6/15) Creating temporary files...

Last edited by Jidn (2021-02-23 21:11:00)


#2 2021-02-23 20:36:52

Registered: 2014-03-06
Posts: 12,987

Re: [SOLVED] System update stopped in post-transaction hooks.

You need to explicity tell pacman to reinstall all the packages from the last update:

pacman -S archlinux-keyring audit bash ca-certificates-mozilla cairo cryptsetup curl device-mapper e2fsprogs filesystem findutils fzf gcc-libs gd gdbm geoip-database ghostscript git glib2 glibc gmp gnupg go gpgme graphviz grub harfbuzz hwids iana-etc icu iproute2 iptables kbd kmod krb5 lcms2 libarchive libassuan libcap libcups libedit libelf libgcrypt libgpg-error libldap libnftnl libpcap librsvg libtiff libusb libuv libwebp libx11 libxml2 libxt linux linux-api-headers linux-firmware mkinitcpio mkinitcpio-busybox msgpack-c nettle nginx-mainline npth openjpeg2 openssl pacman pacman-mirrorlist pam pango perl procps-ng psmisc python python-cffi python-msgpack python-packaging python-pip python-requests python-resolvelib python-setuptools python-urllib3 shared-mime-info sqlite sudo systemd systemd-libs systemd-sysvcompat tar tzdata util-linux util-linux-libs zstd

Last edited by loqs (2021-02-23 20:37:31)


#3 2021-02-23 21:07:50

Registered: 2021-02-23
Posts: 2

Re: [SOLVED] System update stopped in post-transaction hooks.

Thank you.  That did the trick.


Board footer

Powered by FluxBB