You are not logged in.

#1 2021-02-25 11:38:55

dimich
Member
From: Kharkiv, Ukraine
Registered: 2009-11-03
Posts: 58

Audio mixer settings is not properly restored on boot

I have audio source plugged to LineIn to listen to it with headphones. Everything worked fine on my old motherboard. After migrating to motherboard with Z390D chipset sound is not mixed from LineIn to headphones after boot. I see "Loopback Mixing" control is "Enabled" in amixer output as well as in /var/lib/alsa/asound.state. When i run

$ amixer -c 0 sset 'Loopback Mixing',0 Disabled
$ amixer -c 0 sset 'Loopback Mixing',0 Enabled

it starts to work as exected until reboot. The same after manual switching "Loopback Mixing" disable/enable in alsamixer.
Seems "Loopback Mixing" control is not properly restored by "alsactl restore" from alsa-restore.service: it's value is "Enabled" but actually it's disabled.

Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10) (8086:a348)

Any suggestions how to determine in what component the issue is: alsa-utils, libasound, kernel driver etc?

Offline

Board footer

Powered by FluxBB