You are not logged in.

#1 2021-02-25 14:08:42

Registered: 2021-02-25
Posts: 1

ACPI module on thinkpad T490 not working properly (5.11)

Hello, I'm running Arch on a Thinkpad T490 and I updated my packages this morning with the kernel update (5.10 -> 5.11). I rebooted a bit after that and the wifi interface was not showing up with

ip link


iw dev


I check dmesg for iwlwifi related messages and and I had the same issue as this topic. His solution didn't work for me so I looked it up and tried booting with acpi=off in my kernel parameters. It did restore my wifi interface but now I can't charge my laptop. I don't have a wired connection for the next couple of days so I can't really use this laptop without wifi. I could downgrade my kernel but I would like to know if anyone had this issue before and would have another solution.

Thanks in advance for your answers


#2 2021-03-28 16:34:20

Registered: 2015-03-08
Posts: 24

Re: ACPI module on thinkpad T490 not working properly (5.11)

Hey, I don't know if you fixed it since it's been a while, but I recall having a similar problem last month. Don't know if it's this exact problem but all of a sudden NetworkManager wouldn't see my wireless card, as if I had pressed the FN+Wireless radio toggle (but of course I had not). Even on Windows Dual-boot and Ubuntu Live USB it wouldn't work.

I fixed it by going in the bios, disabled the Wireless card completely, rebooted, and enabled it back again. All of a sudden was working fine.

Hope this helps someone!

The good thing about science is that it's true whether or not you believe in it.
    - Neil DeGrasse Tyson


Board footer

Powered by FluxBB