You are not logged in.

#1 2021-03-12 23:24:55

jbhall
Member
Registered: 2021-03-11
Posts: 18

[SOLVED] 5950x not showing proper clock speeds

Out of curiosity, I decided to GeekBench my new system. That's when I discovered that my clock speeds are WONKY to say the least... I can't seem to figure out how to diagnose the issue.

My system is dual boot. I've booted into Windows, and it reads the 5950x just fine, proper clock speeds and all.

In Arch Linux, however, my CPU min/max values are crazy.

GeekBench system info:

System Information
  Operating System              Arch Linux 5.11.2-arch1-1 x86_64
  Model                         Gigabyte Technology Co., Ltd. X570 AORUS
MASTER
  Motherboard                   Gigabyte Technology Co., Ltd. X570 AORUS
MASTER
  BIOS                          American Megatrends International, LLC. F33c

Processor Information
  Name                          AMD Ryzen 9 5950X
  Topology                      1 Processor, 16 Cores, 32 Threads
  Identifier                    AuthenticAMD Family 25 Model 33 Stepping 0
  Base Frequency                6.92 GHz
  L1 Instruction Cache          32.0 KB x 16
  L1 Data Cache                 32.0 KB x 16
  L2 Cache                      512 KB x 16
  L3 Cache                      32.0 MB x 2

Memory Information
  Size                          126 GB

lscpu result:

Architecture:                    x86_64
CPU op-mode(s):                  32-bit, 64-bit
Byte Order:                      Little Endian
Address sizes:                   48 bits physical, 48 bits virtual
CPU(s):                          32
On-line CPU(s) list:             0-31
Thread(s) per core:              2
Core(s) per socket:              16
Socket(s):                       1
NUMA node(s):                    1
Vendor ID:                       AuthenticAMD
CPU family:                      25
Model:                           33
Model name:                      AMD Ryzen 9 5950X 16-Core Processor
Stepping:                        0
Frequency boost:                 enabled
CPU MHz:                         6919.531
CPU max MHz:                     7228.3198
CPU min MHz:                     2200.0000
BogoMIPS:                        6803.63
Virtualization:                  AMD-V
L1d cache:                       512 KiB
L1i cache:                       512 KiB
L2 cache:                        8 MiB
L3 cache:                        64 MiB

And when I look under /proc/cpuinfo, it verifies that these are the speeds Arch Linux is reading. I'm so confused at this point.

Last edited by jbhall (2021-03-13 02:41:16)

Offline

#2 2021-03-12 23:28:58

jbhall
Member
Registered: 2021-03-11
Posts: 18

Re: [SOLVED] 5950x not showing proper clock speeds

Aha, I have finally happened upon this: https://www.youtube.com/watch?v=--2Xu9WIM1E

Offline

#3 2021-03-12 23:47:21

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,269
Website

Re: [SOLVED] 5950x not showing proper clock speeds

Didn't watch the video but wondering if a mainline kernel may have a fix?  Ie 5.12-rc2 https://aur.archlinux.org/packages/linux-mainline/


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#4 2021-03-13 00:04:22

loqs
Member
Registered: 2014-03-06
Posts: 13,664

Re: [SOLVED] 5950x not showing proper clock speeds

5.11.2-arch1-1
https://bugs.archlinux.org/task/69817 the fix is in 5.11.3+

Offline

#5 2021-03-13 02:39:55

jbhall
Member
Registered: 2021-03-11
Posts: 18

Re: [SOLVED] 5950x not showing proper clock speeds

Awesome! Thanks for that, y'all. Now I just gotta figure out how to update my kernel properly. I see this, https://archlinux.org/packages/core/x86_64/linux/, but when I pacman -Syu, it says everything is up to date.

Anyway, I'll get that figured out. Thanks!

Offline

#6 2021-03-13 03:00:35

jbhall
Member
Registered: 2021-03-11
Posts: 18

Re: [SOLVED] 5950x not showing proper clock speeds

Well, actually... I upgraded to 5.11.6, and it's still buggy.

~ → uname -r
5.11.6-arch1-1
~ → lscpu | grep MHz
CPU MHz:                         2200.000
CPU max MHz:                     7228.3198
CPU min MHz:                     2200.0000

I assume this is still related to the kernel, though, and they're still working on it.

Offline

#7 2021-03-13 08:10:05

loqs
Member
Registered: 2014-03-06
Posts: 13,664

Re: [SOLVED] 5950x not showing proper clock speeds

Can you please report to https://bugzilla.kernel.org/show_bug.cgi?id=211791 that you have applied the fix from https://bugzilla.kernel.org/show_bug.cgi?id=211305 and the issue is still present.

Offline

#8 2021-03-13 10:43:04

jbhall
Member
Registered: 2021-03-11
Posts: 18

Re: [SOLVED] 5950x not showing proper clock speeds

Done.

Offline

Board footer

Powered by FluxBB