You are not logged in.

#1 2020-08-12 09:29:20

icar
Member
Registered: 2020-07-31
Posts: 111

Asus ZenBook 14 UM431D | 2 out of 4 speakers working

Hello,
I've recently acquired this laptop and I installed Arch. There's one thing I'm not managing to make to work:

The front speakers (at each side of the laptop) do not work, only the two under it.

For reference, you can check the webpage and scroll down so you can see there are actually 4 speakers.
https://www.asus.com/Laptops/ASUS-ZenBook-14-UM431DA

I've already handled an issue that made the volume change not trigger any volume change by editing

/usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common

and added

[Element Master]
switch = mute
volume = 100

before the PCM settings block.

My system is running 5.7.12-arch1-1 and Gnome 3.36.4-1

and the output of lspci is

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Root Complex
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 IOMMU
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:01.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
00:01.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus A
00:08.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus B
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 61)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 5
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 6
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 7
01:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)
02:00.0 Non-Volatile memory controller: SK hynix BC501 NVMe Solid State Drive 512GB
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c1)
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
03:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) Platform Security Processor
03:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
03:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
03:00.5 Multimedia controller: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor
03:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
04:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 61)

Any tips? Should I try something else? Maybe I should wait for 5.8?

Edit: 5.8.1 did not solve this issue.

Last edited by icar (2020-08-15 10:37:51)

Online

#2 2020-09-25 08:50:03

g4rrucho
Member
Registered: 2016-04-16
Posts: 1

Re: Asus ZenBook 14 UM431D | 2 out of 4 speakers working

You and me buddy. The only thing that I've managed to do is to change the control of the sound. Meaning, instead of changing Master, now it only changes the PCM. I think that the 4 speakers work but whenever I plug any type of headphones/earphones via cable 3.5mm or bluetooth, the master is always lowered for some reason.

Offline

#3 2021-02-21 23:46:25

m4rc0.madrid
Member
Registered: 2021-02-21
Posts: 1

Re: Asus ZenBook 14 UM431D | 2 out of 4 speakers working

Hi

Sorry about revive the post, but i I'm getting crazy with this problem.

Did you found any solution or work around?

Thanks a lot!

Offline

#4 2021-02-21 23:56:33

icar
Member
Registered: 2020-07-31
Posts: 111

Re: Asus ZenBook 14 UM431D | 2 out of 4 speakers working

No, I've been tracking many sound related issues, bugzilla's kernel issues, etc... I don't know, even with hdaretask I've got nothing.

For info, the chip is an ALC294. You can see that is not supported by doing command `sudo alsactl init`

If you max the volume up, all speakers work correctly.

For the mic through the jack combo, I've not had any luck.

Last edited by icar (2021-02-21 23:58:09)

Online

#5 2021-03-30 10:33:15

icar
Member
Registered: 2020-07-31
Posts: 111

Re: Asus ZenBook 14 UM431D | 2 out of 4 speakers working

Update: I have been able to find someone who has the same model (with less RAM and a 3500U instead of a 3700U, but that most likely doesn't affect the sound system). I took pictures of what I could find about the pin configuration:

https://imgur.com/a/cHB7hJe

They don't match what's shown in HDArestask. Any ideas?

Online

Board footer

Powered by FluxBB